View Issue Details

IDProjectCategoryView StatusLast Update
0001836SOGoPackaging (RedHat)public2012-08-22 08:38
Reportercomputersalat Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.16 
Fixed in Version1.3.17 
Summary0001836: SOGo 64bit-portability-issue SOGoAppointmentObject.m:1981, 1983
Description

I'm packaging SOGo for openSUSE (build.opensuse.org) and running into this error:

E: SOGo 64bit-portability-issue SOGoAppointmentObject.m:1981, 1983

Additional Information

gcc SOGoAppointmentObject.m -c \
-MMD -MP -Wno-unused -DGNUSTEP -DGNUSTEP_BASE_LIBRARY=1 -DGNU_RUNTIME=1 -DGNUSTEP_BASE_LIBRARY=1 -D_REENTRANT -fPIC -Wall -DGSWARN -DGSDIAGNOSE -Wno-import -fmessage-length=0 -O2 -Wall -fstack-pro
tector -funwind-tables -fasynchronous-unwind-tables -fno-strict-aliasing -fgnu-runtime -fconstant-string-class=NSConstantString -I.. -I../.. -I../../SOPE -I../../SOPE/ -I. -I/home/abuild/GNUstep/Library/Headers
-I/usr/local/include -I/usr/include \
-o obj/Appointments.obj/SOGoAppointmentObject.m.o
SOGoAppointmentObject.m:1401:2: warning: #warning Make sure this is correct ..
SOGoAppointmentObject.m:1468:2: warning: #warning parseSingleFromSource is invoked far too many times: maybe we should use an additional ivar to store the new iCalendar
SOGoAppointmentObject.m: In function '-[SOGoAppointmentObject PUTAction:]':
SOGoAppointmentObject.m:1981: warning: passing argument 1 of 'setStatus:' makes pointer from integer without a cast
SOGoAppointmentObject.m:1983: warning: passing argument 1 of 'setStatus:' makes pointer from integer without a cast

TagsNo tags attached.

Activities

buzzdee

buzzdee

2012-06-12 04:00

reporter   ~0004043

I get this on OpenBSD amd64, using gcc 4.2.1:
cc SOGoAppointmentObject.m -c \
-MMD -MP -DGNUSTEP -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGNUSTEP_BASE_LIBRARY=1 -fno-strict-aliasing -pthread -fPIC -DDEBUG -fno-omit-frame-pointer -Wall -DGSWARN -DGSDIAGNOSE -Wno-import -O2 -pipe -g -fgnu-runtime -f
trampolines -fconstant-string-class=NSConstantString -I/home/ports/pobj/sogo-1.3.16/fake-amd64//usr/local/include/ObjectiveC2 -I.. -I../.. -I../../SOPE -I../../SOPE/ -I. -I/usr/local/include -I/sogo-1.3.16_writes_to_HOME/GNUstep/Library/Headers -I/
usr/local/include \
-o obj/Appointments.obj/SOGoAppointmentObject.m.o
SOGoAppointmentObject.m: In function '-[SOGoAppointmentObject _handleResourcesConflicts:forEvent:]':
SOGoAppointmentObject.m:517: warning: pointer type mismatch in conditional expression
SOGoAppointmentObject.m:1401:2: warning: #warning Make sure this is correct ..
SOGoAppointmentObject.m:1468:2: warning: #warning parseSingleFromSource is invoked far too many times: maybe we should use an additional ivar to store the new iCalendar
SOGoAppointmentObject.m: In function '-[SOGoAppointmentObject PUTAction:]':
SOGoAppointmentObject.m:1981: warning: passing argument 1 of 'setStatus:' makes pointer from integer without a cast
SOGoAppointmentObject.m:1983: warning: passing argument 1 of 'setStatus:' makes pointer from integer without a cast
SOGoAppointmentObject.m: In function '-[SOGoAppointmentObject _addOrUpdateEvent:forUID:owner:]':
SOGoAppointmentObject.m:178: warning: 'iCalString' may be used uninitialized in this function

response seems to be a WOResponse, and setStatus is supposed to take unsigned int, so I don't get why the warning tells that it makes a pointer from the integer.

computersalat

computersalat

2012-08-10 10:51

reporter   ~0004311

seem to fixed with 1.3.17

buzzdee

buzzdee

2012-08-13 03:09

reporter   ~0004319

yep, also for they are gone

Issue History

Date Modified Username Field Change
2012-06-11 08:33 computersalat New Issue
2012-06-12 04:00 buzzdee Note Added: 0004043
2012-08-10 10:51 computersalat Note Added: 0004311
2012-08-13 03:09 buzzdee Note Added: 0004319
2012-08-22 08:38 Christian Mack Status new => resolved
2012-08-22 08:38 Christian Mack Resolution open => fixed
2012-08-22 08:38 Christian Mack Fixed in Version => 1.3.17