View Issue Details

IDProjectCategoryView StatusLast Update
0001649SOGoBackend Calendarpublic2012-08-27 09:25
Reporterfschlich Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.12 
Target Version1.3.18Fixed in Version1.3.18 
Summary0001649: Calendar notification emails do not protect (quote) comma in contact name / From: line
Description

This is sogo 1.3.12c / current Debian package for squeeze.

This issue is related to 0001475, 0001436 and 0001399.

Our ldap address book source gives the display name as 'Surname, Firstname'. When I invite someone to an event, the email that is sent out by sogo contains the following header lines:

content-type: multipart/mixed; boundary="----=_=-_OpenGroupware_org_NGMime-3327-1330095875.912441-2------"
date: Fri, 24 Feb 2012 16:04:35 +0100
from: Surname, Firstname <surname@our.domain.invalid>
subject: Termineinladung: "Neuer Termin"
to: Florian Schlichting <florian.schlichting@our.domain.invalid>

While the lacking capitalization of the first letter of these headers is just unusual, the From: line fails to double-quote the sender name, thus (wrongly) specifying two addresses.

Correct and expected behaviour would be:

From: "Surname, Firstname" <surname@our.domain.invalid>

TagsNo tags attached.

Activities

fschlich

fschlich

2012-02-24 10:57

reporter   ~0003487

it's not visible in my example above, but when the contact that's invited to the event also comes from the same ldap source, the To: line is just as broken:

to: Schlichting,
"Florian" <florian.schlichting@our.domain.invalid>

dgp

dgp

2012-05-24 09:40

reporter   ~0003975

This is still an issue in 1.3.15a.

There seems to be quite some deep level break here as adding a comma to a name in the "Invite Attendees" window breaks the free/busy search. The bar goes pink "No free-busy information". Subsequently removing the comma doesn't fix it.

mra

mra

2012-05-26 02:33

reporter   ~0003977

It's similiar to 0001340

ludovic

ludovic

2012-08-27 09:25

administrator   ~0004380

http://mtn.inverse.ca/revision/diff/02a0c346903984d754efc6a1339191e14f2a9b9f/with/81e5a2cbed9325efd0e582da75adabe4e79cff9f

Issue History

Date Modified Username Field Change
2012-02-24 10:46 fschlich New Issue
2012-02-24 10:57 fschlich Note Added: 0003487
2012-05-24 09:40 dgp Note Added: 0003975
2012-05-25 07:38 ludovic Target Version => 1.3.16
2012-05-26 02:33 mra Note Added: 0003977
2012-05-29 15:59 ludovic Target Version 1.3.16 => 1.3.17
2012-07-16 08:44 ludovic Target Version 1.3.17 => 1.3.18
2012-08-27 09:25 ludovic Note Added: 0004380
2012-08-27 09:25 ludovic Status new => closed
2012-08-27 09:25 ludovic Resolution open => fixed
2012-08-27 09:25 ludovic Fixed in Version => 1.3.18