View Issue Details

IDProjectCategoryView StatusLast Update
0001225SOGoWeb Mailpublic2011-07-06 14:02
ReporterLadislav Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.3.8 
Summary0001225: Not possible to read Content-Transfer-Encoding: binary in web GUI
Description

I cannot read some emails in SOGo web interface that has this header:

MIME-Version: 1.0
Content-Transfer-Encoding: binary
Content-Type: multipart/mixed; boundary="_----------=_1300953631213090"
X-Mailer: MIME::Lite 3.020 (F2.74; B3.07; Q3.07)

In sogo.log there is this error:

2011-04-01 16:06:11.525 sogod[5592] encoding 'binary' unknown, returning nil data
Apr 01 16:06:11 sogod [5592]: [ERROR] UIxMailPartTextViewer got no text content: 1
sogo.valbek.cz - - [01/Apr/2011:16:06:11 GMT] "GET /SOGo/so/pasek@valbek.cz/Mail//0/folderINBOX/folderspr%C3%A1va-IT/24068/popupview HTTP/1.1" 200 61 79/0 0.099 18406 66% 4K

Additional Information

Source email:

Return-Path: <nex2@valbek.cz>
Delivered-To: pasek@valbek.cz
Received: from localhost (localhost.localdomain [127.0.0.1])
by mail.valbek.cz (Postfix) with ESMTP id 880441CF9385;
Wed, 30 Mar 2011 20:30:11 +0200 (CEST)
X-Virus-Scanned: amavisd-new at valbek.cz
Received: from mail.valbek.cz ([127.0.0.1])
by localhost (mail.valbek.cz [127.0.0.1]) (amavisd-new, port 10024)
with ESMTP id FSsOVm5F4oqO; Wed, 30 Mar 2011 20:30:11 +0200 (CEST)
Received: from nex2.valbek.cz (unknown [192.168.1.191])
by mail.valbek.cz (Postfix) with ESMTP id 452E71CF9368
for <it@valbek.cz>; Wed, 30 Mar 2011 20:30:11 +0200 (CEST)
MIME-Version: 1.0
Content-Transfer-Encoding: binary
Content-Type: multipart/mixed; boundary="_----------=_130150981193300"
X-Mailer: MIME::Lite 3.020 (F2.74; B3.07; Q3.07)
Date: Wed, 30 Mar 2011 20:30:11 +0200
Subject: [NMS Report] NOTICE: host nex2
To: it@valbek.cz
From: nex2@valbek.cz

This is a multi-part message in MIME format.

--_----------=_130150981193300
Content-Disposition: inline
Content-Length: 2484
Content-Transfer-Encoding: binary
Content-Type: text/plain

FAULT: **
FAULT: Appliance : nex2 (OS v3.0.4, NMS v3.0.4 (r8917))
FAULT: Machine SIG : 9BHG8AI9K
FAULT: Primary MAC :
FAULT: Time : Wed Mar 30 20:30:11 2011
FAULT: Trigger : services-check
FAULT: Fault Type : ALARM
FAULT: Fault ID : 25
FAULT: Fault Count : 1006
FAULT: Severity : NOTICE
FAULT: Description : Service auto-sync:data-002 went into maintenance state.
FAULT: : Corrective action applied: service state = online
FAULT: **

!
! For more detais on this trigger click on link below:
! http://:2000/data/runners?selected_runner=services-check
!

LOG: /var/svc/log/system-filesystem-zfs-auto-sync:data-002.log
LOG: ------------------------------------------------------------------------
LOG:
LOG: LICENSE WARNING: the appliance has outstanding license related alarm(s)
LOG: [ Mar 30 20:15:09 (zfs-auto-sync, 7462) from: root@nex1.valbek.cz:/data/LI34, to: localhost:/data, proto=zfs+netcat, marker=...caef ]
LOG: [ Mar 30 20:15:11 (zfs-auto-sync, 7462) auto-sync uses replic mode. For more information see '-R' switch for 'zfs send' command ]
LOG: [ Mar 30 20:15:12 (zfs-auto-sync, 7462) Error: failed to list marker 'aeba31ba0f04682394e589988c0acaef' at destination localhost/data/LI34 ]
LOG: [ Mar 30 20:15:12 (zfs-auto-sync, 7462) WARNING: Service's saved marker is might not actual. Trying to get real marker name ]
LOG: [ Mar 30 20:15:18 (zfs-auto-sync, 7462) Fatal Error: Could not find working marker for replication. Auto-sync will not continue ]
LOG: [ Mar 30 20:15:18 (zfs-auto-sync, 7462) Moving service svc:/system/filesystem/zfs/auto-sync:data-002 to maintenance mode. ]
LOG: [ Mar 30 20:15:18 Stopping for maintenance due to service_request. ]
LOG: [ Mar 30 20:15:18 Executing stop method ("/lib/svc/method/zfs-auto-sync stop"). ]
LOG:
LOG: LICENSE WARNING: the appliance has outstanding license related alarm(s)
LOG: [ Mar 30 20:15:26 Method "stop" exited with status 0. ]
LOG: [ Mar 30 20:15:26 Stopping for maintenance due to service_request. ]
LOG: [ Mar 30 20:30:05 Leaving maintenance because clear requested. ]
LOG: [ Mar 30 20:30:05 Enabled. ]
LOG: [ Mar 30 20:30:05 Executing start method ("/lib/svc/method/zfs-auto-sync start"). ]
LOG:
LOG: LICENSE WARNING: the appliance has outstanding license related alarm(s)
LOG: [ Mar 30 20:30:10 Method "start" exited with status 0. ]

--_----------=_130150981193300--

TagsNo tags attached.

Activities

ludovic

ludovic

2011-06-15 17:07

administrator   ~0002582

Please attach the real rfc822 version of the message.

westphal

westphal

2011-06-16 03:41

reporter   ~0002586

Same Problem here:

Small Test-Message (sent with sendmail -t):
----------------- cut here ---------------------
MIME-Version: 1.0
Content-Disposition: inline
Content-Transfer-Encoding: binary
Content-Type: text/plain; charset="ISO-8859-1"
X-Mailer: MIME::Lite 3.027 (F2.74; A1.77; B3.07; Q3.07)
Date: Wed, 15 Jun 2011 22:17:30 +0200
From: westphal@verit.de
To: westphal@verit.de
Subject: test binary encoding

test binary encoding
----------------- cut here ---------------------

When opening this message in SOGo web mailer (which I really like),
the body shown is empty.

sogo.log says:
2011-06-16 09:39:16.042 sogod[31016] encoding 'binary' unknown, returning nil data
Jun 16 09:39:16 sogod [31016]: [ERROR] UIxMailPartTextViewer got no text content: (nil)

We're using the rpm sogo-1.3.7a-1.el5 on CentOS 5.6.

2011-06-17 01:59

 

ludovic

ludovic

2011-07-06 14:02

administrator   ~0002668

Fixed with: http://mtn.inverse.ca/revision/diff/980bdf3533fa9e08756ddec4c168f1f2b3ef31d2/with/fe089deaf1b0181c06ece935c26c6677fc993265

Issue History

Date Modified Username Field Change
2011-04-01 10:11 Ladislav New Issue
2011-06-15 17:07 ludovic Note Added: 0002582
2011-06-16 03:41 westphal Note Added: 0002586
2011-06-17 01:59 Ladislav File Added: [NMS Report] NOTICE host nex2.eml
2011-07-06 14:02 ludovic Note Added: 0002668
2011-07-06 14:02 ludovic Status new => resolved
2011-07-06 14:02 ludovic Fixed in Version => 1.3.8
2011-07-06 14:02 ludovic Resolution open => fixed
2011-07-06 14:02 ludovic Assigned To => ludovic