View Issue Details

IDProjectCategoryView StatusLast Update
0001055SOGoWeb Calendarpublic2012-04-19 16:57
Reporterpocquet Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.4 
Fixed in Version1.3.15 
Summary0001055: Day events imported from .ics file are displayed on previous day
Description

I have a problem about all-day events exported in ics format from Webcalendar into SOGo. Both are in "Europe/Paris" timezone.
For example, I export an all day event on Monday 20th december, and import into SOGo. In SOGo, this event is displayed on Sunday 19th, because "End" is set to 19th whereas "Start" is set to 20th. "All day event" is checked correctly.
Have you an idea of what is going wrong ?
Thanks a lot in advance

Additional Information

BEGIN:VCALENDAR
X-WR-CALNAME;VALUE=TEXT:pocquet
PRODID:-//WebCalendar-ics-v1.2.1
VERSION:2.0
METHOD:PUBLISH
BEGIN:VEVENT
UID:-INTRANET-IRIT-FR-WEBCALENDAR-GENDET-0000008880
LAST-MODIFIED:20101201T094819Z
SUMMARY:Congé JCD\, LC\, CR (AM)\, BM
DESCRIPTION:JC Debelle\, L. Chauveau\, C. Rosa (AM)\, B Marchiset
CLASS:PUBLIC
STATUS:CONFIRMED
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=ACCEPTED;CN="Anne-Marie
Pocquet":MAILTO:pocquet@irit.fr
DTSTART;VALUE=DATE:20101220
DTSTAMP:20101214T162941Z
DTEND;VALUE=DATE:20101220
END:VEVENT
BEGIN:VEVENT
UID:-INTRANET-IRIT-FR-WEBCALENDAR-POCQUET-0000008996
LAST-MODIFIED:20101214T162356Z
SUMMARY:Test sogo
DESCRIPTION:Test sogo
CLASS:PUBLIC
STATUS:CONFIRMED
ATTENDEE;ROLE=CHAIR;PARTSTAT=ACCEPTED;CN="Anne-Marie
Pocquet":MAILTO:pocquet@irit.fr
DTSTART:20101220T140000Z
DTSTAMP:20101214T162941Z
DTEND:20101220T153000Z
END:VEVENT
BEGIN:VEVENT
UID:-INTRANET-IRIT-FR-WEBCALENDAR-POCQUET-0000008997
LAST-MODIFIED:20101214T162811Z
SUMMARY:Evénement sur la journée
DESCRIPTION:Evénement sur la journée
CLASS:PUBLIC
STATUS:CONFIRMED
ATTENDEE;ROLE=CHAIR;PARTSTAT=ACCEPTED;CN="Anne-Marie
Pocquet":MAILTO:pocquet@irit.fr
DTSTART;VALUE=DATE:20101220
DTSTAMP:20101214T162941Z
DTEND;VALUE=DATE:20101220
END:VEVENT
END:VCALENDAR

TagsNo tags attached.

Relationships

has duplicate 0001775 new Funambol SOGo Connector Full day events synced from Outlook and imported from K5N webcalendar show on wrong day 

Activities

2010-12-15 10:23

 

all_day_event.png (47,961 bytes)   
all_day_event.png (47,961 bytes)   
ludovic

ludovic

2010-12-16 10:13

administrator   ~0001950

Last edited: 2012-04-19 16:14

The DTSTART equals the DTEND :

DTSTART;VALUE=DATE:20101220
DTEND;VALUE=DATE:20101220

I think this is where the problem comes from. Try to change the DTEND in the file you want to import to:

DTEND;VALUE=DATE:20101221

We could eventually had a "hack" for this in SOGo.

ludovic

ludovic

2010-12-16 10:19

administrator   ~0001951

The ics is violating the iCalendar RFC:

3.8.2.2. Date-Time End
The value MUST be later in time than the value of the "DTSTART" property.

pocquet

pocquet

2011-01-03 09:13

reporter   ~0001991

Hello Ludovic,
Thanks a lot for your answer. I updated manually the DTEND as you suggested, and it works fine. The problem is that we intend to replace Webcalendar by SOGo in our institute (about 600 persons). It is important that the import into SOGo works fine directly without any update of the ics files.
Could it be possible, in SOGo, to take into account the problem of events with similar DTSTART and DTEND ?
Thanks in advance. Sincerely. Anne-Marie

ludovic

ludovic

2012-04-19 16:57

administrator   ~0003788

Fixed - http://mtn.inverse.ca/revision/diff/5af155533446328556c907456566939affd0ae8f/with/2684d8c1336cad3425d5075a447d817d5808948d

Issue History

Date Modified Username Field Change
2010-12-15 10:23 pocquet New Issue
2010-12-15 10:23 pocquet File Added: all_day_event.png
2010-12-16 10:13 ludovic Note Added: 0001950
2010-12-16 10:19 ludovic Note Added: 0001951
2011-01-03 09:13 pocquet Note Added: 0001991
2012-04-19 16:14 ludovic Note Edited: 0001950
2012-04-19 16:57 ludovic Note Added: 0003788
2012-04-19 16:57 ludovic Status new => resolved
2012-04-19 16:57 ludovic Fixed in Version => 1.3.15
2012-04-19 16:57 ludovic Resolution open => fixed
2012-04-19 16:57 ludovic Assigned To => ludovic
2012-04-19 16:57 ludovic Status resolved => closed
2012-04-20 03:26 Christian Mack Relationship added has duplicate 0001775