Relationship Graph

Relationship Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0002086SOGoWeb Mailpublic2012-11-18 13:19
Reportermats Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version2.0.2 
Fixed in Version2.0.2a 
Summary0002086: First character omitted from mail subject
Description

After upgrading to 2.0.2, in some mails the first character of the subject is omitted in the overview mail module as well as in the header section of the individual mail display.
Both internal mails (eg. SOGo event notifications) and external mails from remote senders are affected.

In the raw mail source, the subject header is displayed correctly.

Comparing some of the affected mails I have encountered so far, common features seem to be:

  • The affected mails are of content-type: multipart/...
  • The subject of the affected mails is in UTF8 coding (which we use throughout the organisation); mails where the subject is encoded (eg. in iso8859-1) display correctly.
Additional Information

First mentioned on the mailing-list: https://inverse.ca/sogo/lists/arc/users/2012-10/msg00473.html

Example header of an affected internal mail (first letter "A" is missing in the webmail window):

x-sogo-message-type: calendar:invitation-reply
content-type: multipart/mixed; boundary="----=_=-_OpenGroupware_org_NGMime-4441-1351516480.656072-7------"
MIME-Version: 1.0
date: Mon, 29 Oct 2012 14:14:40 +0100
from: xxxx
subject: Antwort auf Termineinladung: "Test"
to: xxxx
X-Virus-Checked: Checked by ClamAV on xxxx

------=_=-_OpenGroupware_org_NGMime-4441-1351516480.656072-7------
content-type: text/html; charset=utf-8

TagsNo tags attached.

Relationships

duplicate of 0002078 closed First char hidden on subjects in german (?) mail invitations 
related to 0002102 new Review and potentially re-integrate recent optimizations 

Activities

mats

mats

2012-10-30 18:17

reporter   ~0004754

May also be related to https://inverse.ca/sogo/lists/arc/users/2012-10/msg00524.html (Sogo does not show utf-8 eMails correctly)?

mra

mra

2012-10-30 19:49

reporter   ~0004755

This is the same like 0002078

ludovic

ludovic

2012-11-18 09:25

administrator   ~0004882

Please test again with 2.0.2a.

mats

mats

2012-11-18 12:58

reporter   ~0004899

Last edited: 2012-11-18 12:59

Tested in 2.0.2a; seems to be fixed indeed.

Issue History

Date Modified Username Field Change
2012-10-30 18:07 mats New Issue
2012-10-30 18:17 mats Note Added: 0004754
2012-10-30 19:49 mra Note Added: 0004755
2012-10-31 09:07 Christian Mack Relationship added duplicate of 0002078
2012-11-18 09:25 ludovic Note Added: 0004882
2012-11-18 09:25 ludovic Status new => feedback
2012-11-18 12:58 mats Note Added: 0004899
2012-11-18 12:59 mats Note Edited: 0004899
2012-11-18 13:18 ludovic Relationship added related to 0002102
2012-11-18 13:19 ludovic Status feedback => closed
2012-11-18 13:19 ludovic Resolution open => fixed
2012-11-18 13:19 ludovic Fixed in Version => 2.0.2a