Scalable OGo (SOGo)

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000432SOGoWeb Preferencespublic2010-02-16 05:492010-04-02 16:04
Reportertolivier 
Assigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Versiongit / nightly 
Target Version1.2.2Fixed in Version1.2.2 
Summary0000432: Sieve delete and upload script error
DescriptionSogo cannot delete and/or upload sieve script to Dovecot/ManageSieve.

conf sogo:
SOGoForwardEnabled = YES;
SOGoVacationEnabled = YES;

however,webmail sogo works fine with Dovecot.
Additional Informationsogo:

2010-02-16 10:12:25.390 sogod[9651] Scanner initialised with nil string
127.0.0.1 - - [16/Feb/2010:10:12:25 GMT] "GET /SOGo/so/usertest/preferences HTTP/1.1" 200 12673/0 0.070 49890 74% 248K
Feb 16 10:12:35 sogod [9651]: <0x092483A8[SOGoMailAccount]:usertest_A_localhost> WARNING: Could not delete Sieve script - continuing...: {RawResponse = "{ok = NO; }"; result = NO; }
Feb 16 10:12:35 sogod [9651]: [ERROR] <0x092483A8[SOGoMailAccount]:usertest_A_localhost> Could not upload Sieve script: {RawResponse = "{}"; result = NO; }
127.0.0.1 - - [16/Feb/2010:10:12:35 GMT] "POST /SOGo/so/baltest/preferences HTTP/1.1" 200 256/1494 0.059 - - 4K

Tags0000398
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of 0000398resolvedludovic defaultbc link not created in sieve directory when activating Vacation or Forward scripts 

-  Notes
(0000567)
tolivier (reporter)
2010-02-16 05:53

another test with an unknow command from sieve.

Feb 16 10:07:53 sogod [4166]: [ERROR] <0x094C19B0[SOGoMailAccount]:usertest_A_localhost> Could not upload Sieve script: {RawResponse = "{ok = NO; reason = \"Error in MANAGESIEVE command : Unknown command.\"; }"; result = NO; }
(0000576)
ludovic (administrator)
2010-02-16 08:52

Provide a session sniffed using tcpflow.

Also, on which port is your Sieve service running?
(0000578)
tolivier (reporter)
2010-02-16 09:51
edited on: 2010-02-16 09:52

Sieve listen on tcp/2000, sogo sieve file is create on the server but not active...

here is the trace by tcpflow
(111 = sogo, 88 = imap/sieve)

193.049.225.088.02000-193.049.225.111.58300: OK "Logged in."

193.049.225.088.02000-193.049.225.111.58300: OK "Logged in."

193.049.225.111.58300-193.049.225.088.02000: DELETESCRIPT "sogo"

193.049.225.111.58300-193.049.225.088.02000: DELETESCRIPT "sogo"

193.049.225.088.02000-193.049.225.111.58300: OK "Deletescript completed."

193.049.225.111.58300-193.049.225.088.02000:

193.049.225.088.02000-193.049.225.111.58300: OK "Deletescript completed."

193.049.225.111.58300-193.049.225.088.02000:

193.049.225.088.02000-193.049.225.111.58300: NO "Error in MANAGESIEVE command : Unknown command."

193.049.225.111.58300-193.049.225.088.02000: PUTSCRIPT "sogo" {425+}
require ["vacation"];
if allof ( not exists ["list-help", "list-unsubscribe", "list-subscribe", "list-owner", "list-post", "list-archive", "list-id", "Mailing-List"], not header :comparator "i;ascii-casemap" :is "Precedence" ["list", "bulk", "junk"], not header :comparator "i;ascii-casemap" :matches "To" "Multiple recipients of*" ) {vacation :days 7 :addresses ["user3@localhost"] text:
by admin
.
;
}


193.049.225.111.58300-193.049.225.088.02000:

193.049.225.088.02000-193.049.225.111.58300: OK "PUTSCRIPT completed."

193.049.225.088.02000-193.049.225.111.58300: NO "Error in MANAGESIEVE command : Unknown command."

193.049.225.088.02000-193.049.225.111.58300: NO "Error in MANAGESIEVE command : Unknown command."

193.049.225.111.58300-193.049.225.088.02000: PUTSCRIPT "sogo" {425+}
require ["vacation"];
if allof ( not exists ["list-help", "list-unsubscribe", "list-subscribe", "list-owner", "list-post", "list-archive", "list-id", "Mailing-List"], not header :comparator "i;ascii-casemap" :is "Precedence" ["list", "bulk", "junk"], not header :comparator "i;ascii-casemap" :matches "To" "Multiple recipients of*" ) {vacation :days 7 :addresses ["user3@localhost"] text:
by admin
.
;
}


193.049.225.111.58300-193.049.225.088.02000:

193.049.225.088.02000-193.049.225.111.58300: OK "PUTSCRIPT completed."

193.049.225.088.02000-193.049.225.111.58300: NO "Error in MANAGESIEVE command : Unknown command."

(0000712)
wsourdeau (viewer)
2010-03-11 16:52

Hi Olivier,


We have fixed another bug which looks a lot like this one (http://www.scalableogo.org/bugs/view.php?id=398 [^]), is it possible for you to try again with the next nightly builds of the sope49-mime package?
(0000723)
wsourdeau (viewer)
2010-03-12 16:41

Considered fixed. Please reopen if needed.
(0000773)
tolivier (reporter)
2010-03-22 09:51

Hi Wolfgang,

there is still the "NO .. unknown command" in dovecot-sieve.

sieve always answers "NO" to an empty command...

thanks

Thomas.
(0000789)
wsourdeau (viewer)
2010-03-24 14:36

I think I know what the problem is but still need to experiment with it. Stay tuned...
(0000862)
wsourdeau (viewer)
2010-04-02 16:04

Fixed in 9e9ae5751a1a008c8b1986bd933c97f02aa65760. Please try the next nightly builds.

- Issue History
Date Modified Username Field Change
2010-02-16 05:49 tolivier New Issue
2010-02-16 05:49 tolivier Tag Attached: 0000398
2010-02-16 05:53 tolivier Note Added: 0000567
2010-02-16 08:52 ludovic Note Added: 0000576
2010-02-16 09:51 tolivier Note Added: 0000578
2010-02-16 09:52 tolivier Note Edited: 0000578
2010-02-16 09:52 tolivier Note Edited: 0000578
2010-02-23 09:19 ludovic Target Version => 1.2.2
2010-03-11 16:52 wsourdeau Note Added: 0000712
2010-03-11 16:55 wsourdeau Fixed in Version => 1.2.2
2010-03-12 16:41 wsourdeau Note Added: 0000723
2010-03-12 16:41 wsourdeau Relationship added duplicate of 0000398
2010-03-12 16:41 wsourdeau Duplicate ID 0 => 398
2010-03-12 16:41 wsourdeau Status new => resolved
2010-03-12 16:41 wsourdeau Resolution open => fixed
2010-03-12 16:41 wsourdeau Assigned To => wsourdeau
2010-03-22 09:51 tolivier Note Added: 0000773
2010-03-22 09:51 tolivier Status resolved => feedback
2010-03-22 09:51 tolivier Resolution fixed => reopened
2010-03-24 14:36 wsourdeau Note Added: 0000789
2010-04-02 16:04 wsourdeau Note Added: 0000862
2010-04-02 16:04 wsourdeau Status feedback => resolved
2010-04-02 16:04 wsourdeau Resolution reopened => fixed
2010-04-02 16:04 wsourdeau Duplicate ID 398 => 0


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker