View Issue Details

IDProjectCategoryView StatusLast Update
0000997SOGoWeb Address Bookpublic2011-01-05 14:06
Reporteralessio Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.3 
Fixed in Version1.3.5 
Summary0000997: i can't delete address book
Description

I delete an address book, i see this in sogo.log

Nov 19 17:30:22 sogod [27580]: <<0x0A8A4940[SOGoContactGCSFolder]:6BBC-4CE6A300-5-662DAA80>>D fetched 0 records.
Nov 19 17:30:22 sogod [27580]: <<0x0A8A4940[SOGoContactGCSFolder]:6BBC-4CE6A300-5-662DAA80>>D fetched 0 records.
localhost - - [19/Nov/2010:17:30:22 GMT] "POST /SOGo/so/admin/Contacts/6BBC-4CE6A300-5-662DAA80/view?noframe=1&sort=c_cn&asc=true HTTP/1.1" 200 596/0 0.011 - - 0
localhost - - [19/Nov/2010:17:30:24 GMT] "POST /SOGo/so/admin/Contacts/6BBC-4CE6A480-7-662DAA80/delete HTTP/1.1" 404 208/0 0.007 - - 0

I can't, addressbook doesn't disappear. I make logout/login
I delete, address book is deleted. I see this in sogo.log

localhost - - [19/Nov/2010:17:31:21 GMT] "POST /SOGo/so/admin/Contacts/6BBC-4CE6A300-5-662DAA80/delete HTTP/1.1" 204 0/0 0.011 - - 0
Nov 19 17:31:21 sogod [27580]: <<0x09400890[SOGoContactGCSFolder]:personal>>D fetched 0 records.
Nov 19 17:31:21 sogod [27580]: <<0x09400890[SOGoContactGCSFolder]:personal>>D fetched 0 records.
localhost - - [19/Nov/2010:17:31:21 GMT] "POST /SOGo/so/admin/Contacts/personal/view?noframe=1&sort=c_cn&asc=true HTTP/1.1" 200 596/0 0.010 - - 0

Additional Information

If i want to delete another addressbook, it doesn't work

TagsNo tags attached.

Activities

alessio

alessio

2010-11-19 11:39

reporter   ~0001870

If i do login/logout i can delete another addressbook.

ludovic

ludovic

2010-11-19 11:44

administrator   ~0001871

Works for me, even on sogo-demo.inverse.ca.

Clear your browser's cache.

Marcel

Marcel

2011-01-05 06:03

reporter   ~0001995

I just had noticed the same problem and wanted to report it :-).

The following sequence is reproducible for me, even on sogo-demo:

• Go to Address Book
• Create two new address books and name them e.g., "abc" and "def" (this step is not necessary if you have two address books to spare)
• Delete one (e.g., "abc") and confirm the "Are you sure?" dialog (this works as expected)
• Delete a second address book (e.g., "def") and confirm the dialog
• The address book is still there (and it is not a display problem, as we will see later)
• Further attempts at deleting this or other address books will also fail silently
• Switch to another view (I used "Mail")
• Switch back to "Address Books" ("def" is still there)
• Now you can delete "def"
• But deleting another address book will fail silently unless you first switch the views again

So in summary, a single address book can always be deleted, but (without switching the view or a relogin), only one address book can be deleted

francis

francis

2011-01-05 14:06

administrator   ~0001999

Fixed in revision 87cdbdef6d83dbc434c03ced31452112ebb2df51

Issue History

Date Modified Username Field Change
2010-11-19 11:38 alessio New Issue
2010-11-19 11:39 alessio Note Added: 0001870
2010-11-19 11:44 ludovic Note Added: 0001871
2011-01-05 06:03 Marcel Note Added: 0001995
2011-01-05 14:06 francis Note Added: 0001999
2011-01-05 14:06 francis Status new => resolved
2011-01-05 14:06 francis Fixed in Version => 1.3.5
2011-01-05 14:06 francis Resolution open => fixed
2011-01-05 14:06 francis Assigned To => francis