View Issue Details

IDProjectCategoryView StatusLast Update
0000920SOGoWeb Mailpublic2010-11-02 15:03
Reportergienger Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.3 
Target Version1.3.4Fixed in Version1.3.4 
Summary0000920: "in-reply-to"-Header wrong
Description

The Message-ID in "In-Reply-To:" has to be set in <>.

Example:

Received: from bafoussam.rz.uni-konstanz.de ([134.34.240.37])
by unitis.rz.uni-konstanz.de with ESMTP; 22 Oct 2010 22:02:01 +0000
Received: by bafoussam.rz.uni-konstanz.de (Postfix, from userid 502)
id C4421156024B; Sat, 23 Oct 2010 00:02:00 +0200 (CEST)
in-reply-to: 4CC209F2.3020404@southbrain.com
to: "Pascal Gienger" <pascal@southbrain.com>
from: "Pascal Gienger" <pascal.gienger@uni-konstanz.de>
message-id: <7d63-4cc20a00-39-19a22740@145653377>
subject: =?utf-8?q?Re:Sch=C3=B6n:)?=
date: Sat, 23 Oct 2010 00:02:00 +0200
MIME-Version: 1.0
content-type: text/plain; charset="utf-8"
reply-to: "Pascal Gienger" <pascal.gienger@uni-konstanz.de>
User-Agent: SOGoMail 1.3.3
content-transfer-encoding: quoted-printable

It should be:

In-Reply-To: <4CC209F2.3020404@southbrain.com>

Is it a feature that some header line are written with all-lowercase-letters?

TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2010-10-29 16:40

viewer   ~0001669

Hi Pascal,

Yes. It's far easier that way because those headers are handled in lowercase internally. The fact that their are also output that way is not an issue since this is still rfc compliant.

ludovic

ludovic

2010-11-02 15:03

administrator   ~0001693

Fixed with :

http://mtn.inverse.ca/revision/diff/334ce1ea6611e00728006a3a82bb74de2055da15/with/a84d89083c5074c42f4091869e33b834834865dc

Issue History

Date Modified Username Field Change
2010-10-22 18:05 gienger New Issue
2010-10-29 16:39 wsourdeau Target Version => 1.3.4
2010-10-29 16:40 wsourdeau Note Added: 0001669
2010-11-01 16:38 ludovic Status new => assigned
2010-11-01 16:38 ludovic Assigned To => ludovic
2010-11-02 15:03 ludovic Note Added: 0001693
2010-11-02 15:03 ludovic Status assigned => resolved
2010-11-02 15:03 ludovic Fixed in Version => 1.3.4
2010-11-02 15:03 ludovic Resolution open => fixed