View Issue Details

IDProjectCategoryView StatusLast Update
0000916SOGoWeb Calendarpublic2011-03-15 13:05
Reportermettatu Assigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.2 
Fixed in Version1.3.6 
Summary0000916: Timezone problem with Exchange 2007 (mismatch with FLE Standard Time?)
Description

What happens:
Starting time is 1 hour later in Nokia (synchronized through Funambol) if the event has been accepted through SOGo web-interface webmail. If accepted from CalDAV-client (iCal), everything is correct.

Components:
CentOS 5.5
SOGo 1.3.2
Funambol 8.7 (same with 8.0 and 8.5)
funambol-sogo-1.0.8

Mac OS X 10.6.4
iCal 4.0.3

How to produce:

  • Our SOGo 1.3.2 is configured to be in "Europe / Helsinki" timezone, same zone as FLE Standard Time.
  • External sends calendar invitation (exchange.ics) from Exchange 2007 system, timezone in the ICS file is TZID:FLE Standard Time

Mismatch in the syncronization:
If the calendar entry is accepted from the SOGo interface using webmail-component:
1) It shows up correctly on the SOGo interface and iCal (caldav)
2) When syncronized through Funambol (8.7) to Nokia E71 it shows up 1 hour later in the Nokia phone

Correct syncronization:
If the calendar entry is accepted from iCal (caldav)
1) It shows up correctly in SOGo and iCal
2) It shows up correctly in Nokia phone syncronized through Funambol (8.7)

TagsNo tags attached.

Activities

2010-10-19 10:09

 

exchange.ics (1,696 bytes)   
BEGIN:VCALENDAR
METHOD:REQUEST
PRODID:Microsoft Exchange Server 2007
VERSION:2.0
BEGIN:VTIMEZONE
TZID:FLE Standard Time
BEGIN:STANDARD
DTSTART:16010101T040000
TZOFFSETFROM:+0300
TZOFFSETTO:+0200
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010101T030000
TZOFFSETFROM:+0200
TZOFFSETTO:+0300
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
ORGANIZER;CN=Lastname Firstname:MAILTO:Firstname.Lastname@userdomain.fi
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN=Firstname.lastn
 ame@sogocompany.fi:MAILTO:Firstname.Lastname@sogocompany.fi
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE;CN=SogoUserFirstname.Sog
 ogouserLastname@sogocompany.fi:MAILTO:SogoUserFirstname.SogoUserLastnamename@sogocompany.fi
DESCRIPTION;LANGUAGE=fi-FI:Milloin: 20. lokakuuta 2010 10:00-11:00 (GMT+02:
 00) Helsinki\, Kyiv\, Riga\, Sofia\, Tallinn\, Vilnius.\n\n*~*~*~*~*~*~*~*
 ~*~*\n\n\n\n
SUMMARY;LANGUAGE=fi-FI:Dis is a test
DTSTART;TZID=FLE Standard Time:20101020T100000
DTEND;TZID=FLE Standard Time:20101020T110000
UID:040000008200E00074C5B7101A82E0080000000010224337A36FCB01000000000000000
 01000000024112EB2D1081047B5AD87EA3EE97966
CLASS:PUBLIC
PRIORITY:5
DTSTAMP:20101019T123510Z
TRANSP:OPAQUE
STATUS:CONFIRMED
SEQUENCE:0
LOCATION;LANGUAGE=fi-FI:
X-MICROSOFT-CDO-APPT-SEQUENCE:0
X-MICROSOFT-CDO-OWNERAPPTID:-1326209062
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-ALLDAYEVENT:FALSE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INSTTYPE:0
BEGIN:VALARM
ACTION:DISPLAY
DESCRIPTION:REMINDER
TRIGGER;RELATED=START:-PT15M
END:VALARM
END:VEVENT
END:VCALENDAR
exchange.ics (1,696 bytes)   
mettatu

mettatu

2010-10-20 04:04

reporter   ~0001633

Mismatch in the synchronization:
If the calendar entry is accepted from Thunderbird using Lightning extension:
1) It shows up correctly on the SOGo interface and Lightning
2) When synchronized through Funambol (8.7) to Nokia E71 it shows up 1 hour later in the Nokia phone

Thunderbird: 3.1.5
Lightning.xpi: 1.0b2

sheck

sheck

2011-03-10 09:03

reporter   ~0002244

Last edited: 2011-03-10 09:04

With TZ "W. Europe Standard Time" the same. These are one hour late in the sogo calendar, but correctly shown in lightning.

The event was an invitation send from outlook 2007 (mac) and was accepted in the web interface from sogo.

Part of the invitation:
DTSTART;TZID=W. Europe Standard Time:20110311T130000
DTEND;TZID=W. Europe Standard Time:20110311T140000

Due to the mailing-list answer from Ludovic its a parsing bug for TZID that contains a space character.

SOGo 1.3.5a with integrator/connector/lightning.

wsourdeau

wsourdeau

2011-03-15 13:05

viewer   ~0002262

Fixed in a0b3d112eca99119d0e99fa3a948f74e17a73249

Issue History

Date Modified Username Field Change
2010-10-19 10:09 mettatu New Issue
2010-10-19 10:09 mettatu File Added: exchange.ics
2010-10-20 04:04 mettatu Note Added: 0001633
2011-03-10 09:03 sheck Note Added: 0002244
2011-03-10 09:05 sheck Note Edited: 0002244
2011-03-15 13:05 wsourdeau Note Added: 0002262
2011-03-15 13:05 wsourdeau Status new => resolved
2011-03-15 13:05 wsourdeau Fixed in Version => 1.3.6
2011-03-15 13:05 wsourdeau Resolution open => fixed
2011-03-15 13:05 wsourdeau Assigned To => wsourdeau