View Issue Details

IDProjectCategoryView StatusLast Update
0000914SOGoWeb Calendarpublic2010-10-18 16:36
Reporterbertails Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version1.3.2 
Summary0000914: Delete event
Description

Some of my users keep loosing important events when they use the web interface. I finally understood what was happening.

When they want to delete an event, they access the contextual menu with the right-click of the mouse and then delete the event. They assume that the event to be deleted is the one they clicked on, which happens not to be the case: the web interface does not make clear which events are selected and the pop-up does not provide this information either. So I see that kind of request:
[[
POST /SOGo/so/XXX/Calendar/11F5-4CBC5100-B-6BC72480/batchDelete?ids=11F5-4CBCA300-2F-6BC72480.ics/11F5-4CBCAA00-47-6BC72480.ics/11F5-4CBCAA80-4D-6BC72480.ics
]]

Here are my suggestions:

  • by default, a right-click on an event means that only this event is concerned
  • one can pick several events by using the Control-key and only this way
  • the pop-up for confirmation of the deletion should include the title of the event(s) to be deleted, just to be sure
TagsNo tags attached.

Relationships

duplicate of 0000854 resolvedfrancis Unstable delete option 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2010-10-18 16:14 bertails New Issue
2010-10-18 16:35 francis Relationship added duplicate of 0000854
2010-10-18 16:35 francis Status new => closed
2010-10-18 16:35 francis Resolution open => fixed
2010-10-18 16:35 francis Fixed in Version => 1.3.3
2010-10-18 16:36 francis Fixed in Version 1.3.3 =>