View Issue Details

IDProjectCategoryView StatusLast Update
0000876SOGoWeb Preferencespublic2010-10-08 12:14
Reporteresco Assigned Tofrancis  
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.2 
Target Version1.3.3Fixed in Version1.3.3 
Summary0000876: Apache Config
Description

Hi,

instead of the following entry in /etc/apache2/conf.d/SOGo.conf:
<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.jpg">
SetHandler default-handler
</LocationMatch>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.png">
SetHandler default-handler
</LocationMatch>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.gif">
SetHandler default-handler
</LocationMatch>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.css">
SetHandler default-handler
</LocationMatch>

<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.js">
SetHandler default-handler
</LocationMatch>

You could write this shorter config entry:
<LocationMatch "^/SOGo/so/ControlPanel/Products/.UI/Resources/.(jpg|png|gif|css|js)">
SetHandler default-handler
</LocationMatch>

TagsNo tags attached.

Activities

ludovic

ludovic

2010-10-07 21:05

administrator   ~0001563

We should also add retry=1 or retry=0 to the ProxyPass section. People with crashing sogod daemons get a miserable end-user experience when that happens since Apache will ignore all available workers for 60 seconds by default.

ludovic

ludovic

2010-10-07 21:24

administrator   ~0001564

And while we're at it, we should remove "interpolate".

francis

francis

2010-10-08 12:14

administrator   ~0001581

Fixed in revision 86a2fae210ddf9a8afe4fb41b434cdc9e3237eef.

Issue History

Date Modified Username Field Change
2010-10-01 08:06 esco New Issue
2010-10-07 10:11 francis Target Version => 1.3.3
2010-10-07 11:32 francis Status new => assigned
2010-10-07 11:32 francis Assigned To => francis
2010-10-07 21:05 ludovic Note Added: 0001563
2010-10-07 21:24 ludovic Note Added: 0001564
2010-10-08 12:14 francis Note Added: 0001581
2010-10-08 12:14 francis Status assigned => resolved
2010-10-08 12:14 francis Fixed in Version => 1.3.3
2010-10-08 12:14 francis Resolution open => fixed