View Issue Details

IDProjectCategoryView StatusLast Update
0000831SOGoWeb Mailpublic2010-10-11 08:03
Reporterketzaldev Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.3.3 
Summary0000831: When adding a new IMAP acount on the WEBUI, the CPU overload
Description

Hi,

When I added a new IMAP account on my subscriber, I saw my CPU going on the sky:

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
26524 sogo 20 0 23100 6256 1844 R 49.8 2.5 4:46.51 sogod
26526 sogo 20 0 32076 17m 8072 R 49.8 7.2 4:46.78 sogod

Is it because sogo is downloading all the mail from the IMAP?
So, I'm not able to do any action, I'll wait the CPU to go down..

Thanks
Ket

TagsNo tags attached.

Activities

ketzaldev

ketzaldev

2010-09-14 11:21

reporter   ~0001439

By the way, it's crashing, because then I cannot do any other actions with Sogo WebUI. I need to kill the processes and restart sogo.

wcronen

wcronen

2010-09-14 14:25

reporter   ~0001441

I added 2 accounts without any problems but they did contain only a few mails.

A colleague with many mails in a google account crashed the system.

ludovic

ludovic

2010-09-14 14:37

administrator   ~0001444

Do you see any exceptions in the sogod.log file?

ketzaldev

ketzaldev

2010-09-15 03:26

reporter   ~0001464

I did not see exeception:

I run some logs during the connexion to my account: Before logging, CPU is 1%, after this, there are two sogod processes with 49.x% CPU each.

Nothing appears on the log at that time (I made a tail to be sure)

Here is the log (I think errors related to local IMAP is not relevant here, cause I don't have local IMAP, the CPU issue appeared when I created the gmail IMAP account)

2010-09-15 09:05:11.392 sogod[27829] Note: Using UTF-8 as URL encoding in NGExtensions.
Sep 15 09:05:11 sogod: SOGo watchdog [27829]: <0x0x90a6fe8[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Sep 15 09:05:11 sogod: SOGo watchdog [27829]: <0x0x90a6fe8[SOGoCache]> Using host(s) 'localhost' as server(s)
2010-09-15 09:05:11.401 sogod[27829] Note(SoObject): SoDebugKeyLookup is enabled!
2010-09-15 09:05:11.402 sogod[27829] Note(SoObject): SoDebugBaseURL is enabled!
2010-09-15 09:05:11.402 sogod[27829] Note(SoObject): relative base URLs are enabled.
2010-09-15 09:05:11.423 sogod[27829] ERROR(-[NGBundleManager bundleWithPath:]): could not create bundle for path: '/usr/share/GNUstep/Libraries/gnustep-base/Versions/1.19/Resources/SSL.bundle'
2010-09-15 09:05:11.464 sogod[27829] WOCompoundElement: pool embedding is on.
2010-09-15 09:05:11.465 sogod[27829] WOCompoundElement: id logging is on.
2010-09-15 09:05:11.549 sogod[27829] WARNING(-[NSNull(misc) count]): called NSNull -count (returns 0) !!!
127.0.0.1 - - [15/Sep/2010:09:05:11 GMT] "GET /SOGo/ HTTP/1.1" 200 3848/0 0.234 10803 64% 2M
2010-09-15 09:05:23.428 sogod[27829] Scanner initialised with nil string
Sep 15 09:05:23 sogod: SOGo watchdog [27829]: SOGoRootPage successful login for user 'ketzaldev' - expire = -1 grace = -1
Sep 15 09:05:23 sogod: SOGo watchdog [27829]: [WARN] <0x0x8e9cd58[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
Sep 15 09:05:23 sogod: SOGo watchdog [27829]: [WARN] <0x0x8e9cd58[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
Sep 15 09:05:23 sogod: SOGo watchdog [27829]: [WARN] <0x0x8e9cd58[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
127.0.0.1 - - [15/Sep/2010:09:05:23 GMT] "POST /SOGo/connect HTTP/1.1" 200 27/43 0.096 - - 352K
127.0.0.1 - - [15/Sep/2010:09:05:23 GMT] "GET /SOGo/ketzaldev HTTP/1.1" 302 0/0 0.016 - - 8K
127.0.0.1 - - [15/Sep/2010:09:05:23 GMT] "GET /SOGo/ketzaldev/view HTTP/1.1" 302 0/0 0.114 - - 16K
127.0.0.1 - - [15/Sep/2010:09:05:23 GMT] "GET /SOGo/so/ketzaldev/Mail HTTP/1.1" 302 0/0 0.020 - - 0
Sep 15 09:05:24 sogod: SOGo watchdog [27829]: [ERROR] <0x0x9209f30[NGImap4ConnectionManager]> IMAP4 login failed:
host=localhost, user=ketzaldev, pwd=yes
url=imap://ketzaldev@localhost/INBOX/
base=(nil)
base-class=(nil))
= <0x0x92787b8[NGImap4Client]: login=ketzaldev(pwd) address=<0x0x92690a0[NGInternetSocketAddress]: host=localhost port=143>>
Sep 15 09:05:24 sogod: SOGo watchdog [27829]: <0x09268FF8[SOGoMailFolder]:folderINBOX> renewing imap4 password
Sep 15 09:05:24 sogod: SOGo watchdog [27829]: [ERROR] <0x0x9209f30[NGImap4ConnectionManager]> IMAP4 login failed:
host=localhost, user=ketzaldev, pwd=yes
url=imap://ketzaldev@localhost/INBOX/
base=(nil)
base-class=(nil))
= <0x0x925ca10[NGImap4Client]: login=ketzaldev(pwd) address=<0x0x925cac0[NGInternetSocketAddress]: host=localhost port=143>>
Sep 15 09:05:24 sogod: SOGo watchdog [27829]: [ERROR] <0x09268FF8[SOGoMailFolder]:folderINBOX> Could not connect IMAP4
Sep 15 09:05:24 sogod: SOGo watchdog [27829]: [ERROR] <0x0x9209f30[NGImap4ConnectionManager]> IMAP4 login failed:
host=localhost, user=ketzaldev, pwd=yes
url=imap://ketzaldev@localhost/
base=(nil)
base-class=(nil))
= <0x0x92635d8[NGImap4Client]: login=ketzaldev(pwd) address=<0x0x9263688[NGInternetSocketAddress]: host=localhost port=143>>
Sep 15 09:05:24 sogod: SOGo watchdog [27829]: <0x092714D8[SOGoMailAccount]:0> renewing imap4 password
Sep 15 09:05:24 sogod: SOGo watchdog [27829]: [ERROR] <0x0x9209f30[NGImap4ConnectionManager]> IMAP4 login failed:
host=localhost, user=ketzaldev, pwd=yes
url=imap://ketzaldev@localhost/
base=(nil)
base-class=(nil))
= <0x0x9266378[NGImap4Client]: login=ketzaldev(pwd) address=<0x0x9266590[NGInternetSocketAddress]: host=localhost port=143>>
Sep 15 09:05:24 sogod: SOGo watchdog [27829]: [ERROR] <0x092714D8[SOGoMailAccount]:0> Could not connect IMAP4
127.0.0.1 - - [15/Sep/2010:09:05:24 GMT] "GET /SOGo/so/ketzaldev/Mail/view HTTP/1.1" 200 6912/0 0.422 27091 74% 1M
2010-09-15 09:05:27.051 sogod[27829] ERROR: MySQL4 field is marked unsigned (unsupported): {columnName = c_folder_id; name = c_folder_id; }
127.0.0.1 - - [15/Sep/2010:09:05:27 GMT] "POST /SOGo/so/ketzaldev/Calendar/alarmslist?browserTime=1284534309 HTTP/1.1" 200 2/0 0.104 - - 104K
Sep 15 09:05:27 sogod: SOGo watchdog [27829]: [ERROR] <0x0x9209f30[NGImap4ConnectionManager]> IMAP4 login failed:
host=localhost, user=ketzaldev, pwd=yes
url=imap://ketzaldev@localhost/
base=(nil)
base-class=(nil))
= <0x0x91977b0[NGImap4Client]: login=ketzaldev(pwd) address=<0x0x915a5e0[NGInternetSocketAddress]: host=localhost port=143>>
Sep 15 09:05:27 sogod: SOGo watchdog [27829]: <0x0919F2D0[SOGoMailAccount]:0> renewing imap4 password
Sep 15 09:05:27 sogod: SOGo watchdog [27829]: [ERROR] <0x0x9209f30[NGImap4ConnectionManager]> IMAP4 login failed:
host=localhost, user=ketzaldev, pwd=yes
url=imap://ketzaldev@localhost/
base=(nil)
base-class=(nil))
= <0x0x91a1d58[NGImap4Client]: login=ketzaldev(pwd) address=<0x0x8e06a08[NGInternetSocketAddress]: host=localhost port=143>>
Sep 15 09:05:27 sogod: SOGo watchdog [27829]: [ERROR] <0x0919F2D0[SOGoMailAccount]:0> Could not connect IMAP4
127.0.0.1 - - [15/Sep/2010:09:05:27 GMT] "POST /SOGo/so/ketzaldev/Mail/0/mailboxes HTTP/1.1" 200 17/0 0.079 - - 8K
2010-09-15 09:05:28.280 sogod[27829] Note(NGImap4Connection): using '/' as the IMAP4 folder separator.
127.0.0.1 - - [15/Sep/2010:09:05:29 GMT] "POST /SOGo/so/ketzaldev/Mail/1/mailboxes HTTP/1.1" 200 1168/0 2.136 - - 912K
2010-09-15 09:05:30.731 sogod[27829] Note: using 'UCS-2LE' on Linux.
Sep 15 09:15:29 sogod: SOGo watchdog [27826]: [WARN] <0x0x8ea9bc0[WOWatchDogChild]> safety belt -- sending KILL signal to pid 27829
Sep 15 09:15:29 sogod: SOGo watchdog [27826]: <0x0x8ea9bc0[WOWatchDogChild]> child 27829 exited
Sep 15 09:15:29 sogod: SOGo watchdog [27826]: <0x0x8ea9bc0[WOWatchDogChild]> (terminated due to signal 9)
Sep 15 09:15:29 sogod: SOGo watchdog [27826]: <0x0x8e8e520[WOWatchDog]> child spawned with pid 28110
Sep 15 09:15:30 sogod: SOGo watchdog [28110]: <0x0x8fe4040[SOGoProductLoader]> SOGo products loaded from '/usr/lib/GNUstep/SOGo':
Sep 15 09:15:30 sogod: SOGo watchdog [28110]: <0x0x8fe4040[SOGoProductLoader]> MainUI.SOGo, Appointments.SOGo, Mailer.SOGo, CommonUI.SOGo, MailerUI.SOGo, SchedulerUI.SOGo, Contacts.SOGo, AdministrationUI.SOGo, MailPartViewers.SOGo, ContactsUI.SOGo, PreferencesUI.SOGo
Sep 15 09:15:30 sogod: SOGo watchdog [28110]: |SOGo| version 1.3.0 (build @vizzini.inverse.ca 201009121112) -- starting
Sep 15 09:15:30 sogod: SOGo watchdog [28110]: |SOGo| vmem size check enabled: shutting down app when vmem > 384 MB
2010-09-15 09:15:30.489 sogod[28110] Note: Using UTF-8 as URL encoding in NGExtensions.
Sep 15 09:15:30 sogod: SOGo watchdog [28110]: <0x0x8e20530[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Sep 15 09:15:30 sogod: SOGo watchdog [28110]: <0x0x8e20530[SOGoCache]> Using host(s) 'localhost' as server(s)
2010-09-15 09:15:30.510 sogod[28110] Scanner initialised with nil string
2010-09-15 09:15:30.524 sogod[28110] Note(SoObject): SoDebugKeyLookup is enabled!
2010-09-15 09:15:30.524 sogod[28110] Note(SoObject): SoDebugBaseURL is enabled!
2010-09-15 09:15:30.524 sogod[28110] Note(SoObject): relative base URLs are enabled.
2010-09-15 09:15:31.664 sogod[28110] Note(NGImap4Connection): using '/' as the IMAP4 folder separator.
<0x0x902d810[WOHttpTransaction]> client disconnected during delivery of response for <WORequest[0x0x9055c20]: method=POST uri=/SOGo/so/ketzaldev/Mail//1/folderINBOX/unseenCount app=SOGo rqKey=so rqPath=ketzaldev/Mail//1/folderINBOX/unseenCount> (len=13): the socket was shutdown
127.0.0.1 - - [15/Sep/2010:09:15:32 GMT] "POST /SOGo/so/ketzaldev/Mail//1/folderINBOX/unseenCount HTTP/1.1" 200 13/0 2.454 - - 2M
2010-09-15 09:15:32.984 sogod[28110] ERROR(-[NGBundleManager bundleWithPath:]): could not create bundle for path: '/usr/share/GNUstep/Libraries/gnustep-base/Versions/1.19/Resources/SSL.bundle'
2010-09-15 09:15:33.111 sogod[28110] WOCompoundElement: pool embedding is on.
2010-09-15 09:15:33.111 sogod[28110] WOCompoundElement: id logging is on.
<0x0x903cfd0[WOHttpTransaction]> client disconnected during delivery of response for <WORequest[0x0x8ff4d80]: method=POST uri=/SOGo/so/ketzaldev/Mail/foldersState app=SOGo rqKey=so rqPath=ketzaldev/Mail/foldersState> (len=0): the socket was shutdown
127.0.0.1 - - [15/Sep/2010:09:15:33 GMT] "POST /SOGo/so/ketzaldev/Mail/foldersState HTTP/1.1" 200 0/0 0.350 - - 1M
<0x0x920c228[WOHttpTransaction]> client disconnected during delivery of response for <WORequest[0x0x914cee0]: method=POST uri=/SOGo/so/ketzaldev/Mail//1/folderINBOX/unseenCount app=SOGo rqKey=so rqPath=ketzaldev/Mail//1/folderINBOX/unseenCount> (len=13): the socket was shutdown
127.0.0.1 - - [15/Sep/2010:09:15:33 GMT] "POST /SOGo/so/ketzaldev/Mail//1/folderINBOX/unseenCount HTTP/1.1" 200 13/0 0.363 - - 12K
2010-09-15 09:15:34.193 sogod[28110] Note: using 'UCS-2LE' on Linux.

ludovic

ludovic

2010-09-15 10:11

administrator   ~0001468

Last edited: 2010-09-15 10:27

There's seem to be a problem with GMail IMAP accounts...

Over openssl s_client, after the LOGIN, whenever I issue a simple "SELECT INBOX", it freezes while it works from Thunderbird.

It works when specifying -crlf with s_client and SOPE really sends commands ending with \r\n.

ludovic

ludovic

2010-09-15 10:38

administrator   ~0001469

Last edited: 2010-09-15 10:38

Could be due to large IMAP folders on GMail because it works with small ones.

SOPE sends a large UID FETCH which might get truncated by GMail...

ketzaldev

ketzaldev

2010-09-15 11:09

reporter   ~0001471

So, is there a way to fix it?

It works when specifying -crlf with s_client and SOPE really sends commands ending with \r\n ->> What do you mean by this?

"Could be due to large IMAP folders on GMail because it works with small ones." ->> There are only 10 messages on my inbox.

Does Sogo download the Entire content of mails or does it just read the mails on the IMAP server?

Thanks
Ket

ludovic

ludovic

2010-10-11 08:03

administrator   ~0001592

Should be fixed with http://mtn.inverse.ca/revision/diff/294283259afe17fbd3d6a8fcecdd0e385910a860/with/c97680ec76b8116f6a89a6fbfdd96aafe8765a7f

Issue History

Date Modified Username Field Change
2010-09-14 04:46 ketzaldev New Issue
2010-09-14 11:21 ketzaldev Note Added: 0001439
2010-09-14 14:25 wcronen Note Added: 0001441
2010-09-14 14:37 ludovic Note Added: 0001444
2010-09-15 03:26 ketzaldev Note Added: 0001464
2010-09-15 10:11 ludovic Note Added: 0001468
2010-09-15 10:27 ludovic Note Edited: 0001468
2010-09-15 10:38 ludovic Note Added: 0001469
2010-09-15 10:38 ludovic Note Edited: 0001469
2010-09-15 11:09 ketzaldev Note Added: 0001471
2010-10-11 08:03 ludovic Note Added: 0001592
2010-10-11 08:03 ludovic Status new => resolved
2010-10-11 08:03 ludovic Fixed in Version => 1.3.3
2010-10-11 08:03 ludovic Resolution open => fixed
2010-10-11 08:03 ludovic Assigned To => ludovic