View Issue Details

IDProjectCategoryView StatusLast Update
0000078SOGoWeb Calendarpublic2010-01-11 13:45
Reporterfrancis Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.2.0 
Summary0000078: Read-only event invitation still have input fields and buttons
Description

When a user open an event invitation in his/her calendar, the same form is used as when creating or editing an writable event, even though it's impossible to save any modification.

Information should be clearly read-only (labels instead of input fields, no modify button for the attachment, no edit button for custom recurrent rule).

TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2009-07-22 19:14

viewer   ~0000036

We should probably create a new view inspired by the read-only/invitation dialog from Lightning. This would also enable us to save alarms.

francis

francis

2009-07-27 15:21

administrator   ~0000051

When a read-only event has no attendee but a description, the description div doesn't span down the bottom of the popup window as it does with event with attendees but no description.

francis

francis

2009-07-27 15:26

administrator   ~0000052

The attendees div should first be hidden and then displayed only if there are attendees. Otherwise it's a bit annoying to see the div disappear as the window is loaded (when there are no attendee) ..

francis

francis

2009-07-27 15:57

administrator   ~0000053

sogod crashes when opening an read-only task.

francis

francis

2009-07-29 11:16

administrator   ~0000059

The popup window is resized in JavaScript when the event/task is read-only. This is annoying

francis

francis

2009-07-29 15:09

administrator   ~0000060

sogod no longer crashes; I fixed the problems when viewing read-only tasks.

ludovic

ludovic

2009-08-05 11:03

administrator   ~0000069

When viewing a task, we have an "Attendees" label - it shouldn't be there.

francis

francis

2009-08-06 18:04

administrator   ~0000071

The attendees label no longer appear when looking at a read-only task.

ludovic

ludovic

2009-10-09 15:41

administrator   ~0000154

The save & close, invite attendees and others are visible also when looking at an event coming from an ICS subscription.

francis

francis

2009-10-14 14:28

administrator   ~0000162

I fixed the view for web calendar events (ICS).

ludovic

ludovic

2009-10-15 22:59

administrator   ~0000178

Note sure if it's related to the previous fix but when I subscribe to:

http://inverse.ca/~lmarcotte/canada.ics

from the Web interface, if I try to double-click on any events from that calendar, I get:

An error occurred during object publishing

the requested object could not be found!

In the logs I have:

Oct 16 03:51:41 sogod [13961]: |SOGo| starting method 'POST' on uri '/SOGo/so/lmarcotte/Calendar/3689-4AD7D100-33-ECC35D0/3689-4AD7D100-3D-ECC35D0/occurence1255060800/view'
Oct 16 03:51:41 sogod [13961]: |SOGo| request took 0.127269 seconds to execute
localhost - - [16/Oct/2009:03:51:41 GMT] "POST /SOGo/so/lmarcotte/Calendar/3689-4AD7D100-33-ECC35D0/3689-4AD7D100-3D-ECC35D0/occurence1255060800/view HTTP/1.0" 404 208/0 0.133 - - 0
Oct 16 03:51:41 sogod [13961]: |SOGo| starting method 'GET' on uri '/SOGo/so/lmarcotte/Calendar/3689-4AD7D100-33-ECC35D0/3689-4AD7D100-3D-ECC35D0/occurence1255060800/confirmEditing'
Oct 16 03:51:41 sogod [13961]: |SOGo| request took 0.105166 seconds to execute
localhost - - [16/Oct/2009:03:51:41 GMT] "GET /SOGo/so/lmarcotte/Calendar/3689-4AD7D100-33-ECC35D0/3689-4AD7D100-3D-ECC35D0/occurence1255060800/confirmEditing HTTP/1.0" 404 208/0 0.111 - - 0

ludovic

ludovic

2009-10-17 16:05

administrator   ~0000199

It happens only with recurring events coming from a Web calendar.

In the calendar specified above (canada.ics), it works well for Good Friday and Eeaster Monday in April 2010 but not for Thanksgiving Day (October 9th, 2009)

ludovic

ludovic

2009-10-19 15:02

administrator   ~0000216

Looks like the bug only happens on PowerPC.

ludovic

ludovic

2009-10-19 15:03

administrator   ~0000217

Removing as blocker for 1.1.0.

Issue History

Date Modified Username Field Change
2009-07-22 18:38 francis New Issue
2009-07-22 18:38 francis Status new => assigned
2009-07-22 18:38 francis Assigned To => user4
2009-07-22 19:14 wsourdeau Note Added: 0000036
2009-07-23 16:11 user4 Status assigned => resolved
2009-07-23 16:11 user4 Resolution open => fixed
2009-07-27 15:21 francis Note Added: 0000051
2009-07-27 15:26 francis Note Added: 0000052
2009-07-27 15:57 francis Note Added: 0000053
2009-07-27 15:57 francis Status resolved => feedback
2009-07-27 15:57 francis Resolution fixed => reopened
2009-07-29 09:45 user4 Status feedback => assigned
2009-07-29 09:45 user4 Assigned To user4 => francis
2009-07-29 11:16 francis Note Added: 0000059
2009-07-29 15:09 francis Note Added: 0000060
2009-08-05 11:03 ludovic Note Added: 0000069
2009-08-06 18:04 francis Note Added: 0000071
2009-10-09 13:40 ludovic Fixed in Version => 1.1.0
2009-10-09 13:51 ludovic Fixed in Version 1.1.0 =>
2009-10-09 13:51 ludovic Target Version => 1.1.0
2009-10-09 15:41 ludovic Note Added: 0000154
2009-10-14 14:28 francis Note Added: 0000162
2009-10-15 22:59 ludovic Note Added: 0000178
2009-10-17 16:05 ludovic Note Added: 0000199
2009-10-19 15:02 ludovic Note Added: 0000216
2009-10-19 15:03 ludovic Note Added: 0000217
2009-10-19 15:03 ludovic Product Version 1.0.3 => Monotone / nightly
2009-10-19 15:03 ludovic Target Version 1.1.0 =>
2010-01-11 13:45 francis Status assigned => resolved
2010-01-11 13:45 francis Fixed in Version => 1.2.0
2010-01-11 13:45 francis Resolution reopened => fixed