View Issue Details

IDProjectCategoryView StatusLast Update
0000735SOGoBackend Generalpublic2010-09-13 21:08
Reportermaddog Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.0 
Target Version1.3.2Fixed in Version1.3.2 
Summary0000735: Documentation for "IDFieldName" is incorrect/misleading.
Description

In the Installation and Configuration Guide, "IDFieldName" in SOGoUserSources is described as:
"the field that starts a user DN".

This is incorrect if bindFields is also used. IDFieldName must name a field which is unique over the entire SOGo domain (described in a given SOGoUserSources), and it doesn't matter if it is part of a user's DN or not.

(Looking at LDAPSource.m, in the case that bindFields is not used, it looks like maybe IDFieldName should indeed be "the field that starts a user DN". However, it is not clear if SOGo even works if UIDFieldName is not set to be the same as IDFieldName. If so, this is something else to either fix or at least document.)

TagsNo tags attached.

Activities

ludovic

ludovic

2010-09-13 21:08

administrator   ~0001435

Updated the doc.

Issue History

Date Modified Username Field Change
2010-08-07 01:11 maddog New Issue
2010-08-26 21:35 ludovic Target Version => 1.3.2
2010-09-13 21:08 ludovic Note Added: 0001435
2010-09-13 21:08 ludovic Status new => resolved
2010-09-13 21:08 ludovic Fixed in Version => 1.3.2
2010-09-13 21:08 ludovic Resolution open => fixed
2010-09-13 21:08 ludovic Assigned To => ludovic