View Issue Details

IDProjectCategoryView StatusLast Update
0000676SOGoWeb Preferencespublic2011-11-24 14:42
Reporterlpgauthier Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version1.2.2 
Fixed in Version1.3.10 
Summary0000676: Vacation / autoresponder
Description

In web interface -> preference -> Vacation, Add a start date and an end date for vacation message.

If the user receives mails between the dates, the vacation message is sent.

Maybe some condition on to add to sieve script if dates field are filled ;-).

thanks

TagsNo tags attached.

Relationships

has duplicate 0001448 closedludovic sieve: auto-expiration of vacation message 

Activities

mra

mra

2010-07-07 03:56

reporter   ~0001155

Could be done by using the Package "Date" of sieve
http://www.faqs.org/rfcs/rfc5260.html

lpgauthier

lpgauthier

2010-07-07 12:45

reporter   ~0001162

(Link of mra) Section 5.1 - Examples, 2nd example, I think that's the good one.

thanks mra

mra

mra

2010-07-08 04:03

reporter   ~0001164

Last edited: 2010-07-08 04:04

A colleague of mine told me, that CyrusImap-sieve (cmusieve?) has a problem with the Date-Extension (seems to be not implemented there), but maybe this is only on his local installation

Therefore, I think it has to be checked, in which sieve-implementation the Date-Package is available, and in which not.
Unfortunately ...

(Will try to get more information and publish it here)

Martin

dpetschull

dpetschull

2011-03-03 08:38

reporter   ~0002183

+1 from me!

That would be a neat feature and should not be too hard to implement using the 'currentdate' feature of sieve.

roms

roms

2011-07-05 06:39

reporter   ~0002652

Horde with Ingo work well for this.
may be can you get inspired ?

ludovic

ludovic

2011-11-24 14:42

administrator   ~0003059

This has been implemented for 1.3.10. It is also available in the current nightly builds. You MUST also enable the sogo-tool cronjob to make that work.

Issue History

Date Modified Username Field Change
2010-07-02 11:19 lpgauthier New Issue
2010-07-07 03:56 mra Note Added: 0001155
2010-07-07 12:45 lpgauthier Note Added: 0001162
2010-07-08 04:03 mra Note Added: 0001164
2010-07-08 04:04 mra Note Edited: 0001164
2011-03-03 08:38 dpetschull Note Added: 0002183
2011-07-05 06:39 roms Note Added: 0002652
2011-09-20 10:28 wsourdeau Relationship added has duplicate 0001448
2011-11-24 14:42 ludovic Note Added: 0003059
2011-11-24 14:42 ludovic Status new => resolved
2011-11-24 14:42 ludovic Fixed in Version => 1.3.10
2011-11-24 14:42 ludovic Resolution open => fixed
2011-11-24 14:42 ludovic Assigned To => ludovic
2011-11-24 14:42 ludovic Status resolved => closed