View Issue Details

IDProjectCategoryView StatusLast Update
0000675SOGoSOPEpublic2010-07-12 16:52
ReporterJason Oster Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.2 
Fixed in Version1.3.0 
Summary0000675: SOGoProfileURL parsed incorrectly after Ubuntu upgrade 9.10 -> 10.04
Description

The SOGoProfileURL option seems to be parsed incorrectly, resulting in the database/table parse of the URL being used for both the database AND the table.

Here is an example:

defaults write sogod SOGoProfileURL 'postgresql://sogo:sogo@localhost:5432/sogo/sogo_user_profile'

With this configuration, SOGo attempts to connect to a Postgresql database named "sogo/sogo_user_profile" Changing the SOGoProfileURL so that it only references the database, without a table name:

defaults write sogod SOGoProfileURL 'postgresql://sogo:sogo@localhost:5432/sogo'

Makes SOGo connect to a database named "sogo" AND creates/accesses a table named "sogo"

The OCSFolderInfoURL option does NOT exhibit this behavior, at least in my tests. After the SOGoProfileURL connection is established, the OCSFolderInfoURL connection is made and the URL 'postgresql://sogo:sogo@localhost:5432/sogo/sogo_folder_info' is parsed exactly as expected; database "sogo" and table "sogo_folder_info"

Additional Information

Postgresql version: 8.4.4-0ubuntu10.04

This bug is not specific to Postgresql. A user is experiencing the same problem with MySQL: http://www.mail-archive.com/users@sogo.nu/msg00264.html

It may only be a problem when upgrading Ubuntu to 10.04, e.g. installing fresh seems OK, according to some users on the mailing list.

TagsNo tags attached.

Activities

Jason Oster

Jason Oster

2010-07-01 13:23

reporter   ~0001138

Additional information (logs and such things) here: https://inverse.ca/sogo/lists/arc/users/2010-07/msg00022.html

Jason Oster

Jason Oster

2010-07-01 13:36

reporter   ~0001139

Correction for the link in "Additional Information" ... Mantis borked it because it contains an @ character (Mantis bug? lol)

Let's try it with a %-encoded @ character: http://www.mail-archive.com/users%40sogo.nu/msg00264.html

ludovic

ludovic

2010-07-02 07:56

administrator   ~0001140

If I can have SSH access to the server, I could have a look at the connection code through gdb and see it the ABI has changed so that it breaks sope-gdl.

Jason Oster

Jason Oster

2010-07-02 15:19

reporter   ~0001143

After a debug marathon with Ludovic, it was discovered that the nightly builds for Debian Lenny are not suitable for Ubuntu 10.04 LTS (ABI issues, apparently). Building SOPE and SOGo from sources works correctly.

The plan of attack is that Inverse will be working on nightly builds specifically for Ubuntu 10.04. In the interim, SOPE/SOGO can be built as described below:

First, remove all SOPE/SOGo related packages (this step will leave all configuration in place):

apt-get remove sogo

apt-get autoremove

You may still have some SOPE packages installed after the autoremove, as I did. (I installed some of them manually for Postgresql support) To list any SOPE packages:

dpkg -l | grep sope

These can be apt-get remove'd as well.

Next, install the build environment:

apt-get install subversion monotone build-essential gnustep-make \

libxml++2.6-dev libxml2-dev libssl-dev libldap2-dev libpq-dev patch \
libldap2-dev libxml2-dev libldap2-dev libssl-dev libpq-dev gobjc-4.4 \
libgnustep-base-dev apache2-prefork-dev libapr1-dev libaprutil1-dev \
libdb4.8-dev libexpat1-dev libpcre3-dev libsqlite3-dev uuid-dev \
libmysqlclient16-dev libmysqlclient15off mysql-common

This may not cover every package, but it gets the majority of dependencies that you will need.

Build instructions are available here: http://www.sogo.nu/english/support/faq/article/how-do-i-compile-sogo-2.html

After successful build, you may need to modify your Apache SOGo.conf to point to the new WebResources install location, depending on how it was configured.

According to Ludovic, starting your SOGo build goes something like this:

sudo -u sogo /usr/local/sbin/sogod -WONoDetach YES -WOWorkersCount 1 -WOLogFile - -WOPidFile /tmp/sogo.pid

Some additional build information can be found here, though it a bit out-of-date: http://wiki.mhcsoftware.de/SOGo_1.0.1_on_Ubuntu_9.04

Issue History

Date Modified Username Field Change
2010-07-01 13:21 Jason Oster New Issue
2010-07-01 13:23 Jason Oster Note Added: 0001138
2010-07-01 13:36 Jason Oster Note Added: 0001139
2010-07-02 07:56 ludovic Note Added: 0001140
2010-07-02 15:19 Jason Oster Note Added: 0001143
2010-07-12 16:52 ludovic Status new => resolved
2010-07-12 16:52 ludovic Fixed in Version => 1.3.0
2010-07-12 16:52 ludovic Resolution open => fixed
2010-07-12 16:52 ludovic Assigned To => ludovic