View Issue Details

IDProjectCategoryView StatusLast Update
0000636SOGoBackend Generalpublic2010-06-11 15:05
Reporterwharf Assigned To 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Product Version1.2.2 
Summary0000636: [SOGO] libevent and memcached dependancies error
Description
  • Freshly new installed CentOS 5.5
  • SOGo 1.2.2 and / or nighlty

issuing command :

yum install sogo

gives the following results

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • addons: mirror.ovh.net
  • base: mirror.ovh.net
  • extras: mirror.ovh.net
  • updates: mirror.ovh.net
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package sogo.i386 0:1.2_20100528-1.el5 set to be updated
    --> Processing Dependency: memcached for package: sogo
    --> Running transaction check
    ---> Package memcached.i386 0:1.4.2-1.el5 set to be updated
    --> Processing Dependency: libevent-1.1a.so.1 for package: memcached
    --> Finished Dependency Resolution
    memcached-1.4.2-1.el5.i386 from sogo-nightly-rhel5 has depsolving problems
    --> Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.2-1.el5.i386 (sogo-nightly-rhel5)
    Error: Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.2-1.el5.i386 (sogo-nightly-rhel5)
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    [root@ssandbox sogo]#
Additional Information

inverse.repo content :
[sogo-nightly-rhel5]
name= Inverse SOGo nightly-build Repository
baseurl=http://inverse.ca/downloads/SOGo/RHEL5/nightly/$basearch

excluding memcache doesn't help, still same error.

I saw same trouble ticket but i can't apply what is suggested because CentOS is a bit different with yum, i can't find sources of memcached, libevent and i have no idea on what should be done to make sogo work.
Why can't it simply work out of the box ?

I tried to force installation of libevent 1.1 over libevent 1.4 and sogo looks like it would worked but then i have proxy errors when attempting to add an event.
Also added 512 Mb memory limit but again it doesn't help, still having errors so uninstalled sogo and restarted from beginning.
I'm afraid i'm in a loop when something is fixed, it breaks elsewhere.
Thank you for your help and sorry for my poor english level.

TagsNo tags attached.

Relationships

duplicate of 0000605 resolvedfrancis memcached package preventing libevent update on RHEL5 

Activities

wharf

wharf

2010-05-29 08:34

reporter   ~0001071

I tried to forcibly install libevent 1.1 and all the packages from the nightly build with rpm -ivh *.rpm --force

Prior to this, i installed libevent 1.1 --force

Sogo runs at present but i'm not sure everything is where it should be...
I prefer when everything installs without glitches out of the box.

wcronen

wcronen

2010-05-29 17:48

reporter   ~0001074

Last edited: 2010-05-29 17:48

There's already a bug report:
http://www.scalableogo.org/bugs/view.php?id=605

wsourdeau

wsourdeau

2010-06-11 15:04

viewer   ~0001110

Duplicate of 0000605

Issue History

Date Modified Username Field Change
2010-05-29 05:38 wharf New Issue
2010-05-29 08:34 wharf Note Added: 0001071
2010-05-29 17:48 wcronen Note Added: 0001074
2010-05-29 17:48 wcronen Note Edited: 0001074
2010-06-10 21:02 ludovic Target Version => 1.2.3
2010-06-10 21:02 ludovic Additional Information Updated
2010-06-11 15:04 wsourdeau Note Added: 0001110
2010-06-11 15:04 wsourdeau Status new => closed
2010-06-11 15:04 wsourdeau Resolution open => duplicate
2010-06-11 15:04 wsourdeau Relationship added duplicate of 0000605
2010-06-11 15:05 wsourdeau Target Version 1.2.3 =>