View Issue Details

IDProjectCategoryView StatusLast Update
0000620SOGoBackend Mailpublic2010-06-28 18:11
Reporterhmonteiro Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.2 
Target Version1.3.0Fixed in Version1.3.0 
Summary0000620: bare LFs on messages with attachments
Description

I've been having problems with attachments and i even tried an upgrade to 1.2.2.20100520, but things remained the same.

Checking the logs, i've come across an interesting situation. It appears that SOGo tries to send the message using bare LFs, as opposed to RFC 5321, section 2.3.8, recommendations.

This situation only happens when attachments are involved.

Additional Information

LOGS

==> /var/log/sogo/sogo.log <==
2010-05-20 16:40:37.917 sogod[18421] Note: using 'UCS-2LE' on Linux.
2010-05-20 16:40:37.944 sogod[18421] File NSKeyValueCoding.m: 892. In [UIxMailEditor -valuesForKeys:] This method is deprecated, use -dictionaryWithValuesForKeys:
May 20 16:40:37 sogod: SOGo watchdog [18421]: <<0x02ABB3A0[SOGoDraftObject]:newDraft1274369981-1>>D MIME Envelope: {"MIME-Version" = 1.0; "User-Agent" = "SOGoMail 1.2.2"; date = "Thu, 20 May 2010 16:40:37 +0100"; from = "Hugo Monteiro <hm@ae.fct.unl.pt>"; "message-id" = "<47f5-4bf55800-5-6b8b4580@65349433>"; "reply-to" = "Hugo Monteiro <hm@ae.fct.unl.pt>"; subject = asdadasd; to = "\"Hugo Monteiro\" <hugo.monteiro@fct.unl.pt>"; }
May 20 16:40:37 sogod: SOGo watchdog [18421]: <<0x02ABB3A0[SOGoDraftObject]:newDraft1274369981-1>>D attachments: ("<NGMimeBodyPart[0x0x25da7d0]: header={\"content-disposition\" = \"<NGMimeContentDispositionHeaderField[0x0x1c46b10]: type=attachment parameters={filename = zcs.vcard; }>\"; \"content-length\" = 30388; \"content-transfer-encoding\" = base64; \"content-type\" = \"application/octet-stream\"; } bodyClass=NGMimeFileData body=<0x0x1ac7110[NGMimeFileData]: path=/tmp/OGo47F54BF557F501.tmp>>")
May 20 16:40:37 sogod: SOGo watchdog [18421]: <<0x02ABB3A0[SOGoDraftObject]:newDraft1274369981-1>>D message: <NGMimeMessage[0x0x219d880]: header={"MIME-Version" = 1.0; "User-Agent" = "SOGoMail 1.2.2"; "content-type" = "<NGMimeType: multipart/mixed>"; date = "Thu, 20 May 2010 16:40:37 +0100"; from = "Hugo Monteiro <hm@ae.fct.unl.pt>"; "message-id" = "<47f5-4bf55800-5-6b8b4580@65349433>"; "reply-to" = "Hugo Monteiro <hm@ae.fct.unl.pt>"; subject = asdadasd; to = "\"Hugo Monteiro\" <hugo.monteiro@fct.unl.pt>"; } body=<NGMimeMultipartBody[0x0x2319380]: parts=("<NGMimeBodyPart[0x0x20674c0]: header={\"content-type\" = \"text/plain; charset=utf-8\"; } bodyClass=GSCInlineString bodyLen=20 body=
--
Hugo Monteiro>", "<NGMimeBodyPart[0x0x25da7d0]: header={\"content-disposition\" = \"<NGMimeContentDispositionHeaderField[0x0x1c46b10]: type=attachment parameters={filename = zcs.vcard; }>\"; \"content-length\" = 30388; \"content-transfer-encoding\" = base64; \"content-type\" = \"application/octet-stream\"; } bodyClass=NGMimeFileData body=<0x0x1ac7110[NGMimeFileData]: path=/tmp/OGo47F54BF557F501.tmp>>")>>
C: connect to <0x0x2d08bb0[NGInternetSocketAddress]: host=localhost not-filled>
S: <SMTP-Reply: code=220 line='mail.ae.fct.unl.pt ESMTP AEFCTUNL Mail eXchanger'>
C: EHLO localhost
S: <SMTP-Reply: code=250 line='8BITMIME'>
S: pipelining extension supported.
C: MAIL FROM:<hm@ae.fct.unl.pt>
C: RCPT TO:<hugo.monteiro@fct.unl.pt>
C: DATA
S: <SMTP-Reply: code=354 line='go ahead punk, make my day'>
C: data(31309 bytes) ..
S: <SMTP-Reply: code=451 line='See http://pobox.com/~djb/docs/smtplf.html.'>
2010-05-20 16:40:38.034 sogod[18421] SMTP(DATA): mail input failed, got code 451 ..
EXCEPTION: <NSException: 0x25b8fd0> NAME:SMTPException REASON:require state 2, now in 3 INFO:(nil)
May 20 16:40:38 sogod: SOGo watchdog [17581]: <0x0x1bb8c40[WOWatchDogChild]> child 18421 exited
May 20 16:40:38 sogod: SOGo watchdog [17581]: <0x0x1bb8c40[WOWatchDogChild]> (terminated due to signal 6)
May 20 16:40:38 sogod: SOGo watchdog [18483]: SNS support disabled.
May 20 16:40:38 sogod: SOGo watchdog [17581]: <0x0x1b81230[WOWatchDog]> child spawned with pid 18483
May 20 16:40:38 sogod: SOGo watchdog [18483]: <0x0x1f74ba0[SOGoProductLoader]> SOGo products loaded from '/usr/lib/GNUstep/SOGo':
May 20 16:40:38 sogod: SOGo watchdog [18483]: <0x0x1f74ba0[SOGoProductLoader]> Mailer.SOGo, AdministrationUI.SOGo, MailerUI.SOGo, Contacts.SOGo, PreferencesUI.SOGo, ContactsUI.SOGo, MailPartViewers.SOGo, SchedulerUI.SOGo, MainUI.SOGo, CommonUI.SOGo, Appointments.SOGo
May 20 16:40:38 sogod: SOGo watchdog [18483]: |SOGo| version 1.2.2 (build @vizzini.inverse.ca 201005201056) -- starting
May 20 16:40:38 sogod: SOGo watchdog [18483]: |SOGo| vmem size check enabled: shutting down app when vmem > 384 MB

==> /var/log/apache2/hosting/ae.fct.unl.pt/error.log <==
[Thu May 20 16:40:38 2010] [error] [client 10.130.24.131] (70014)End of file found: proxy: error reading status line from remote server 127.0.0.1, referer: https://ae.fct.unl.pt/SOGo/so/hm/Mail/hm_A_ae_D_fct_D_unl_D_pt/folderDrafts/newDraft1274369981-1/edit
[Thu May 20 16:40:38 2010] [error] [client 10.130.24.131] proxy: Error reading from remote server returned by /SOGo/so/hm/Mail/hm_A_ae_D_fct_D_unl_D_pt/folderDrafts/newDraft1274369981-1/send, referer: https://ae.fct.unl.pt/SOGo/so/hm/Mail/hm_A_ae_D_fct_D_unl_D_pt/folderDrafts/newDraft1274369981-1/edit

TagsNo tags attached.

Issue History

Date Modified Username Field Change
2010-05-20 16:03 hmonteiro New Issue
2010-06-10 21:05 ludovic Target Version => 1.2.3
2010-06-11 15:04 wsourdeau Status new => assigned
2010-06-11 15:04 wsourdeau Assigned To => wsourdeau
2010-06-28 12:03 ludovic Assigned To wsourdeau => ludovic
2010-06-28 18:11 ludovic Note Added: 0001130
2010-06-28 18:11 ludovic Status assigned => resolved
2010-06-28 18:11 ludovic Fixed in Version => 1.3.0
2010-06-28 18:11 ludovic Resolution open => fixed