View Issue Details

IDProjectCategoryView StatusLast Update
0000586SOGoWeb Calendarpublic2012-04-20 12:03
Reporterhavardw Assigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.1 
Fixed in Version1.3.15 
Summary0000586: Event alarms with a fixed time doesn't show in the web interface
Description

If I create an event in Lightning and set the alarm to a fixed time (e.g. 2010-04-22 22:00) instead of relative ("15 minutes before") the alarm doesn't show up in the web interface.

Additional Information

Example of an event with fixed alarm time:
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Oslo
X-LIC-LOCATION:Europe/Oslo
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20100422T190453Z
LAST-MODIFIED:20100422T190637Z
DTSTAMP:20100422T190637Z
UID:b9820d85-33e9-4073-a963-6cb6e3f63ff2
SUMMARY:Alarmtest absolute
DTSTART;TZID=Europe/Oslo:20100423T100000
DTEND;TZID=Europe/Oslo:20100423T110000
DESCRIPTION:Alarm at 09:00
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DATE-TIME:20100423T070000Z
DESCRIPTION:Standard Mozilla beskrivelse
END:VALARM
END:VEVENT
END:VCALENDAR

TagsNo tags attached.

Relationships

duplicate of 0000633 closed Funambol SOGo Connector Alarms aren't synced correctly. Conversion necessary! 

Activities

wcronen

wcronen

2010-04-22 18:44

reporter   ~0000978

Same seems to happen with one of my funambol-clients (I must revalidate wether it was the Outlook or the Outlook mobile client).

In the calendar (wether Outlook or O.mobile) I set a relative alarm (i.e. -15m) which seems to be converted by the funambol client to an fixed alarm (absolute time).

This doesn't then show up in the sogo-web but if you click to edit the event there's set an user-defined alarm.

In thunderbird the alarm is shown.

I'll recheck the next days if I've more time and post the detailed results.

wcronen

wcronen

2010-05-20 16:14

reporter   ~0001044

I can confirm also with the latest nightly of the sogo webinterface.

In Lightning you see an alarm icon but if you edit the event there's only a user-defined alarm and you don't see the exact time of the alarm neither relative nor absolute!

Wouldn't it be better to write the relative alarm time in the vevent entries? This might fix all problems or am I wrong?

Issue History

Date Modified Username Field Change
2010-04-22 15:25 havardw New Issue
2010-04-22 18:44 wcronen Note Added: 0000978
2010-05-20 16:14 wcronen Note Added: 0001044
2011-12-22 12:55 francis Relationship added duplicate of 0000633
2012-04-20 12:03 wsourdeau Status new => resolved
2012-04-20 12:03 wsourdeau Fixed in Version => 1.3.15
2012-04-20 12:03 wsourdeau Resolution open => fixed
2012-04-20 12:03 wsourdeau Assigned To => wsourdeau