View Issue Details

IDProjectCategoryView StatusLast Update
0000058SOGoBackend Mailpublic2010-06-23 16:57
Reporterjulien Assigned Towsourdeau 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Target Version1.3.0Fixed in Version1.3.0 
Summary0000058: Special message make sogod crash
Description

I received a multipart MIME message from amavisd-new which Sogod cannot display. It always crashs with the following errors:

Jul 09 16:33:07 sogod [5185]: <0x0x9a6f4f8[NGImap4Client]> ERROR(-[NGImap4Client _processCommandParserException:]): catched IMAP4 parser exception NGImap4ParserException: unexpected char <
A> expected < >
Jul 09 16:33:07 sogod [5185]: [ERROR] <0x0x9a79000[NGImap4Connection]> could not fetch 5 uids for url: imap://julien@imap.indato.ch/INBOX/Sogo%20fail/
EXCEPTION: <NSException: 0x9b2a560> NAME:NSInvalidArgumentException REASON:Tried to add nil to array INFO:(nil)

child 5185 (0000001) was terminated by signal 6 (uptime=16s).

Additional Information

I attached the email which causes the crash.
You should be able to reproduce the bug sending it to a sogo user with the sendmail command:
$ sendmail user@example.com < message.txt

TagsNo tags attached.

Activities

2009-07-09 10:50

 

message.txt (3,149 bytes)   
Content-Type: multipart/mixed; boundary="----------=_1238660776-7791-2"
Content-Transfer-Encoding: binary
MIME-Version: 1.0
Subject: "Agenda_personnel" a ete cree
From: Julien Tognazzi <julien.tognazzi@indato.ch>
To: Julien Tognazzi <julien.tognazzi@indato.ch>
Date: Wed, 10 Jul 2009 17:54:02 +0200

This is a multi-part message in MIME format...


------------=_1238660776-7791-2
Content-Type: text/plain; charset="iso-8859-1"
Content-Disposition: inline
Content-Transfer-Encoding: 8bit

Spam detection software, running on the system "tux.indato.ch", has
identified this incoming email as possible spam.  The original message
has been attached to this so you can view it (if it isn't spam) or label
similar future email.  If you have any questions, see
the administrator of that system for details.

Content preview:  Le dossier "Agenda personnel" a �t� cr��. Vous pouvez
  acc�der � distance � ce dossier avec le lien suivant: http://calendar.indato.ch/SOGo/so/oe/Cal...
   [...] 

Content analysis details:   (8.3 points, 5.0 required)

 pts rule name              description
---- ---------------------- --------------------------------------------------
 0.0 ALL_TRUSTED            Passed through trusted hosts only via SMTP
 3.2 TVD_RCVD_IP4           TVD_RCVD_IP4
 1.9 TVD_RCVD_IP            TVD_RCVD_IP
 1.0 DATE_IN_PAST_12_24     Date: is 12 to 24 hours before Received: date
 2.7 MULTIPART_ALT_NON_TEXT BODY: MULTIPART_ALT_NON_TEXT
-1.1 BAYES_05               BODY: Bayesian spam probability is 1 to 5%
                            [score: 0.0143]
 0.6 MIME_HEADER_CTYPE_ONLY 'Content-Type' found without required MIME
                            headers

------------=_1238660776-7791-2
Content-Type: message/rfc822; x-spam-type=original; name="message"
Content-Disposition: attachment; filename="message"
Content-Transfer-Encoding: 8bit
Content-Description: Original message

Return-Path: <julien.tognazzi@indato.ch>
Received: from 10.10.10.221 (unknown [10.10.10.221]) by tux.indato.ch
 (Postfix) with ESMTP id EE47E6140FB for <julien.tognazzi@indato.ch>; Thu, 
 2 Apr 2009 10:26:14 +0200 (CEST)
content-type: multipart/alternative; boundary="----=_=-_OpenGroupware_org_NGMime-11056-1238601242.707071-1------"
From: Julien Tognazzi <julien.tognazzi@indato.ch>
To: Julien Tognazzi <julien.tognazzi@indato.ch>
Date: Wed, 01 Apr 2009 17:54:02 +0200
Subject: =?utf-8?Q?"Agenda_personnel"_a_=C3=A9t=C3=A9_cr=C3=A9=C3=A9?=
Message-Id: <20090402082614.EE47E6140FB@tux.indato.ch>
Mime-Version: 1.0


------=_=-_OpenGroupware_org_NGMime-11056-1238601242.707071-1------
content-type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit

Le dossier "Agenda personnel" a été créé.

Vous pouvez accéder à  distance à  ce dossier avec le lien suivant:

    http://calendar.indato.ch/SOGo/so/oe/Calendar/personal/
------=_=-_OpenGroupware_org_NGMime-11056-1238601242.707071-1------
content-type: application/x-sogo-notification; method=add; type=Appointment; charset=utf-8

http://calendar.indato.ch/SOGo/so/oe/Calendar/personal/
------=_=-_OpenGroupware_org_NGMime-11056-1238601242.707071-1--------


------------=_1238660776-7791-2--
message.txt (3,149 bytes)   
wsourdeau

wsourdeau

2009-07-23 13:19

viewer   ~0000041

Hi Julien,

I am unable to reproduce your problem. Can you send me an IMAP sniff log?
Also, are you sure you are using the very latest SOPE patchset? If not, can you try again with that version?

2009-07-28 05:39

 

imap.txt (2,215 bytes)   
13 status "INBOX.test" (UIDVALIDITY)
* STATUS "INBOX.test" (UIDVALIDITY 1247049519)
13 OK STATUS Completed.
14 select "INBOX.test"
* FLAGS (\Draft \Answered \Flagged \Deleted \Seen \Recent)
* OK [PERMANENTFLAGS (\* \Draft \Answered \Flagged \Deleted \Seen)] Limited
* 1 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 1247049519] Ok
* OK [MYRIGHTS "acdilrsw"] ACL
14 OK [READ-WRITE] Ok
15 capability
* CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION XMAGICTRASH
15 OK CAPABILITY completed
16 UID SORT (REVERSE ARRIVAL) UTF-8 not deleted
* SORT 1
16 OK SORT done.
17 uid fetch 1 (UID FLAGS ENVELOPE RFC822.SIZE BODYSTRUCTURE BODY.PEEK[HEADER.FIELDS (X-PRIORITY)])
* 1 FETCH (UID 1 FLAGS (\Seen) ENVELOPE ("Wed, 10 Jul 2009 17:54:02 +0200" "=?utf-8?Q?\"Agenda_personnel\"_a_=C3=A9t=C3=A9_cr=C3=A9=C3=A9?=" (("Julien Tognazzi" NIL "julien" "indato.ch")) (("Julien Tognazzi" NIL "julien" "indato.ch")) (("Julien Tognazzi" NIL "julien" "indato.ch")) (("Julien Tognazzi" NIL "julien.tognazzi" "indato.ch")) NIL NIL NIL "<20090728083914.D7EAE36384@canopus.indato.ch>") RFC822.SIZE 3554 BODYSTRUCTURE (("text" "plain" ("charset" "utf-8") NIL NIL "8bit" 1206 23 NIL ("inline" NIL) NIL)("message" "rfc822" ("x-spam-type" "original" "name" "message") NIL "Original message" "8bit" 1221 ("Wed, 01 Apr 2009 17:54:02 +0200" "=?utf-8?Q?\"Agenda_personnel\"_a_=C3=A9t=C3=A9_cr=C3=A9=C3=A9?=" (("Julien Tognazzi" NIL "julien.tognazzi" "indato.ch")) (("Julien Tognazzi" NIL "julien.tognazzi" "indato.ch")) (("Julien Tognazzi" NIL "julien.tognazzi" "indato.ch")) (("Julien Tognazzi" NIL "julien.tognazzi" "indato.ch")) NIL NIL NIL "<20090402082614.EE47E6140FB@tux.indato.ch>") (("text" "plain" ("charset" "utf-8") NIL NIL "8bit" 184 4 NIL NIL NIL)("application" "x-sogo-notification" ("method" "add" "type" "Appointment" "charset" "utf-8") NIL NIL "8bit" 55 NIL NIL NIL) "alternative" ("boundary" "----=_=-_OpenGroupware_org_NGMime-11056-1238601242.707071-1------") NIL NIL) 27 NIL ("attachment" ("filename" "message")) NIL) "mixed" ("boundary" "----------=_1238660776-7791-2") NIL NIL) BODY[HEADER.FIELDS ("X-PRIORITY")] {2}

)
17 OK FETCH completed.

imap.txt (2,215 bytes)   
julien

julien

2009-07-28 05:41

reporter   ~0000054

I Wolfgang,

I tried again on the 20090727 nightly and it still crashes.

I attach the sniff, tell me if you need anything else.
By the way our IMAP server is courier-imap v. 4.0.6

joaquinllano

joaquinllano

2010-04-15 07:32

reporter   ~0000951

Hi, I have a similar error:

SOgo logs shows:
<0x0x8bd3ef0[NGImap4Client]> ERROR(-[NGImap4Client _processCommandParserException:]): catched IMAP4 parser exception NGImap4ParserException: unexpected char <j> expected < >
<0x0x9166350[NGImap4Connection]> could not fetch 17 uids for url: imap://pruebasogouno@192.168.55.61/INBOX/
EXCEPTION: <NSException: 0x8d30110> NAME:NSInvalidArgumentException REASON:Tried to add nil to array INFO:(nil)
<0x0x81c42b0[WOWatchDogChild]> received SIGCHLD from pid 22909
<0x0x81c42b0[WOWatchDogChild]> (terminated due to signal 6)
<0x0x81c42b0[WOWatchDogChild]> avoiding to respawn child before 2010-04-15 13:19:37 +0200
SNS support disabled.

A multi part message causes SOGo crash.

If you like I can send you the message (I haven't attached it because its contains private data).

Regards.

julien

julien

2010-04-28 10:12

reporter   ~0000983

Hi,

I got a new msg causing a similar crash, so I'm willing to help out what's wrong here...
I updated an instance of SOGo to the latest nightly, and tried to read this specific new msg.
I'll attach the new log file, imap trace and backtrace.

2010-04-28 10:22

 

backtrace.txt (7,557 bytes)   
Breakpoint 1, -[NSException raise] (self=0x93cdb60, _cmd=0x1eb948) at NSException.m:815
815	NSException.m: No such file or directory.
	in NSException.m
(gdb) bt
#0  -[NSException raise] (self=0x93cdb60, _cmd=0x1eb948) at NSException.m:815
#1  0x0016e818 in -[NGImap4ResponseParser setLastException:] (self=0x92c9658, _cmd=0x1eb968, _exc=0x93cdb60) at NGImap4ResponseParser.m:229
#2  0x00178428 in _consumeIfMatch (self=0x92c9658, _match=32 ' ') at NGImap4ResponseParser.m:2521
#3  0x00176417 in _parseSingleBody (self=0x92c9658, isBodyStructure=1 '\001') at NGImap4ResponseParser.m:2050
#4  0x001770c6 in _parseBody (self=0x92c9658, isBodyStructure=1 '\001') at NGImap4ResponseParser.m:2192
#5  0x00176d7f in _parseMultipartBody (self=0x92c9658, isBodyStructure=1 '\001') at NGImap4ResponseParser.m:2148
#6  0x001770ae in _parseBody (self=0x92c9658, isBodyStructure=1 '\001') at NGImap4ResponseParser.m:2189
#7  0x00174a6a in -[NGImap4ResponseParser _parseNumberUntaggedResponse:] (self=0x92c9658, _cmd=0x1eba80, result_=0x8fa4968) at NGImap4ResponseParser.m:1667
#8  0x00170378 in _parseUntaggedResponse (self=0x92c9658, result_=0x8fa4968) at NGImap4ResponseParser.m:686
#9  0x0016ebb9 in -[NGImap4ResponseParser parseResponseForTagId:exception:] (self=0x92c9658, _cmd=0x1ecbe8, _tag=17, ex_=0xbfa1fc2c) at NGImap4ResponseParser.m:275
#10 0x0017f664 in -[NGImap4Client processCommand:withTag:withNotification:logText:] (self=0x92528b8, _cmd=0x1ecfd8, _command=0x92fce50, _tag=1 '\001', _notification=1 '\001', _txt=0x92fce50)
    at NGImap4Client.m:1410
#11 0x0017fcc1 in -[NGImap4Client processCommand:] (self=0x92528b8, _cmd=0x1eccf8, _command=0x92fce50) at NGImap4Client.m:1481
#12 0x0017c14e in -[NGImap4Client fetchUids:parts:] (self=0x92528b8, _cmd=0x1f66c8, _uids=0x94145f0, _parts=0x9250180) at NGImap4Client.m:788
#13 0x001ad8d7 in -[NGImap4Connection fetchUIDs:inURL:parts:] (self=0x92cfb90, _cmd=0xa61df8, _uids=0x94145f0, _url=0x93c6a70, _parts=0x9250180) at NGImap4Connection.m:541
#14 0x00a41930 in -[SOGoMailFolder fetchUIDs:parts:] (self=0x924acf0, _cmd=0xb18608, _uids=0x94145f0, _parts=0x9250180) at SOGoMailFolder.m:524
#15 0x00b05b42 in -[UIxMailListView messages] (self=0x93cd038, _cmd=0x92fa618) at UIxMailListView.m:514
#16 0x003cac5f in _getComponentValue (self=0x93f7c70, object=0x93cd038, info=0x93f7ca8) at WOKeyPathAssociation.m:528
#17 0x003cb4cd in _getOneValue (self=0x93f7c70, root=0x93cd038) at WOKeyPathAssociation.m:723
#18 0x003cc7ac in -[WOKeyPathAssociation valueInComponent:] (self=0x93f7c70, _cmd=0x4c2e90, _component=0x93cd038) at WOKeyPathAssociation.m:954
#19 0x003c7c39 in -[WOAssociation valueInContext:] (self=0x93f7c70, _cmd=0x4e8728, _ctx=0x929f100) at WOAssociation.m:227
#20 0x00406378 in -[_WOSimpleRepetition appendToResponse:inContext:] (self=0x93fe120, _cmd=0x4e1cd0, _response=0x93fdee0, _ctx=0x929f100) at WORepetition.m:790
#21 0x003ef55c in -[WOCompoundElement appendToResponse:inContext:] (self=0x93fe228, _cmd=0x4e3d20, _response=0x93fdee0, _ctx=0x929f100) at WOCompoundElement.m:247
---Type <return> to continue, or q <return> to quit---
#22 0x003f69c3 in -[WOGenericContainer appendToResponse:inContext:] (self=0x93f7370, _cmd=0x4e1cd0, _response=0x93fdee0, _ctx=0x929f100) at WOGenericContainer.m:121
#23 0x003ef55c in -[WOCompoundElement appendToResponse:inContext:] (self=0x93fe0e0, _cmd=0x4e3d20, _response=0x93fdee0, _ctx=0x929f100) at WOCompoundElement.m:247
#24 0x003f69c3 in -[WOGenericContainer appendToResponse:inContext:] (self=0x93e0270, _cmd=0x4cb1a8, _response=0x93fdee0, _ctx=0x929f100) at WOGenericContainer.m:121
#25 0x003dbd6f in -[WOTemplate appendToResponse:inContext:] (self=0x93e2430, _cmd=0x492580, _response=0x93fdee0, _ctx=0x929f100) at WOTemplate.m:128
#26 0x0036a5c8 in -[WOComponent appendToResponse:inContext:] (self=0x93cd038, _cmd=0x4ff9e0, _response=0x93fdee0, _ctx=0x929f100) at WOComponent.m:924
#27 0x004283ed in -[SoDefaultRenderer renderComponent:inContext:] (self=0x93bf2f0, _cmd=0x4ffa88, _c=0x93cd038, _ctx=0x929f100) at SoDefaultRenderer.m:134
#28 0x00429181 in -[SoDefaultRenderer renderObject:inContext:] (self=0x93bf2f0, _cmd=0x501d28, _object=0x93cd038, _ctx=0x929f100) at SoDefaultRenderer.m:253
#29 0x00431902 in -[SoObjectRequestHandler renderObject:inContext:] (self=0x90b03a8, _cmd=0x501dd0, _object=0x93cd038, _ctx=0x929f100) at SoObjectRequestHandler.m:473
#30 0x00432771 in -[SoObjectRequestHandler handleRequest:inContext:session:application:] (self=0x90b03a8, _cmd=0x4b37f8, _rq=0x9250088, _ctx=0x929f100, _sn=0x0, app=0x905f720)
    at SoObjectRequestHandler.m:623
#31 0x003aedd5 in -[WORequestHandler handleRequest:] (self=0x90b03a8, _cmd=0x4902a0, _request=0x9250088) at WORequestHandler.m:241
#32 0x00365246 in -[WOCoreApplication dispatchRequest:usingHandler:] (self=0x905f720, _cmd=0x4902d8, _request=0x9250088, handler=0x90b03a8) at WOCoreApplication.m:704
#33 0x003655cc in -[WOCoreApplication dispatchRequest:] (self=0x905f720, _cmd=0x8050b70, _request=0x9250088) at WOCoreApplication.m:744
#34 0x0804a805 in -[SOGo dispatchRequest:] (self=0x905f720, _cmd=0x4f1550, _request=0x9250088) at SOGo.m:414
#35 0x0041f042 in -[WOHttpTransaction _run] (self=0x9398ca8, _cmd=0x4f1568) at WOHttpTransaction.m:546
#36 0x0041f449 in -[WOHttpTransaction run] (self=0x9398ca8, _cmd=0x4f05a8) at WOHttpTransaction.m:599
#37 0x0041a810 in -[WOHttpAdaptor runConnection:] (self=0x91f1450, _cmd=0x4f05f8, _socket=0x9390d08) at WOHttpAdaptor.m:404
#38 0x0041aa91 in -[WOHttpAdaptor _handleAcceptedConnection:] (self=0x91f1450, _cmd=0x4f0600, _connection=0x9390d08) at WOHttpAdaptor.m:438
#39 0x0041b2f8 in -[WOHttpAdaptor _handleConnection:] (self=0x91f1450, _cmd=0x4f0680, connection=0x9390d08) at WOHttpAdaptor.m:549
#40 0x0041b720 in -[WOHttpAdaptor acceptConnection:] (self=0x91f1450, _cmd=0x4f0588, _notification=0x93e9270) at WOHttpAdaptor.m:607
#41 0x0105d3cd in -[NSNotificationCenter _postAndRelease:] (self=0x8f8a750, _cmd=0x126d268, notification=0x93e9270) at NSNotificationCenter.m:1070
#42 0x0105dce0 in -[NSNotificationCenter postNotificationName:object:userInfo:] (self=0x8f8a750, _cmd=0x126d270, name=0x589b00, object=0x92f8198, info=0x0) at NSNotificationCenter.m:1129
#43 0x0105db95 in -[NSNotificationCenter postNotificationName:object:] (self=0x8f8a750, _cmd=0x589c08, name=0x589b00, object=0x92f8198) at NSNotificationCenter.m:1109
---Type <return> to continue, or q <return> to quit---
#44 0x00554e84 in -[NSObject(FileObjectWatcher) receivedEvent:type:extra:forMode:] (self=0x92f8198, _cmd=0x12b62f8, _fdData=0x6, _type=ET_RDESC, _extra=0x6, _mode=0x127d1b8)
    at NSRunLoop+FileObjects.m:57
#45 0x01157958 in -[GSRunLoopCtxt pollUntil:within:] (self=0x9088c08, _cmd=0x127da10, milliseconds=29972, contexts=0x9082a18) at GSRunLoopCtxt.m:598
#46 0x010a41b1 in -[NSRunLoop acceptInputForMode:beforeDate:] (self=0x9085cc8, _cmd=0x127da38, mode=0x127d1b8, limit_date=0x926ec18) at NSRunLoop.m:1174
#47 0x010a45f4 in -[NSRunLoop runMode:beforeDate:] (self=0x9085cc8, _cmd=0x490210, mode=0x127d1b8, date=0x9079998) at NSRunLoop.m:1249
#48 0x003649d0 in -[WOCoreApplication run] (self=0x905f720, _cmd=0x8050a88) at WOCoreApplication.m:576
#49 0x08049f16 in -[SOGo run] (self=0x905f720, _cmd=0x4a6a10) at SOGo.m:247
#50 0x003963fc in WOApplicationMain (_appClassName=0x804f9a0, argc=7, argv=0xbfa21084) at WOApplicationMain.m:42
#51 0x003bb9e5 in WOWatchDogApplicationMain (appName=0x804f9a0, argc=7, argv=0xbfa21084) at WOWatchDogApplicationMain.m:980
#52 0x080491f6 in main (argc=7, argv=0xbfa21084, env=0xbfa210a4) at sogod.m:53

backtrace.txt (7,557 bytes)   

2010-04-28 10:22

 

tcp-stream.txt (2,184 bytes)   
14 select "INBOX.Sarah"


* FLAGS (\Draft \Answered \Flagged \Deleted \Seen \Recent)
* OK [PERMANENTFLAGS (\* \Draft \Answered \Flagged \Deleted \Seen)] Limited
* 1 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 1272442981] Ok
* OK [MYRIGHTS "acdilrsw"] ACL
14 OK [READ-WRITE] Ok

15 UID SORT (REVERSE ARRIVAL) UTF-8 NOT DELETED


* SORT 147
15 OK SORT done.

16 uid fetch 147 (UID FLAGS ENVELOPE RFC822.SIZE BODYSTRUCTURE BODY.PEEK[HEADER.FIELDS (X-PRIORITY)])


* 1 FETCH (UID 147 FLAGS (\Seen) ENVELOPE ("Fri, 23 Apr 2010 15:42:43 +0200" "Fwd: Einladung zur 'Open Source Forum'-Partnerschaft" (("Thomas Haenni" NIL "thomas.haenni" "indato.ch")) (("Thomas Haenni" NIL "thomas.haenni" "indato.ch")) (("Thomas Haenni" NIL "thomas.haenni" "indato.ch")) ((NIL NIL "gl" "indato.ch")) NIL NIL NIL "<201004231542.43598.thomas.haenni@indato.ch>") RFC822.SIZE 2603697 BODYSTRUCTURE (("text" "plain" ("charset" "iso-8859-1") NIL NIL "quoted-printable" 89 6 NIL NIL NIL)("message" "rfc822" ("name" "forwarded message") NIL "\"Claudio Dionisio\" <claudio.dionisio@uvision.ch>: Einladung zur 'Open Source Forum'-Partnerschaft" "7bit" 2601692 ("Tue, 20 Apr 2010 14:07:04 +0200" "Einladung zur 'Open Source Forum'-Partnerschaft" (("Claudio Dionisio" NIL "claudio.dionisio" "uvision.ch")) (("Claudio Dionisio" NIL "claudio.dionisio" "uvision.ch")) (("Claudio Dionisio" NIL "claudio.dionisio" "uvision.ch")) ((NIL NIL "thomas.haenni" "indato.ch")) NIL NIL NIL "<009c01cae081$fe0f0280$fa2d0780$@dionisio@
uvision.ch>") ((("text" "plain" ("charset" "iso-8859-1") NIL NIL "quoted-printable" 2464 84 NIL NIL NIL)("text" "html" ("charset" "iso-8859-1") NIL NIL "quoted-printable" 6789 209 NIL NIL NIL) "alternative" ("boundary" "----=_NextPart_001_009E_01CAE092.C197D280") NIL NIL)("application" "pdf" ("name" "Open Source Forum 2010_Partner Package.pdf") NIL NIL "base64" 2589264 NIL ("attachment" ("filename" "Open Source Forum 201
0_Partner Package.pdf")) NIL) "mixed" ("boundary" "----=_NextPart_000_009D_01CAE092.C197D280") NIL "de-ch") 33568 NIL ("inline" NIL) NIL) "mixed" ("boundary" "Boundary-00=_TPa0L6M3IH1AYUz") NIL NIL) BODY[HEADER.FIELDS ("X-PRIORITY")] {2}

)
16 OK FETCH completed.

tcp-stream.txt (2,184 bytes)   

2010-04-28 10:23

 

crash.log (4,002 bytes)
julien

julien

2010-04-28 10:26

reporter   ~0000984

And it seems the crash occur during the fetch from mail header only, so the actual content doesn't seem relevant...

roberto

roberto

2010-05-18 11:09

reporter   ~0001026

I've been able to find a message and the string to reproduce the crash. No idea why is this happening. In a forwarded mail, I found an address between quotation marks (line 122 of the file mailwithquotes.txt) that makes SOGo fail. I tried putting the same quotation in other addresses and SOGo didn't crash... If I put simple quotations marks or if I erase them all mails get read again. I snipped the Base64 encoded part of the message to make it smaller. HTH. TIA.

2010-05-18 11:10

 

mailwithquotes.txt (8,718 bytes)   
Return-path: <maugusto@mydomain>
Envelope-to: myuser@mydomain,
 jda@mydomain
Delivery-date: Fri, 14 May 2010 09:36:14 -0300
Received: from [192.168.144.132]
	by mail.mydomain with esmtp (Exim 4.69)
	(envelope-from <maugusto@mydomain>)
	id 1OCu7h-0002c4-7i; Fri, 14 May 2010 09:36:13 -0300
Message-ID: <4BED438E.7000600@mydomain>
Date: Fri, 14 May 2010 09:35:26 -0300
From: Marita Augusto <maugusto@mydomain>
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
To: Alfonso Brandi <abrandi@mydomain>, 
 Alfredo Baroni <abaroni@mydomain>,
 Andrea Antonietti <antonietti@mydomain>, =?ISO-8859-1?Q?Bety_L=F3pez?=
 <blopez@mydomain>, Carina Villatoro <cvillatoro@mydomain>, 
 =?ISO-8859-1?Q?Cecilia_Fern=E1ndez?= <cfernand@mydomain>, 
 Celeste Campoo <campoo@mydomain>,
 Claudia Levada <clevada@mydomain>, 
 Claudia Lisandrello <clissandrello@mydomain>,
 =?ISO-8859-1?Q?Claudia_Maman=ED?= <cmamani@mydomain>, 
 COMPETENCIAS LABORALES <competencias@mydomain>,
 Cristian Perez <candru@mydomain>, =?ISO-8859-1?Q?DIFUSI=D3N?=
 <difusion@mydomain>, =?ISO-8859-1?Q?Enrique_Ad=E1n?=
 <eadan@mydomain>, =?ISO-8859-1?Q?Fabi=E1n_Barone?=
 <fbarone@mydomain>, Federico Alegre <falegre@mydomain>, 
 Flavia Dalmau <fdalmau@mydomain>,
 Gabriela Estevez <gestevez@mydomain>, 
 GERENCIA GENERAL <gerencia@mydomain>,
 Gonzalo Camacho <gcamacho@mydomain>, Gustavo Aloy <galoy@mydomain>, 
 Gustavo Ruiz <gruiz@mydomain>,
 =?ISO-8859-1?Q?Hern=E1n_Puga?= <hpuga@mydomain>, =?ISO-8859-1?Q?Hern=E1?=
 =?ISO-8859-1?Q?n_Rovati?= <hrovati@mydomain>, 
 Horacio Marasso <hmarasso@mydomain>,
 Iris Santilli <isantilli@mydomain>, =?ISO-8859-1?Q?Jefes_de_=E1rea?=
 =?ISO-8859-1?Q?_IDR?= <jda@mydomain>, =?ISO-8859-1?Q?Jos=E9_Luis_C?=
 =?ISO-8859-1?Q?ruz?= <jlcruz@mydomain>, 
 Liliana Fernandez <lfernandez@mydomain>,
 Lorena Nuarte <lnuarte@mydomain>, =?ISO-8859-1?Q?Luc=EDa_Pannochia?=
 <lpanno@mydomain>, Mabel Pereyra <mpereyra@mydomain>, 
 =?ISO-8859-1?Q?Mar=EDa_Jimena_Dalla_Torre?= <mjdallatorre@mydomain>, 
 Mariana Rios <mrios@mydomain>,
 Mariela Rios Rolla <marios@mydomain>, 
 Mariela Rojas <mariela.rojas@mydomain>,
 Marita Augusto <maugusto@mydomain>, =?ISO-8859-1?Q?Mart=EDn_P=E9rez?=
 <mperez@mydomain>, =?ISO-8859-1?Q?Mary_Pe=F1a?= <mpenia@mydomain>, 
 Mercedes Gatica <mgatica@mydomain>,
 Nahir Oliva <noliva@mydomain>, =?ISO-8859-1?Q?Natalia_Z=E1rate?=
 <nzarate@mydomain>, =?ISO-8859-1?Q?Nicol=E1s_Guti=E9rrez?=
 <ngutierrez@mydomain>, =?ISO-8859-1?Q?Norma_Garc=EDa?=
 <ngarcia@mydomain>, Oscar Giordano <ogiordano@mydomain>, 
 Pablo Potaschner <potaschner@mydomain>,
 Ramiro Gonzalez Feltrup <rgonzalez@mydomain>, 
 Roberto Burgos <"roberto.burgos"@mydomain>,
 Roberto Meyer <myuser@mydomain>, 
 Romina Beltrame <rbeltrame@mydomain>,
 Sergio Velocce <svelocce@mydomain>, Tania Peral <tperal@mydomain>, 
 Victoria Farmache <vfarmache@mydomain>
Subject: =?ISO-8859-1?Q?Invitaci=F3n_Acto_de_Lanzamiento_Programa?=
 =?ISO-8859-1?Q?_de_Formaci=F3n_en_Vinculaci=F3n_y_Gesti=F3n_?=
 =?ISO-8859-1?Q?Tecnol=F3gica?=
Content-Type: multipart/mixed;
 boundary="------------030500080108050407030200"

This is a multi-part message in MIME format.
--------------030500080108050407030200
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit

Estimados:
Colaboramos con la difusi�n del siguiente evento.
Atte.

-- 
Lic. Mar�a Alicia Augusto 
Comunicaci�n Institucional
IDR (Instituto de Desarrollo Rural)
www.mydomain
San Mart�n 601, 3� piso. 
Tel. 54 261 4056000/40


--------------030500080108050407030200
Content-Type: message/rfc822;
 name="[Vinc-oscivil] =?ISO-8859-1?Q?Invitaci=F3n_Acto_de_Lanzamiento_Pr?==?ISO-8859-1?Q?ograma_de_Formaci=F3n_en_Vinculaci=F3n_y_Gest?==?ISO-8859-1?Q?i=F3n_Tecnol=F3gica=2Eeml?="
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;
 filename*0*=ISO-8859-1''%5B%56%69%6E%63%2D%6F%73%63%69%76%69%6C%5D%20%49;
 filename*1*=%6E%76%69%74%61%63%69%F3%6E%20%41%63%74%6F%20%64%65%20%4C%61;
 filename*2*=%6E%7A%61%6D%69%65%6E%74%6F%20%50%72%6F%67%72%61%6D%61%20%64;
 filename*3*=%65%20%46%6F%72%6D%61%63%69%F3%6E%20%65%6E%20%56%69%6E%63%75;
 filename*4*=%6C%61%63%69%F3%6E%20%79%20%47%65%73%74%69%F3%6E%20%54%65%63;
 filename*5*=%6E%6F%6C%F3%67%69%63%61%2E%65%6D%6C

Return-path: <vinc-oscivil-bounces@listas.unl.edu.ar>
Envelope-to: info@mydomain
Delivery-date: Thu, 13 May 2010 14:57:58 -0300
Received: from smtp2.unl.edu.ar ([168.96.132.8])
	by mail.mydomain with esmtp (Exim 4.69)
	(envelope-from <vinc-oscivil-bounces@listas.unl.edu.ar>)
	id 1OCcfU-0002Pm-NR
	for info@mydomain; Thu, 13 May 2010 14:57:58 -0300
Received: from smtp2.unl.edu.ar (localhost [127.0.0.1])
	by smtp2.unl.edu.ar (Postfix) with ESMTP id B841C1915D;
	Thu, 13 May 2010 14:57:52 -0300 (ART)
X-Original-To: vinc-oscivil@listas.unl.edu.ar
Delivered-To: vinc-oscivil@listas.unl.edu.ar
Received: from smtp.unl.edu.ar (smtp3.unl.edu.ar [168.96.132.123])
	by smtp2.unl.edu.ar (Postfix) with ESMTP id A4DAF192E6;
	Thu, 13 May 2010 14:07:23 -0300 (ART)
Received: from localhost (localhost [127.0.0.1])
	by smtp.unl.edu.ar (Postfix) with ESMTP id 6F4D86E0A9;
	Thu, 13 May 2010 14:07:23 -0300 (ART)
Received: from smtp.unl.edu.ar ([127.0.0.1])
	by localhost (smtp3.unl.edu.ar [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id zTEx8gCZjPoF; Thu, 13 May 2010 14:07:23 -0300 (ART)
Received: from marianela (fwvincu.unl.edu.ar [168.96.132.153])
	by smtp.unl.edu.ar (Postfix) with SMTP id 44FDA6E097;
	Thu, 13 May 2010 14:07:23 -0300 (ART)
Message-ID: <010401caf2cf$bbf30b20$d050a8c0@marianela>
To: <"Undisclosed-Recipient:;"@smtp3.unl.edu.ar>
Date: Thu, 13 May 2010 14:08:55 -0500
MIME-Version: 1.0
Content-Type: multipart/mixed;
	boundary="----=_NextPart_000_00FF_01CAF2A5.D30C6150"
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2900.3598
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3350
X-EsetScannerBuild: 7023
X-Mailman-Approved-At: Thu, 13 May 2010 14:24:24 -0300
From: vinc-oscivil@listas.unl.edu.ar
Subject: [Vinc-oscivil] =?iso-8859-1?q?Invitaci=F3n_Acto_de_Lanzamiento_Pr?=
	=?iso-8859-1?q?ograma_de_Formaci=F3n_en_Vinculaci=F3n_y_Gesti=F3n_?=
	=?iso-8859-1?q?Tecnol=F3gica?=
X-BeenThere: vinc-oscivil@listas.unl.edu.ar
X-Mailman-Version: 2.1.11
Precedence: list
Reply-To: vinculacion@unl.edu.ar, vinc-oscivil@listas.unl.edu.ar
List-Id: <vinc-oscivil.listas.unl.edu.ar>
List-Unsubscribe: <http://listas.unl.edu.ar/mailman/options/vinc-oscivil>,
	<mailto:vinc-oscivil-request@listas.unl.edu.ar?subject=unsubscribe>
List-Archive: <http://listas.unl.edu.ar/mailman/private/vinc-oscivil>
List-Post: <mailto:vinc-oscivil@listas.unl.edu.ar>
List-Help: <mailto:vinc-oscivil-request@listas.unl.edu.ar?subject=help>
List-Subscribe: <http://listas.unl.edu.ar/mailman/listinfo/vinc-oscivil>,
	<mailto:vinc-oscivil-request@listas.unl.edu.ar?subject=subscribe>
Sender: vinc-oscivil-bounces@listas.unl.edu.ar
Errors-To: vinc-oscivil-bounces@listas.unl.edu.ar
X-Spam-Report: Spam scan skipped; message too large

This is a multi-part message in MIME format.

------=_NextPart_000_00FF_01CAF2A5.D30C6150
Content-Type: multipart/related;
	type="multipart/alternative";
	boundary="----=_NextPart_001_0100_01CAF2A5.D30EAB40"


------=_NextPart_001_0100_01CAF2A5.D30EAB40
Content-Type: multipart/alternative;
	boundary="----=_NextPart_002_0101_01CAF2A5.D30EAB40"


------=_NextPart_002_0101_01CAF2A5.D30EAB40
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable


------=_NextPart_002_0101_01CAF2A5.D30EAB40
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content=3D"text/html; charset=3Diso-8859-1" =
http-equiv=3DContent-Type>
<META name=3DGENERATOR content=3D"MSHTML 8.00.6001.18702">
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><IMG border=3D0 hspace=3D0 alt=3D"" align=3Dbaseline=20
src=3D"cid:00f901caf2cf$bbdb3d60$d050a8c0@marianela"></DIV></BODY></HTML>=


------=_NextPart_002_0101_01CAF2A5.D30EAB40--

------=_NextPart_001_0100_01CAF2A5.D30EAB40
Content-Type: image/jpeg;
	name="invitacion Lanzamiento GTEC Litoral - Centro.jpg"
Content-Transfer-Encoding: base64
Content-ID: <00f901caf2cf$bbdb3d60$d050a8c0@marianela>

<BASE64 part snipped>

------=_NextPart_000_00FF_01CAF2A5.D30C6150
Content-Type: text/plain; charset="iso-8859-1"
MIME-Version: 1.0
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

_______________________________________________
Vinc-oscivil mailing list
Vinc-oscivil@listas.unl.edu.ar
http://listas.unl.edu.ar/mailman/listinfo/vinc-oscivil

------=_NextPart_000_00FF_01CAF2A5.D30C6150--

--------------030500080108050407030200--
mailwithquotes.txt (8,718 bytes)   
roberto

roberto

2010-05-18 12:49

reporter   ~0001027

Another mail which caused I couldn't read my inbox (mail2.txt uploaded)

May 18 13:28:47 sogod: SOGo watchdog [3707]: <0x0x8c61718[NGImap4Client]> ERROR(-[NGImap4Client _processCommandParserException:]): catched IMAP4 parser exception NGImap4ParserException: unexpected char <C> expected < >
May 18 13:28:47 sogod: SOGo watchdog [3707]: [ERROR] <0x0x81c97a0[NGImap4Connection]> could not fetch 11 uids for url: imap://myuser%40mydomain@localhost/INBOX/
EXCEPTION: <NSException: 0x8862030> NAME:NSInvalidArgumentException REASON:Tried to add nil to array INFO:(nil)

2010-05-18 12:49

 

mail2.txt (3,690 bytes)   
Return-path: <fbarone@mydomain>
Envelope-to: myuser@mydomain
Delivery-date: Tue, 18 May 2010 13:27:21 -0300
Received: from [192.168.144.69]
	by mail.mydomain with esmtp (Exim 4.69)
	(envelope-from <fbarone@mydomain>)
	id 1OEPdZ-0000ws-M3; Tue, 18 May 2010 13:27:21 -0300
Message-ID: <4BF2BFE6.4060304@mydomain>
Date: Tue, 18 May 2010 13:27:18 -0300
From: Fabian Barone <fbarone@mydomain>
User-Agent: Thunderbird 2.0.0.24 (X11/20100411)
MIME-Version: 1.0
To: myuser@mydomain, fbarone@mydomain
Subject: [Fwd: Event Invitation: =?UTF-8?B?IkNvbWlzacOzbiBJbnRlcm5hIENlbnM=?=
 =?UTF-8?B?byJd?=
Content-Type: multipart/mixed;
 boundary="------------070800040106080709000203"

This is a multi-part message in MIME format.
--------------070800040106080709000203
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit

vaaaaaa

--------------070800040106080709000203
Content-Type: message/rfc822;
 name="Event Invitation: =?UTF-8?B?IkNvbWlzacOzbiBJbnRlcm5hIENlbnNvIi5lbWw=?="
Content-Transfer-Encoding: 8bit
Content-Disposition: inline;
 filename*0*=UTF-8''%45%76%65%6E%74%20%49%6E%76%69%74%61%74%69%6F%6E%3A%20;
 filename*1*=%22%43%6F%6D%69%73%69%C3%B3%6E%20%49%6E%74%65%72%6E%61%20%43;
 filename*2*=%65%6E%73%6F%22%2E%65%6D%6C

Return-path: <abaroni@mydomain>
Envelope-to: fbarone@mydomain
Delivery-date: Tue, 04 May 2010 12:07:16 -0300
Received: from localhost ([127.0.0.1])
	by mail.mydomain with esmtp (Exim 4.69)
	(envelope-from <abaroni@mydomain>)
	id 1O9JiO-0004Il-1r
	for fbarone@mydomain; Tue, 04 May 2010 12:07:16 -0300
from: =?utf-8?q?Alfredo=20Baroni?= <abaroni@mydomain>
content-type: multipart/mixed; boundary="----=_=-_OpenGroupware_org_NGMime-16241-1272985635.906759-2------"
subject: =?utf-8?q?Event_Invitation:_"Comisi=C3=B3n_Interna_Censo"?=
date: Tue, 04 May 2010 12:07:15 -0300
MIME-Version: 1.0
to: fbarone@mydomain

------=_=-_OpenGroupware_org_NGMime-16241-1272985635.906759-2------
content-type: text/plain; charset="utf-8"

Alfredo Baroni has invited you to Comisión Interna Censo.
------=_=-_OpenGroupware_org_NGMime-16241-1272985635.906759-2------
content-transfer-encoding: quoted-printable
content-type: text/calendar; method=REQUEST; charset="utf-8"

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VTIMEZONE
TZID:America/Araguaina
X-LIC-LOCATION:America/Araguaina
BEGIN:STANDARD
TZOFFSETFROM:-0300
TZOFFSETTO:-0300
TZNAME:BRT
DTSTART:19700101T000000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20100504T150550Z
LAST-MODIFIED:20100504T150710Z
DTSTAMP:20100504T150710Z
UID:e7ded8f5-d7a5-4be4-817c-a3fa9420a238
SUMMARY:Comisi=C3=B3n Interna Censo
ORGANIZER;PARTSTAT=3DACCEPTED;ROLE=3DCHAIR;RSVP=3DTRUE;CN=3DAlfredo Baroni:mailto:a
 baroni@mydomain
ATTENDEE;PARTSTAT=3DNEEDS-ACTION;ROLE=3DREQ-PARTICIPANT;RSVP=3DTRUE;CN=3DHernan Pug
 a - IDR:mailto:hpuga@mydomain
ATTENDEE;PARTSTAT=3DNEEDS-ACTION;ROLE=3DREQ-PARTICIPANT;RSVP=3DTRUE;CN=3DRoberto Me
 yer:mailto:myuser@mydomain
ATTENDEE;PARTSTAT=3DNEEDS-ACTION;ROLE=3DREQ-PARTICIPANT;RSVP=3DTRUE;CN=3DFabian Bar
 one:mailto:fbarone@mydomain
ATTENDEE;PARTSTAT=3DNEEDS-ACTION;ROLE=3DREQ-PARTICIPANT;RSVP=3DTRUE;CN=3DMart=C3=ADn Per
 ez:mailto:mperez@mydomain
ATTENDEE;PARTSTAT=3DNEEDS-ACTION;ROLE=3DREQ-PARTICIPANT;RSVP=3DTRUE;CN=3DSrta. CECI
 LIA FERNANDEZ:mailto:cfernand@mydomain
ATTENDEE;PARTSTAT=3DNEEDS-ACTION;ROLE=3DREQ-PARTICIPANT;RSVP=3DTRUE;CN=3DMariana Ri
 os:mailto:mrios@mydomain
DTSTART;TZID=3DAmerica/Araguaina:20100507T091500
DTEND;TZID=3DAmerica/Araguaina:20100507T110000
END:VEVENT
END:VCALENDAR

------=_=-_OpenGroupware_org_NGMime-16241-1272985635.906759-2--------





--------------070800040106080709000203--
mail2.txt (3,690 bytes)   
roberto

roberto

2010-05-18 13:59

reporter   ~0001028

Last edited: 2010-05-18 14:05

A follow up to my latest post, I took away the double quotes of the subject of mail2.txt (line 45) and could read the mails again. Both cases were solved taking away the double quotes. We've some kind of a pattern here :-)

I'm using Debian Lenny, latest sogo packages, UTF-8 charset, Courier-imap, exim, maildir storage format.

julien

julien

2010-05-19 03:12

reporter   ~0001036

Good catch !

I reviewed my mail and also found a problematic double quote
In the tcp-stream.txt above, there is the following:
("name" "forwarded message") NIL "\"Claudio Dionisio\" <claudio.dionisio@uvision.ch>: Einladung zur 'Open Source Forum'-Partnerschaft" "7bit"

Corresponding to the following header:
...
Content-Type: message/rfc822; name="forwarded message"
Content-Transfer-Encoding: 7bit
Content-Description: "Claudio Dionisio" <claudio.dionisio@uvision.ch>:
Einladung zur 'Open Source Forum'-Partnerschaft
...

Removing the double quote from Content-Description solves the crash in SOGo.

I'm also using Courier-imap, so, it seems that courier-imap escapes the " with \
but the SOGo parser doesn't like it very much.

interesting...

ludovic

ludovic

2010-06-23 16:57

administrator   ~0001124

Fixed with http://mtn.inverse.ca/revision/diff/8e1a3af5628f31703023508d2fb742a933691c15/with/3316e8de631c5da2b7ba6c4505fa74b707b80b51

Issue History

Date Modified Username Field Change
2009-07-09 10:50 julien New Issue
2009-07-09 10:50 julien File Added: message.txt
2009-07-23 13:19 wsourdeau Note Added: 0000041
2009-07-28 05:39 julien File Added: imap.txt
2009-07-28 05:41 julien Note Added: 0000054
2010-04-15 07:32 joaquinllano Note Added: 0000951
2010-04-28 10:12 julien Note Added: 0000983
2010-04-28 10:22 julien File Added: backtrace.txt
2010-04-28 10:22 julien File Added: tcp-stream.txt
2010-04-28 10:23 julien File Added: crash.log
2010-04-28 10:26 julien Note Added: 0000984
2010-05-18 11:09 roberto Note Added: 0001026
2010-05-18 11:10 roberto File Added: mailwithquotes.txt
2010-05-18 12:49 roberto Note Added: 0001027
2010-05-18 12:49 roberto File Added: mail2.txt
2010-05-18 13:59 roberto Note Added: 0001028
2010-05-18 14:05 roberto Note Edited: 0001028
2010-05-19 03:12 julien Note Added: 0001036
2010-06-10 21:06 ludovic Target Version => 1.2.3
2010-06-11 15:03 wsourdeau Status new => assigned
2010-06-11 15:03 wsourdeau Assigned To => wsourdeau
2010-06-23 16:57 ludovic Note Added: 0001124
2010-06-23 16:57 ludovic Status assigned => resolved
2010-06-23 16:57 ludovic Fixed in Version => 1.3.0
2010-06-23 16:57 ludovic Resolution open => fixed