View Issue Details

IDProjectCategoryView StatusLast Update
0000554SOGoBackend Mailpublic2010-09-16 14:22
ReporterwsourdeauAssigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Fixed in Version1.3.2 
Summary0000554: email address headers with a display name containing a "@" seems badly interpreted
Description

When sending a mail with a From: "wolfgang@test.com" <wolfgang@test.com>,
the corresponding field in the resulting message in the sent box is displayed as this: =?utf-8?q?wolfgang@test.com?= (Dovecot) or =?utf-8?q?wolfgang@test.com = <wolfgang@test.com> (Cyrus).

Since SOGo uses the envelope data from the IMAP server to display those headers, there is not a lot that can be done. It seems that the problem lies in the fact that the imap servers use the first "@" to separate the components, without taking the QP quoting into account. Would that be a bug in the way SOGo/SOPE encode those addresses?

TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2010-08-26 11:31

viewer   ~0001366

Fixed in the nigthlies.

Issue History

Date Modified Username Field Change
2010-04-08 12:10 wsourdeau New Issue
2010-08-26 11:31 wsourdeau Note Added: 0001366
2010-08-26 11:31 wsourdeau Status new => resolved
2010-08-26 11:31 wsourdeau Resolution open => fixed
2010-08-26 11:31 wsourdeau Assigned To => wsourdeau
2010-09-16 14:22 francis Fixed in Version => 1.3.2