View Issue Details

IDProjectCategoryView StatusLast Update
0000544SOGoWeb Mailpublic2010-04-06 10:32
Reporteraschild Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.2.2 
Summary0000544: HTML paste from word does not work
Description

When composing a new email in HTML mode in the web gui, the past from word does not work.

  1. Switch your webgui email format to use html mails
  2. Create a new email
  3. Open a MS word 2007 document and copy parts of it to the clipboard
  4. Now select the edit window in sogo and press CTRL+V (Paste)

The pasted content briefly shows in the window, then the window is empty

If we do a past by right-click and select paste from the context menu, we receive the message that this is not allowed. It then opens a paste window where we can do the ctrl+v paste.
Here the content is shown, but as soon as we click OK on that window, the pasted content vanishes and the main editor window is blank....

Additional Information

Build 201004021051 on Debian lenny
Firefox 3.6.2 on Windows 7

Copy-Paste in plain-text format works fine, also pasting from non-MS Office stuff works.

TagsNo tags attached.

Activities

francis

francis

2010-04-06 09:08

administrator   ~0000872

Looks like a bug fixed in CKEditor 3.1.1 ( http://ckeditor.com/whatsnew ).

francis

francis

2010-04-06 10:32

administrator   ~0000873

Fixed in revision e63ebbcc6deba63bb09fed682c0c64d7967a0579

Issue History

Date Modified Username Field Change
2010-04-06 08:50 aschild New Issue
2010-04-06 09:08 francis Note Added: 0000872
2010-04-06 10:32 francis Note Added: 0000873
2010-04-06 10:32 francis Status new => resolved
2010-04-06 10:32 francis Fixed in Version => 1.2.2
2010-04-06 10:32 francis Resolution open => fixed
2010-04-06 10:32 francis Assigned To => francis