View Issue Details

IDProjectCategoryView StatusLast Update
0005359SOGoWeb Mailpublic2021-08-11 10:51
Reporterabdunazarov Assigned Tofrancis  
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionno change required 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version5.1.1 
Summary0005359: Blank page after login for only one user after update from SOGo 4 to SOGo 5
Description

Hello, friends!
Found a strange error after upgrading to version 5.
Only one user does not have an IMAP connection after logging in and the web interface shows a blank page.
And it happens only when I'm trying login whith my user klin_10sk1. In the same server all other users works normal.

In debug mode I see next last string in /var/log/sogo/sogo.log.
Jul 20 18:06:50 sogod [1992]: |SOGo| request took 0.026390 seconds to execute
Jul 20 18:06:50 sogod [1992]: 127.0.0.1 "GET /SOGo/so/klin_10sk1/Mail/view HTTP/1.1" 200 82472/0 0.027 - - 0 - 15

When I'm trying with other normal users, after that strings above SOGo starts IMAP connection:
Jul 20 18:14:00 sogod [1992]: <0x0x561c8b318460[NGImap4Client]> TLS started successfully.
Jul 20 18:14:01 sogod [1991]: |SOGo| request took 0.316299 seconds to execute
And it starts fetching mailbox content, messages uidlist etc.

Strange thing is that, when I've tried rollback one of my servers to version SOGo 4 and tested, this user logs in successfully and everything works fine in rolled back server

Can, please, anybody explain? What is going wrong here with SOGo 5 in my server?

I've tried sogo-tool remove klin_10sk1 and restore in from backup.

Additional Information

I've tried sogo-tool remove klin_10sk1 and restore in from backup.

TagsNo tags attached.

Activities

abdunazarov

abdunazarov

2021-07-20 12:09

reporter  

sogo.log (7,380 bytes)   
Jul 20 18:06:42 sogod [1992]: |SOGo| starting method 'GET' on uri '/SOGo'
Jul 20 18:06:42 sogod [1992]: |SOGo| request took 0.000388 seconds to execute
Jul 20 18:06:42 sogod [1992]: 127.0.0.1 "GET /SOGo HTTP/1.1" 302 0/0 0.001 - - 0 - 15
Jul 20 18:06:42 sogod [1992]: |SOGo| starting method 'GET' on uri '/SOGo/'
Jul 20 18:06:42 sogod [1992]: |SOGo|   constructed root-url: /SOGo/
Jul 20 18:06:42 sogod [1992]: |SOGo|   setting root-url in context: /SOGo/
Jul 20 18:06:42 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/
Jul 20 18:06:42 sogod [1992]: |SOGo| request took 0.008536 seconds to execute
Jul 20 18:06:42 sogod [1992]: 127.0.0.1 "GET /SOGo/ HTTP/1.1" 200 27228/0 0.009 - - 0 - 15
Jul 20 18:06:49 sogod [1992]: |SOGo| starting method 'POST' on uri '/SOGo/connect'
Jul 20 18:06:49 sogod [1992]: <0x0x561c8b1f5d30[NGLdapConnection]> Using ldap_initialize for LDAP URL: ldaps://my.domain.tld
Jul 20 18:06:49 sogod [1992]: SOGoRootPage successful login from '127.0.0.1' for user 'klin_10sk1' - expire = -1  grace = -1
2021-07-20 18:06:49.390 sogod[1992:1992] PG0x0x561c8b5aaa40 SQL: BEGIN TRANSACTION
2021-07-20 18:06:49.391 sogod[1992:1992] PG0x0x561c8b5aaa40 SQL: SELECT t1.c_creationdate, t1.c_id, t1.c_lastseen, t1.c_value FROM  sogo_sessions_folder t1 WHERE t1.c_id='BV42bCnMjlUT0ic2V8OpCA=='
2021-07-20 18:06:49.424 sogod[1992:1992] PG0x0x561c8b5aaa40 SQL: ROLLBACK TRANSACTION
2021-07-20 18:06:49.424 sogod[1992:1992] PG0x0x561c8b5c8c60 SQL: BEGIN TRANSACTION
2021-07-20 18:06:49.425 sogod[1992:1992] PG0x0x561c8b5c8c60 SQL: INSERT INTO sogo_sessions_folder (c_lastseen, c_creationdate, c_value, c_id) VALUES (1626793609, 1626793609, 'zunbwOzS/RsvmVp7nRL15cRNojAbG2kEi2rDK3cvo16dby/HgNum6kTGx8AMvwHcGtVqTAHZtkpSbWD8ZYjsYEjzM3IOJr2FcK9a7h8QG/qjNtQ2UnZk6VjOwyFfspd5qkY4N1Pf+jz7bKkKceRfBjX5eqzBI6NFuGZOZXzxbjYpjnKtzwGFRNzjOAJbnD2o3JHy4BHZhCsvzQXRuW9/mg==', 'BV42bCnMjlUT0ic2V8OpCA==')
2021-07-20 18:06:49.425 sogod[1992:1992] PG0x0x561c8b5c8c60 SQL: COMMIT TRANSACTION
2021-07-20 18:06:49.427 sogod[1992:1992] PG0x0x561c8b5aaa40 SQL: SELECT c_settings FROM sogo_user_profile WHERE c_uid = 'klin_10sk1'
Jul 20 18:06:49 sogod [1992]: |SOGo| request took 0.048139 seconds to execute
Jul 20 18:06:49 sogod [1992]: 127.0.0.1 "POST /SOGo/connect HTTP/1.1" 200 75/79 0.049 - - 0 - 15
Jul 20 18:06:50 sogod [1992]: |SOGo| starting method 'GET' on uri '/SOGo/klin_10sk1'
Jul 20 18:06:50 sogod [1992]: |SOGo| request took 0.003176 seconds to execute
Jul 20 18:06:50 sogod [1992]: 127.0.0.1 "GET /SOGo/klin_10sk1 HTTP/1.1" 302 0/0 0.004 - - 0 - 15
Jul 20 18:06:50 sogod [1992]: |SOGo| starting method 'GET' on uri '/SOGo/klin_10sk1/view'
Jul 20 18:06:50 sogod [1992]: |SOGo|   constructed root-url: /SOGo/
Jul 20 18:06:50 sogod [1992]: |SOGo|   setting root-url in context: /SOGo/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/
Jul 20 18:06:50 sogod [1992]: <0x561c8b28f220[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/klin_10sk1/view
  own: /SOGo/klin_10sk1
Jul 20 18:06:50 sogod [1992]: |SOGo| request took 0.003888 seconds to execute
Jul 20 18:06:50 sogod [1992]: 127.0.0.1 "GET /SOGo/klin_10sk1/view HTTP/1.1" 302 0/0 0.004 - - 0 - 15
Jul 20 18:06:50 sogod [1992]: |SOGo| starting method 'GET' on uri '/SOGo/so/klin_10sk1/Mail'
Jul 20 18:06:50 sogod [1992]: |SOGo| request took 0.002808 seconds to execute
Jul 20 18:06:50 sogod [1992]: 127.0.0.1 "GET /SOGo/so/klin_10sk1/Mail HTTP/1.1" 302 0/0 0.003 - - 0 - 15
Jul 20 18:06:50 sogod [1992]: |SOGo| starting method 'GET' on uri '/SOGo/so/klin_10sk1/Mail/view'
2021-07-20 18:06:50.490 sogod[1992:1992] PG0x0x561c8b5c8c60 SQL: SELECT c_settings FROM sogo_user_profile WHERE c_uid = 'klin_10sk1'
Jul 20 18:06:50 sogod [1992]: |SOGo|   constructed root-url: /SOGo/
Jul 20 18:06:50 sogod [1992]: |SOGo|   setting root-url in context: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: <0x561c8b223dc0[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/so/klin_10sk1/Mail/view
  own: /SOGo/so/klin_10sk1
Jul 20 18:06:50 sogod [1992]: |SOGo|   using root-url from context: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: <0x561c8b223dc0[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/so/klin_10sk1/Mail/view
  own: /SOGo/so/klin_10sk1
Jul 20 18:06:50 sogod [1992]: <0x561c8b5ab220[SOGoMailAccounts]:Mail> baseURL: name=Mail (container=SOGoUserFolder)
  container: /SOGo/so/klin_10sk1/
  own: /SOGo/so/klin_10sk1/Mail
Jul 20 18:06:50 sogod [1992]: |SOGo|   using root-url from context: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: <0x561c8b223dc0[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/so/klin_10sk1/Mail/view
  own: /SOGo/so/klin_10sk1
Jul 20 18:06:50 sogod [1992]: |SOGo|   using root-url from context: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: <0x561c8b223dc0[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/so/klin_10sk1/Mail/view
  own: /SOGo/so/klin_10sk1
Jul 20 18:06:50 sogod [1992]: |SOGo|   using root-url from context: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: <0x561c8b223dc0[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/so/klin_10sk1/Mail/view
  own: /SOGo/so/klin_10sk1
Jul 20 18:06:50 sogod [1992]: |SOGo|   using root-url from context: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: <0x561c8b223dc0[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/so/klin_10sk1/Mail/view
  own: /SOGo/so/klin_10sk1
Jul 20 18:06:50 sogod [1992]: |SOGo|   using root-url from context: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: <0x561c8b223dc0[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/so/klin_10sk1/Mail/view
  own: /SOGo/so/klin_10sk1
Jul 20 18:06:50 sogod [1992]: |SOGo|   using root-url from context: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: |SOGo| ROOT baseURL(no container, name=(null)):
  own: /SOGo/so/
Jul 20 18:06:50 sogod [1992]: <0x561c8b223dc0[SOGoUserFolder]:klin_10sk1> baseURL: name=klin_10sk1 (container=SOGo)
  container: /SOGo -- https://web.my.domain.tld/SOGo/so/klin_10sk1/Mail/view
  own: /SOGo/so/klin_10sk1
Jul 20 18:06:50 sogod [1992]: |SOGo| request took 0.026390 seconds to execute
Jul 20 18:06:50 sogod [1992]: 127.0.0.1 "GET /SOGo/so/klin_10sk1/Mail/view HTTP/1.1" 200 82472/0 0.027 - - 0 - 15
sogo.log (7,380 bytes)   
francis

francis

2021-08-02 10:11

administrator   ~0015403

Any error in your browser's console?

abdunazarov

abdunazarov

2021-08-09 11:24

reporter   ~0015408

Hello, Francis!
Thanks for your response.

Yes there is some errors related to two js files

Uncaught SyntaxError: '' string literal contains an unescaped line break view:1036:51
Uncaught ReferenceError: UserLogin is not defined
activeUser Common.app.js:17
factory User.service.js:24
Angular 33
Common.app.js:17:10
activeUser Common.app.js:17
factory User.service.js:24
Angular 33

And this error appears when I'm logging in with user klin_10sk1 in any browser in Linux and Windows OS

Errors-in-browser.txt (1,090 bytes)   
Uncaught SyntaxError: '' string literal contains an unescaped line break view:1036:51
Uncaught ReferenceError: UserLogin is not defined
    activeUser Common.app.js:17
    factory User.service.js:24
    Angular 33
        invoke
        e
        invoke
        G
        d
        e
        invoke
        e
        invoke
        G
        d
        e
        invoke
        e
        invoke
        G
        d
        e
        invoke
        e
        invoke
        G
        d
        e
        invoke
        fb
        r
        fb
        c
        Wc
        Ee
        <anonymous>
        b
Common.app.js:17:10
    activeUser Common.app.js:17
    factory User.service.js:24
    Angular 33
        invoke
        e
        invoke
        G
        d
        e
        invoke
        e
        invoke
        G
        d
        e
        invoke
        e
        invoke
        G
        d
        e
        invoke
        e
        invoke
        G
        d
        e
        invoke
        fb
        r
        fb
        c
        Wc
        Ee
        <anonymous>
        b
Errors-in-browser.txt (1,090 bytes)   
Screenshot_20210809.png (11,025 bytes)   
Screenshot_20210809.png (11,025 bytes)   
francis

francis

2021-08-09 14:05

administrator   ~0015410

Please privately attach the source of the "blank" page. Thanks.

francis

francis

2021-08-10 13:38

administrator   ~0015415

It looks like there's a line feed at the end of the user's email address.

What is the result of sogo-tool user-preferences get defaults klin_10sk1 SOGoMailIdentities?

abdunazarov

abdunazarov

2021-08-11 09:15

reporter   ~0015417

Francis, thank you very mach!
Really line feed at the end of the user's email address was caused this problem in SOGo 5
This user was created by script from a list of users in txt, probably user was last in that list
Seems in SOGo 4 it works with the line feed at the end of the user's email address. I've tried it in my rolled back server, there is also "\n" at the end of the address in the page source, but it works fine.

The result of sogo-tool user-preferences get defaults klin_10sk1 SOGoMailIdentities is:
sogo-tool[29966:29966] Value for key "SOGoMailIdentities" not found in defaults

Issue History

Date Modified Username Field Change
2021-07-20 12:09 abdunazarov New Issue
2021-07-20 12:09 abdunazarov File Added: sogo.log
2021-08-02 10:11 francis Note Added: 0015403
2021-08-09 11:24 abdunazarov Note Added: 0015408
2021-08-09 11:24 abdunazarov File Added: Errors-in-browser.txt
2021-08-09 11:24 abdunazarov File Added: Screenshot_20210809.png
2021-08-09 14:05 francis Note Added: 0015410
2021-08-10 13:38 francis Note Added: 0015415
2021-08-11 09:15 abdunazarov Note Added: 0015417
2021-08-11 10:51 francis Assigned To => francis
2021-08-11 10:51 francis Status new => closed
2021-08-11 10:51 francis Resolution open => no change required