View Issue Details

IDProjectCategoryView StatusLast Update
0005332SOGowith SOGopublic2021-06-02 07:22
Reporterhaf Assigned To 
PrioritynormalSeveritymajorReproducibilityrandom
Status newResolutionopen 
Product Version5.1.0 
Summary0005332: Problem with displaying SOGo in browser (with tested temporary solution )
Description

Hi, we have problem with displaying SOGo in web browser. Server generate bad code too often:
<link href="/SOGo?XML=true.woa/WebServerResources/img/sogo.ico?lm=1621369871" rel="shortcut icon" type="image/x-icon" />
<link href="/SOGo?XML=true.woa/WebServerResources/css/theme-default.css" rel="stylesheet" type="text/css" />
<link href="/SOGo?XML=true.woa/WebServerResources/css/styles.css" rel="stylesheet" type="text/css" />
Good code is generated only sometimes.
<link href="/SOGo.woa/WebServerResources/img/sogo.ico?lm=1621369871" rel="shortcut icon" type="image/x-icon" />
<link href="/SOGo.woa/WebServerResources/css/theme-default.css" rel="stylesheet" type="text/css" />
<link href="/SOGo.woa/WebServerResources/css/styles.css" rel="stylesheet" type="text/css" />

After restarting sogod and memcached, the system is more stable for some time.

Problem is here from sogo-5.1.0.20210513-1.el8, last tested good version for me was sogo-5.1.0.20210417-1.el8

Today I have installed:

CentOS Stream 8.5-3, iRedMail 1.3.2 OPENLDAP edition and
-------------------------------============================
sogo-activesync-5.1.0.20210526-1.el8.x86_64
sogo-ealarms-notify-5.1.0.20210526-1.el8.x86_64
sogo-tool-5.1.0.20210526-1.el8.x86_64
sogo-5.1.0.20210526-1.el8.x86_64
sope49-appserver-4.9-20210522_1664.el8.1.1.x86_64
sope49-cards-5.1.0.20210526-1.el8.x86_64
sope49-core-4.9-20210522_1664.el8.1.1.x86_64
sope49-gdl1-contentstore-5.1.0.20210526-1.el8.x86_64
sope49-gdl1-mysql-4.9-20210522_1664.el8.1.1.x86_64
sope49-gdl1-4.9-20210522_1664.el8.1.1.x86_64
sope49-ldap-4.9-20210522_1664.el8.1.1.x86_64
sope49-mime-4.9-20210522_1664.el8.1.1.x86_64
sope49-sbjson-2.3.1-20210522_1664.el8.1.1.x86_64
sope49-xml-4.9-20210522_1664.el8.1.1.x86_64
nginx-all-modules-1.14.1-9.module_el8.0.0+184+e34fea82.noarch
nginx-filesystem-1.14.1-9.module_el8.0.0+184+e34fea82.noarch
nginx-mod-http-image-filter-1.14.1-9.module_el8.0.0+184+e34fea82.x86_64
nginx-mod-http-perl-1.14.1-9.module_el8.0.0+184+e34fea82.x86_64
nginx-mod-http-xslt-filter-1.14.1-9.module_el8.0.0+184+e34fea82.x86_64
nginx-mod-mail-1.14.1-9.module_el8.0.0+184+e34fea82.x86_64
nginx-mod-stream-1.14.1-9.module_el8.0.0+184+e34fea82.x86_64
nginx-1.14.1-9.module_el8.0.0+184+e34fea82.x86_64

Steps To Reproduce

Periodically reload page, ideally direct view-source:https://some.path/SOGo/

Additional Information

Tested workaround

on CentOS iRedMail installation i changed nginx configuration

location ^~ /SOGo {
    proxy_pass http://127.0.0.1:20000;

    # forward user's IP address
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header Host $host;

    # always use https
    proxy_set_header x-webobjects-server-port $server_port;
    proxy_set_header x-webobjects-server-name $host;
    proxy_set_header x-webobjects-server-url  https://$host;

    proxy_set_header x-webobjects-server-protocol HTTP/1.0;

    # Tested workaround
    proxy_set_header Accept-Encoding &quot;&quot;;
    sub_filter_once off;
    sub_filter '=&quot;/SOGo?XML=true.woa/WebServerResources/'  '=&quot;/SOGo.woa/WebServerResources/';
}
TagsNo tags attached.

Activities

francis

francis

2021-06-01 12:12

administrator   ~0015294

You should contact the team of iRedMail.

Ref: https://github.com/iredmail/iRedMail/blob/master/samples/nginx/templates/sogo.tmpl

haf

haf

2021-06-02 07:22

reporter   ~0015298

My original configuration exactly matched https://github.com/iredmail/iRedMail/blob/master/samples/nginx/templates/sogo.tmpl

Issue History

Date Modified Username Field Change
2021-06-01 09:33 haf New Issue
2021-06-01 12:08 francis Additional Information Updated
2021-06-01 12:12 francis Note Added: 0015294
2021-06-02 07:22 haf Note Added: 0015298