View Issue Details

IDProjectCategoryView StatusLast Update
0005327SOGoPackaging (Debian)public2021-05-27 21:57
Reporterabma Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.1.0 
Fixed in Version5.1.1 
Summary0005327: logrotate fails on debian 10 with "error: skipping "/var/log/sogo/sogo.log" because parent directory has insecure permissions"
Description

the permissions of the logfile or the config of logrotate are invalid in the default config.

Steps To Reproduce

systemctl restart logrotate

see output of journalctl -u logrotate and systemctl

Additional Information

Mai 20 07:37:05 sv-jih logrotate[3712]: error: skipping "/var/log/sogo/sogo.log" because parent directory has insecure permissions (It's world writable or writable by group which is not "root")

uncommenting the "su sogo sogo" line fixes the logrotate config:

/etc/logrotate.d# cat sogo 
/var/log/sogo/*.log {
    daily
    missingok
    rotate 7
    compress
    delaycompress
    notifempty
    copytruncate
    # The 'su' parameter is normally not needed but in cases where two
    # instances of SOGo run in parallel under different UNIX users it
    # allows proper rotation; requires logrotate >= 3.8.0
    su sogo sogo
}
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master 88db6a53

2021-05-27 21:55:41

francis

Details Diff
chore(logrotate): fix ownership of log file

Fixes 0005327
Affected Issues
0005327
mod - Scripts/logrotate Diff File

Issue History

Date Modified Username Field Change
2021-05-20 01:45 abma New Issue
2021-05-27 07:33 francis Additional Information Updated
2021-05-27 21:56 francis Changeset attached => sogo master 88db6a53
2021-05-27 21:56 francis Assigned To => francis
2021-05-27 21:56 francis Resolution open => fixed
2021-05-27 21:57 francis Status new => resolved
2021-05-27 21:57 francis Fixed in Version => 5.1.1