View Issue Details

IDProjectCategoryView StatusLast Update
0005324SOGoWeb Generalpublic2021-05-25 12:26
Reporterdeveloper@gevonne.com Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.1.0 
Fixed in Version5.1.1 
Summary0005324: Error when selecting "Snooze" in an alarm reminder
Description

If you choose "Snooze for 10 minutes" in the alarm message a "Not found" error is showed

Steps To Reproduce

Precondition: In the calendars, you have events with alarms configured

  1. Log in to sogo webmail
  2. The alarm message is displayed and the "Snooze for 10 minutes" option is selected. A "Not found" error message is displayed.

A screenshot is attached.

Additional Information

This looks like a bug in the URL building:

May 06 17:13:19 sogod [20229]: 127.0.0.1 "GET /SOGo/so/user@example.com/personal/5EBA-60914600-3-1CC225C0.ics/view?snoozeAlarm=10 HTTP / 1.1" 404 208/0 0.006 - - 0 - 14
It seems that "Calendar" is missing in the URL.

Something like that:
GET /SOGo/so/user@example.com/Calendar/personal/5EBA-60914600-3-1CC225C0.ics/view?resetAlarm=yes

TagsNo tags attached.

Activities

developer@gevonne.com

developer@gevonne.com

2021-05-19 11:12

reporter  

alarm.png (6,577 bytes)   
alarm.png (6,577 bytes)   
alarm1.png (35,379 bytes)   
alarm1.png (35,379 bytes)   

Related Changesets

sogo: master d4a0b25c

2021-05-25 12:23:25

francis

Details Diff
fix(calendar(js)): fix URL for snoozing alarms

Fixes 0005324
Affected Issues
0005324
mod - UI/WebServerResources/js/Preferences/Preferences.service.js Diff File

Issue History

Date Modified Username Field Change
2021-05-19 11:12 developer@gevonne.com New Issue
2021-05-19 11:12 developer@gevonne.com File Added: alarm.png
2021-05-19 11:12 developer@gevonne.com File Added: alarm1.png
2021-05-25 12:25 francis Changeset attached => sogo master d4a0b25c
2021-05-25 12:25 francis Assigned To => francis
2021-05-25 12:25 francis Resolution open => fixed
2021-05-25 12:26 francis Status new => resolved
2021-05-25 12:26 francis Fixed in Version => 5.1.1