View Issue Details

IDProjectCategoryView StatusLast Update
0005151SOGoBackend Generalpublic2021-06-17 14:14
Reporterpstalder Assigned Tofrancis  
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel x64OSUbuntuOS Version20.04.1
Product Version5.0.0 
Fixed in Version5.2.0 
Summary0005151: SOGoInstallationGuide-5.0.0.pdf contains wrong suggested MySQL setting nnodb_file_format
Description

SOGoInstallationGuide-5.0.0.pdf recommends the following MySQL configuration settings on page 33

innodb_file_per_table = TRUE
innodb_file_format = barracuda
innodb_large_prefix = TRUE

Parameter nnodb_file_format was depricated since a while and has been removed in MySQL 8.0.0.
The three recommended parameters can be left away since the should be default now.

Steps To Reproduce

MySQL Database does not start with 'innodb_file_format = barracuda' entry in configuration file - parameter is now unknown.

Additional Information

ubuntu 20.04.1 LTS contains MySQL 8.0.0.
The problem will exist in all OS distributions with MySQL >= 8.0.0

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master 97657935

2021-06-17 14:12:40

francis

Details Diff
docs: update MySQL recommendations for unicode compliance

Fixes 0005151
Affected Issues
0005151
mod - Documentation/SOGoInstallationGuide.asciidoc Diff File

Issue History

Date Modified Username Field Change
2020-09-07 14:51 pstalder New Issue
2021-06-17 14:14 francis Changeset attached => sogo master 97657935
2021-06-17 14:14 francis Assigned To => francis
2021-06-17 14:14 francis Resolution open => fixed
2021-06-17 14:14 francis Status new => resolved
2021-06-17 14:14 francis Fixed in Version => 5.2.0