View Issue Details

IDProjectCategoryView StatusLast Update
0005119SOGoWeb Mailpublic2020-08-14 09:58
Reporterabma Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version5.0.1 
Summary0005119: display errors in To/From/CC fields when display name contains umlaut + comma (MISSING_DOMAIN / unspecified domain,...)
Description

when a contact entry contains a comma in display name, sogo shows weird stuff

Steps To Reproduce

login to demo.sogo.nu

go to address book
create new contact entry:
display name: Ääöö, üüßß
mail: test@example.com
save

go to mail:

write new mail, select the above entry
write some text
save

open mail in drafts:

sogo shows something weird in To: "
=?utf-8?q?=C3=84=C3=A4=C3=B6=C3=B6@unspecified-domain
_=C3=BC=C3=BC=C3=9F=C3=9F?="

Additional Information

tested with sogo nightly 4.3.2.20200803-1

TagsNo tags attached.

Activities

abma

abma

2020-08-04 02:39

reporter  

umlaut-fail.png (58,809 bytes)   
umlaut-fail.png (58,809 bytes)   
abma

abma

2020-08-06 04:48

reporter   ~0014643

sadly its not a display error only: when replying to such a mail, two mails are sent: one to the original sender and one to =?utf-8?q?=C3=84=C3=A4=C3=B6=C3=B6@unspecified-domain, so IMHO this is a urgent bug.

abma

abma

2020-08-11 07:09

reporter   ~0014665

can be still reproduced with sogo 5.0.0 on demo.sogo.nu.

rof

rof

2020-08-13 11:21

reporter   ~0014696

The error is very annoying, because the sender addresses are broken when replying. We hope for a quick fix.

francis

francis

2020-08-14 09:58

administrator   ~0014697

See https://github.com/inverse-inc/sope/commit/4527e6a5c37fb26157ca04ae33591710cbbac68b

Issue History

Date Modified Username Field Change
2020-08-04 02:39 abma New Issue
2020-08-04 02:39 abma File Added: umlaut-fail.png
2020-08-04 08:44 francis Summary display errors in To/From/CC fields when display name contains umlaut + comman (MISSING_DOMAIN / unspecified domain,...) => display errors in To/From/CC fields when display name contains umlaut + comma (MISSING_DOMAIN / unspecified domain,...)
2020-08-06 04:48 abma Note Added: 0014643
2020-08-11 07:09 abma Note Added: 0014665
2020-08-13 11:21 rof Note Added: 0014696
2020-08-14 09:58 francis Assigned To => francis
2020-08-14 09:58 francis Status new => resolved
2020-08-14 09:58 francis Resolution open => fixed
2020-08-14 09:58 francis Fixed in Version => 5.0.1
2020-08-14 09:58 francis Note Added: 0014697