View Issue Details

IDProjectCategoryView StatusLast Update
0005093SOGoWeb Mailpublic2020-08-04 12:11
Reporterdragoangel Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status newResolutionopen 
Platform[Client] MicrosoftOSWindowsOS Version8
Product Version4.3.2 
Summary0005093: Emoji in identity broke From header
Description

If used set emoji in his identity from header will null.
I think if this isn't supported then there must be error on saving your identity with unsupported symbols.

Steps To Reproduce

1.Login to SOGo
2.Open Identity setting
3.Change your login to: One � at Zone 53
4.Try send email to someone
5.Check what mail rcpt get.

TagsNo tags attached.

Activities

dragoangel

dragoangel

2020-07-29 06:17

reporter   ~0014590

More correct:
4.Send email to yourself
5.Check send mail folder

dragoangel

dragoangel

2020-07-29 08:19

reporter   ~0014591

To note: I have Dovecot LMTP which doesn't support UTF8, so maybe it SOGo work with other backends, but I can't test this.
If this works with other backends, maybe there must be additional option in sogo.cfg to configure if UTF8 is allowed or not.

Christian Mack

Christian Mack

2020-08-04 12:09

developer   ~0014628

Did you set the display name including an emoji or set email address with emoji in local part or domain?

dragoangel

dragoangel

2020-08-04 12:11

reporter   ~0014629

I only set Display Name with Emoji. I can't add domain with emoji on backend, as it actually punycode =).

Issue History

Date Modified Username Field Change
2020-07-29 06:16 dragoangel New Issue
2020-07-29 06:17 dragoangel Note Added: 0014590
2020-07-29 08:19 dragoangel Note Added: 0014591
2020-08-04 12:09 Christian Mack Note Added: 0014628
2020-08-04 12:11 dragoangel Note Added: 0014629