View Issue Details

IDProjectCategoryView StatusLast Update
0004988SOGoActiveSyncpublic2020-03-22 15:11
Reportermazzzterrr Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.3.0 
Fixed in Version4.3.1 
Summary0004988: DisplayTo field contains wrong value
Description

In SOGoMailObject+ActiveSync.m this line:
// DisplayTo
[s appendFormat: @"<DisplayTo xmlns=\"Email:\">%@</DisplayTo>", [[context activeUser] login]];

It sets the DisplayTo field to the username/id/login, but it should set it to the name of the Recipient or at least the emailaddress of the recipient. In Nine mail this results in a sent items folder with all names set to my login name.

TagsNo tags attached.

Activities

tfu

tfu

2020-03-21 06:12

reporter   ~0014224

I tested with "Nine - Email & Calendar" but I'm not able to reproduce the problem. Before working on a fix I'd like to see the problem.

mazzzterrr

mazzzterrr

2020-03-22 08:42

reporter  

mazzzterrr

mazzzterrr

2020-03-22 08:42

reporter   ~0014225

See the attached screenshot from my email conversation with support from Nine, it displays rl where it should display Remco Luitwieler. According to Nine support this caused by the wrong DisplayTo field, although i think this is not the DisplayTo, because i am rl and therefore not the To, but the From. Nevertheless, i opened this ticket because Nine support asked me to.
The other screenshot is from the Sent Items folder and there we also see rl where it should display the Recipients name or emailaddress.
I also looked in the code from Horde Groupware and they are filling the DisplayTo field with name or emailaddres of recipient. Also the specification of ActiveSync prescribes the recipient in the DisplayTo field.

Related Changesets

sogo: master b8f31069

2020-03-22 12:15:18

root

Details Diff
fix(eas): fix invalid DisplayTo (fixes 0004988) Affected Issues
0004988
mod - ActiveSync/SOGoMailObject+ActiveSync.m Diff File

sogo: master 45eeb5fa

2020-03-22 14:04:59

ludovic


Committer: GitHub Details Diff
Merge pull request 0000270 from tfux/4988

fix(eas): fix invalid DisplayTo (fixes 0004988)
Affected Issues
0004988
mod - ActiveSync/SOGoMailObject+ActiveSync.m Diff File

Issue History

Date Modified Username Field Change
2020-03-19 04:44 mazzzterrr New Issue
2020-03-21 06:12 tfu Note Added: 0014224
2020-03-22 08:42 mazzzterrr File Added: Screenshot 2020-03-21 at 18.36.56.png
2020-03-22 08:42 mazzzterrr File Added: Screenshot 2020-03-22 at 13.28.26.png
2020-03-22 08:42 mazzzterrr Note Added: 0014225
2020-03-22 14:05 Changeset attached => sogo master b8f31069
2020-03-22 14:05 ludovic Changeset attached => sogo master 45eeb5fa
2020-03-22 14:05 ludovic Assigned To => ludovic
2020-03-22 14:05 ludovic Resolution open => fixed
2020-03-22 15:11 francis Status new => resolved
2020-03-22 15:11 francis Fixed in Version => 4.3.1