View Issue Details

IDProjectCategoryView StatusLast Update
0004933SOGoWeb Mailpublic2020-01-26 13:57
Reportersascha.kasch@sumcumo.com Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version4.3.0 
Summary0004933: An error occured while enabling auto-reply
Description

Since latest Update to 4.2.0 we face nightly errors with auto-replies:

<0x0xb54e60[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
<0x0xb54e60[SOGoCache]> Using host(s) '127.0.0.1' as server(s)
2020-01-09 00:00:02.547 sogo-tool[7131:7131] An error occured while removing auto-reply of user username
2020-01-09 00:00:03.347 sogo-tool[7131:7131] An error occured while enabling auto-reply of user username
2020-01-09 00:00:04.105 sogo-tool[7131:7131] An error occured while removing auto-reply of user username
2020-01-09 00:00:04.887 sogo-tool[7131:7131] An error occured while removing auto-reply of user username
2020-01-09 00:00:05.748 sogo-tool[7131:7131] An error occured while enabling auto-reply of user username
2020-01-09 00:00:06.412 sogo-tool[7131:7131] An error occured while enabling auto-reply of user username
2020-01-09 00:00:07.097 sogo-tool[7131:7131] An error occured while removing auto-reply of user username
2020-01-09 00:00:07.770 sogo-tool[7131:7131] An error occured while enabling auto-reply of user username
<0x0x2499e40[SOGoSieveManager]> Could not delete Sieve script: Error deleting script
2020-01-09 00:00:08.545 sogo-tool[7131:7131] An error occured while removing auto-reply of user username
2020-01-09 00:00:09.371 sogo-tool[7131:7131] An error occured while removing auto-reply of user username
2020-01-09 00:00:10.065 sogo-tool[7131:7131] An error occured while enabling auto-reply of user username
2020-01-09 00:00:10.691 sogo-tool[7131:7131] An error occured while removing auto-reply of user username
2020-01-09 00:00:11.411 sogo-tool[7131:7131] An error occured while enabling auto-reply of user username
2020-01-09 00:00:12.103 sogo-tool[7131:7131] An error occured while removing auto-reply of user username

username at this point represents different masked usernames.
Tried to start that one with gdb but produced no stack

TagsNo tags attached.

Activities

sascha.kasch@sumcumo.com

sascha.kasch@sumcumo.com

2020-01-17 03:43

reporter   ~0014065

it looks like the vacation filter generator does not work anymore.
I can create Filter within SOGo Webinterface and those are added to sogo.script, so communication with sieve works.
But nothing happens on ticking "Enable vaction auto reply".
The setting is enabled in the user-prefs (sogo-tool user-preferences get defaults user -p /sieve-admin Vacation", but does not get transfered to sieve.
Using SOGo Stable Version 4.2.0

francis

francis

2020-01-17 16:48

administrator   ~0014067

Do you use Dovecot or Cyrus?

Have you defined an activation date in the future for your vacation auto-reply?

danbet

danbet

2020-01-18 08:08

reporter   ~0014068

I had the same problem with my last out of office message.
The auto-reply was activated on the correct date, but the start date was not deleted from the database. Therefore, every day the cronjob tried to activate the auto-replay again. I then logged on to the WebUI and removed the start date.
The auto-reply notification was deactivated at the correct end date, but again the information was not deleted from the database. Therefore, the next day an attempt was made to deactivate the message with the cronjob.
Up to version 4.1.1 this worked without any problems. With 4.2.0 there is this error.
But if I understand the documentation correctly, the cronjob "Vacation messages expiration" does not have to be used because the date is already included in the sieve script.

danbet

danbet

2020-01-18 08:09

reporter   ~0014069

I use Dovecot on Debian 9.

francis

francis

2020-01-20 13:30

administrator   ~0014075

Please try the latest nightly build.

danbet

danbet

2020-01-25 08:05

reporter   ~0014101

I will set up a test system to install a nightly build. On my productive system I don't do that.

sascha.kasch@sumcumo.com

sascha.kasch@sumcumo.com

2020-01-26 04:10

reporter   ~0014105

Version 4.3.0 stable is out and has fixed that problem.
We use Cyrus

Issue History

Date Modified Username Field Change
2020-01-10 10:38 sascha.kasch@sumcumo.com New Issue
2020-01-17 03:43 sascha.kasch@sumcumo.com Note Added: 0014065
2020-01-17 16:48 francis Note Added: 0014067
2020-01-18 08:08 danbet Note Added: 0014068
2020-01-18 08:09 danbet Note Added: 0014069
2020-01-20 13:30 francis Note Added: 0014075
2020-01-25 08:05 danbet Note Added: 0014101
2020-01-26 04:10 sascha.kasch@sumcumo.com Note Added: 0014105
2020-01-26 13:57 francis Assigned To => francis
2020-01-26 13:57 francis Status new => resolved
2020-01-26 13:57 francis Resolution open => fixed
2020-01-26 13:57 francis Fixed in Version => 4.3.0