View Issue Details

IDProjectCategoryView StatusLast Update
0004922SOGoActiveSyncpublic2020-01-17 06:38
ReporterLC Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version4.2.0 
Fixed in Version4.3.0 
Summary0004922: Error syncing Android Calendar
Description

I'm unable to sync the calendar on my huawei android phone.
Changes made in SOGO are overwritten by the phone and not all phone calendar is added to Sogo

Steps To Reproduce
  • Configure an Activesync account on android pointing to your SOGO (syncing mail, contact and calendar)
  • add an item to calendar using SOGO web interface
  • Wait for sync: data will appear on phone.
  • Then modify the calendar item in SOGO web interface
  • wait for sync. after syncing, you changes in SOGO will be overwritten by the phone

More, if you add a calendar item on the phone, not always it can be seen on sogo.

Same error if I use GMAIL activesync support instead of built in phone activesync

Additional Information

Debug logs says

2020-01-06 11:51:46.826 sogod[23695] EXCEPTION: <NSException: 0x55caad249d20> NAME:NSInvalidArgumentException REASON:-[SOGoAppointmentObject resourceHasAutoAccepted]: unrecognized selector sent to instance 0x55caad07dd20 INFO:(null)

and then a 501 error is thrown to the client

Jan 06 11:51:46 sogod [23695]: x.y.z.a "POST /SOGo/Microsoft-Server-ActiveSync?Cmd=Sync&User=my%40user.name&DeviceId=androidxxxxxxxxxxx&DeviceType=Android HTTP/1.1" 501 0/1472 0.027 - - 4M

TagsNo tags attached.

Relationships

duplicate of 0004923 resolvedfrancis NSInvalidArgumentException REASON:-[SOGoAppointmentObject resourceHasAutoAccepted]: 

Activities

Dominion

Dominion

2020-01-16 09:15

reporter   ~0014063

I'm also not able to sync any calendar items to sogo from my android 9.

Got the same error message:

2020-01-16 11:45:37.796 sogod[5093:5093] EXCEPTION: <NSException: 0x557ab4b44450> NAME:NSInvalidArgumentException REASON:SOGoAppointmentObject(instance) does not recognize resourceHasAutoAccepted INFO:(null)

Issue History

Date Modified Username Field Change
2020-01-06 06:19 LC New Issue
2020-01-16 09:15 Dominion Note Added: 0014063
2020-01-16 10:46 francis Relationship added duplicate of 0004923
2020-01-16 10:46 francis Assigned To => francis
2020-01-16 10:46 francis Status new => resolved
2020-01-16 10:46 francis Resolution open => duplicate
2020-01-16 10:46 francis Fixed in Version => 4.3.0