View Issue Details

IDProjectCategoryView StatusLast Update
0000492SOGoWeb Calendarpublic2010-03-15 19:33
Reportercwright Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.2.2 
Summary0000492: All day events span across two days
Description

I thought this was fixed earlier by Wolfgang, but I'm again seeing this issue on days after March 14 in the Web calendar with the timezone set to America/Chicago.

I'm using SOGo 1.2.1 201003150640 from the CentOS rpms.

Additional Information

With the calendar set to Month view:

1) An all day event on March 10 displays normally -- only on March 10.

2) An all day event on March 17 displays across two days -- March 16 and March 17.

3) For what it's worth -- an all day event on March 14 displays normally but when opened for editing, the end date is displayed as March 13 and on saving and closing triggers the error message "The end date that you entered occurs before the start date." On all other days I've tested, the event end date is always correct, regardless of whether the all day event displays across one or two days.

TagsNo tags attached.

Activities

2010-03-15 19:25

 

all_day_events.png (7,512 bytes)   
all_day_events.png (7,512 bytes)   
ludovic

ludovic

2010-03-15 19:27

administrator   ~0000736

In the month view only? If so, this issue was fixed today.

cwright

cwright

2010-03-15 19:32

reporter   ~0000737

The problem is only in the month view -- thanks for the fix!

ludovic

ludovic

2010-03-15 19:33

administrator   ~0000738

Already fixed...

Issue History

Date Modified Username Field Change
2010-03-15 19:25 cwright New Issue
2010-03-15 19:25 cwright File Added: all_day_events.png
2010-03-15 19:27 ludovic Note Added: 0000736
2010-03-15 19:32 cwright Note Added: 0000737
2010-03-15 19:33 ludovic Note Added: 0000738
2010-03-15 19:33 ludovic Status new => closed
2010-03-15 19:33 ludovic Resolution open => fixed
2010-03-15 19:33 ludovic Fixed in Version => 1.2.2