View Issue Details

IDProjectCategoryView StatusLast Update
0000049SOGoWeb Calendarpublic2010-02-17 09:20
Reporterwimmer Assigned Towsourdeau 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Summary0000049: cannot insert Event invitation sended from Outlook
Description

When I receive an e-mail message with Event invitation sended from Outlook,
I cannot insert it via "Add to calendar" button in SOGo WebGUI.
SOGo writes warning "received code: 409" and event does not insert.

I discovered that problem is in two-line long UID parameter of vCalendar dates
of that Event:
UID:040000008200E00074C5B7101A82E008000000003090B0D737F0C901000000000000000
010000000ACD545E52B36C047A3CA1F3AE4299772

When I cut it to one-line interpretation only:
UID:040000008200E00074C5B7101A82E008000000003090B0D737F0C901000000000000000

SOGo WebGUI inserts Event without problem.

Milos

TagsNo tags attached.

Activities

ludovic

ludovic

2009-07-31 09:27

administrator   ~0000062

I've tried and I can't reproduce the issue.

Could you give us a sample of your sogod logs when that happens?

2009-07-31 09:56

 

error409 (3,543 bytes)   
From wimmer  Thu Jun 18 17:14:25 2009
Return-Path: <kejzlar@civ.zcu.cz>
X-Original-To: wimmer@civ.zcu.cz
Delivered-To: wimmer@civ.zcu.cz
Received: from fred.zcu.cz (fred.zcu.cz [147.228.57.19])
	by axor.zcu.cz (Postfix) with ESMTP id 05402C0020A4;
	Thu, 18 Jun 2009 17:14:24 +0200 (CEST)
Received: from castor2 (castor.civ.zcu.cz [147.228.1.30])
	(Authenticated sender: kejzlar)
	by fred.zcu.cz (Postfix) with ESMTPSA id 2CAB3A003485;
	Thu, 18 Jun 2009 17:13:49 +0200 (CEST)
From: =?UTF-8?Q?Lubo=C5=A1_Kejzlar?= <kejzlar@civ.zcu.cz>
To: "Ing. Milos WIMMER" <wimmer@civ.zcu.cz>
Subject: =?UTF-8?Q?Sch=C5=AFze_LPS_=28posledn=C3=AD_p=C5=99edpr=C3=A1zdni?=
	=?UTF-8?Q?nov=C3=A1=29?=
Date: Thu, 18 Jun 2009 17:13:49 +0200
Organization: =?UTF-8?Q?Z=C3=A1pado=C4=8Desk=C3=A1_univerzita_v_Plzni?=
Message-ID: <00b001c9f027$7532e3f0$5f98abd0$@zcu.cz>
MIME-Version: 1.0
Content-Type: text/calendar; method=REQUEST;
	charset="UTF-8"
Content-Transfer-Encoding: 8bit
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index: AcnwJyxJjcXSBFPWQgSucRlQAiUdqgAAAAFw
Content-Language: cs
X-ZCU-MailScanner-ID: 2CAB3A003485.EB01B
X-ZCU-MailScanner: Found to be clean
X-ZCU-MailScanner-SpamCheck: not spam, SpamAssassin (not cached,
	score=-98.93, required 5, ALL_TRUSTED -1.44, AWL -0.39,
	TVD_SPACE_RATIO 2.90, USER_IN_WHITELIST -100.00)
X-ZCU-MailScanner-From: kejzlar@civ.zcu.cz
X-Spam-Status: No
X-IMAPbase: 1 0000000001
X-UID: 1
Status: RO
X-Keywords:                                                                     
Content-Length: 3785

BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 12.0 MIMEDIR//EN
VERSION:2.0
METHOD:REQUEST
X-MS-OLK-FORCEINSPECTOROPEN:TRUE
BEGIN:VEVENT
ATTENDEE;CN="Ing. Milos WIMMER";RSVP=TRUE:mailto:wimmer@civ.zcu.cz
CLASS:PUBLIC
CREATED:20090618T151219Z
DESCRIPTION:When: 26. června 2009 13:00-14:00 (GMT+01:00) Praha\, Bratisla
	va\, Budapešť\, Bělehrad\, Lublaň.\nWhere: UI-126\n\nNote: The GMT off
	set above does not reflect daylight saving time adjustments.\n\n*~*~*~*~*~
	*~*~*~*~*\n\n\n
DTEND:20090626T120000Z
DTSTAMP:20090618T151219Z
DTSTART:20090626T110000Z
LAST-MODIFIED:20090618T151248Z
LOCATION:UI-126
ORGANIZER;CN="Luboš Kejzlar":mailto:kejzlar@civ.zcu.cz
PRIORITY:5
SEQUENCE:0
SUMMARY;LANGUAGE=cs:Schůze LPS (poslední předprázdninová)
TRANSP:OPAQUE
UID:040000008200E00074C5B7101A82E008000000003090B0D737F0C901000000000000000
	010000000ACD545E52B36C047A3CA1F3AE4299772
X-ALT-DESC;FMTTYPE=text/html:<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//E
	N">\n<HTML>\n<HEAD>\n<META NAME="Generator" CONTENT="MS Exchange Server ve
	rsion 08.00.0681.000">\n<TITLE></TITLE>\n</HEAD>\n<BODY>\n<!-- Converted f
	rom text/rtf format -->\n\n<P DIR=LTR><SPAN LANG="cs"><FONT FACE="Calibri"
	>When: 26. června 2009 13:00-14:00 (GMT+01:00) Praha\, Bratislava\, Budap
	ešť\, Bělehrad\, Lublaň.</FONT></SPAN></P>\n\n<P DIR=LTR><SPAN LANG="c
	s"><FONT FACE="Calibri">Where: UI-126</FONT></SPAN></P>\n\n<P DIR=LTR><SPA
	N LANG="cs"><FONT FACE="Calibri">Note: The GMT offset above does not refle
	ct daylight saving time adjustments.</FONT></SPAN></P>\n\n<P DIR=LTR><SPAN
	 LANG="cs"><FONT FACE="Calibri">*~*~*~*~*~*~*~*~*~*</FONT></SPAN></P>\n\n<
	P DIR=LTR><SPAN LANG="cs"></SPAN></P>\n\n</BODY>\n</HTML>
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-DISALLOW-COUNTER:FALSE
X-MS-OLK-ALLOWEXTERNCHECK:TRUE
X-MS-OLK-AUTOSTARTCHECK:FALSE
X-MS-OLK-CONFTYPE:0
X-MS-OLK-SENDER;CN="Luboš Kejzlar":mailto:kejzlar@civ.zcu.cz
END:VEVENT
END:VCALENDAR



error409 (3,543 bytes)   
wimmer

wimmer

2009-07-31 10:02

reporter   ~0000064

Jul 31 15:58:34 sogod [23581]: [ERROR] <0x08694518[SOGoMailObject]:1> body part index out of bounds(idx=1 vs count=0): {bodyId = ""; description = ""; disposition = {}; encoding = 8bit; languages = (cs); lines = 48; location = ""; md5 = ""; parameterList = {charset = "UTF-8"; method = REQUEST; }; size = 2065; subtype = calendar; type = text; }

I uploaded message included that invitation (error409 file) into this track,
so you can try it on your server.

thanks,
Milos

wimmer

wimmer

2010-02-16 09:07

reporter   ~0000577

Wolfgang,
there is no problem with this Event invitation now.
I tried both "Add to calednar" and "Accept" just now it and it works greatly.

On the other side - my colleague forwarded me another problematic Event invitation, which sent him other man from MS Outlook. I modified attendees and
sender address and tried to accept by myself, but without success.
I'm working in SOGo WebGUI...

  • I do "Add to calendar" -> event is inserted into my calendar => ok
  • I do "Accept" -> event is inserted into my calendar, but SOGo displays warning

received code: 500
error: <?xml version="1.0" encoding="ISO-8859-1"?>
<html xmlns="http://www.w3.org/1999/xhtml&quot;>
<body><h3>An error occurred during object publishing</h3><p>unable to parse event record</p></body>
</html>

and no message is sended to organizer.

Here is sogo.log:
Feb 16 15:01:51 sogod [18759]: [ERROR] <0x01BA3F10[SOGoMailObject]:9981> body part index out of bounds(idx=1 vs count=0): {bodyId = ""; description = ""; disposition = {}; encoding = 8bit; languages = (cs); lines = 86; location = ""; md5 = ""; parameterList = {charset = "utf-8"; method = REQUEST; }; size = 3697; subtype = calendar; type = text; }
2010-02-16 15:01:51.754 sogod[18759] <0x0x1e79760[PostgreSQL72Channel]: connection=<0x0x1e6a990[PGConnection]: connection=0x0x23740d0>>: message: WARNING: nonstandard use of \ in a string literal
LINE 1: ...0000100000009BB6CBE350E5C349855DE60AC9E259BE', 0, 'BEGIN:VCA...
^
HINT: Use the escape string syntax for backslashes, e.g., E'\'.

Complete event invitation I will send you in private mail.

Milos

wsourdeau

wsourdeau

2010-02-16 18:38

viewer   ~0000580

Hi Milos,

I suspect the issue to be related to the fact that the invitation is for an exception to an event occurrence. In extenso, the organizer has scheduled a recurring event and invited your colleague to only one of the occuring dates. Is this hypothesis correct?

wimmer

wimmer

2010-02-17 07:16

reporter   ~0000583

Yes, original organizer confirmed it was this case - recurring event and invited person to only one of the occuring date. He uses MS Outlook (local, not connected to Exchange).

wsourdeau

wsourdeau

2010-02-17 09:19

viewer   ~0000584

Original bug has been fixed a couple of months ago. New bug moved to own bugreport: http://www.scalableogo.org/bugs/view.php?id=434

Issue History

Date Modified Username Field Change
2009-07-07 16:12 wimmer New Issue
2009-07-31 09:27 ludovic Note Added: 0000062
2009-07-31 09:28 ludovic Status new => feedback
2009-07-31 09:56 wimmer File Added: error409
2009-07-31 10:02 wimmer Note Added: 0000064
2010-02-13 18:23 ludovic Target Version => 1.2.1
2010-02-16 09:07 wimmer Note Added: 0000577
2010-02-16 18:38 wsourdeau Note Added: 0000580
2010-02-17 07:16 wimmer Note Added: 0000583
2010-02-17 09:19 wsourdeau Note Added: 0000584
2010-02-17 09:19 wsourdeau Status feedback => resolved
2010-02-17 09:19 wsourdeau Resolution open => fixed
2010-02-17 09:19 wsourdeau Assigned To => wsourdeau
2010-02-17 09:20 wsourdeau Target Version 1.2.1 =>