View Issue Details

IDProjectCategoryView StatusLast Update
0004877SOGoBackend Calendarpublic2019-12-15 09:28
Reporterpmb Assigned Tofrancis  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux Debian 9OSLinuxOS VersionDebian 9
Product Version4.1.1 
Fixed in Version4.2.0 
Summary0004877: Event created with the most recent thunderbird are shifted one hour earlier in the web access and on Smartphone Client (ASync)
Description

I am using the most recent version of TB 68.2.2 (64-bit) on Linux with integrated Lightning. I connect to SOGo server 4.1.1 using CalDAV.

The local timezone is Europe/Paris. The server is Europe/Paris.

The bug is the following: when I created an event at 3PM in TB, it will appears at 2PM on the server integrated web access.

I have a smartphone connected to the SOGo server with ActiveSync. The event created in TB will also appear one hour earlier (2PM). The smartphone is also Europe/Paris.

I assume there is some kind of bug in handling of timezone / daylight saving in the server.

Steps To Reproduce

See above.

Additional Information

I am ready to run any test / report any extra data to solve this.

This is critical for organizing ourselves in our company.

Thanks.

Note : I used another server SOGo 4.0.0 with the same clients and it works smoothly.

TagsNo tags attached.

Relationships

related to 0004894 resolvedfrancis Sogo shows event created in external app moved by one hour 

Activities

ludovic

ludovic

2019-11-13 09:41

administrator   ~0013895

I can't reproduce the issue.

When was the event created?

Was it a repetitive event?

Show your full list of installed SOGo/SOPE packages.

pmb

pmb

2019-11-13 12:21

reporter   ~0013899

Thanks for your quick answer.

The bug can be triggered when the event, is, for example created today
for an event tomorrow.

As an example, I just created in TB an event at 2PM tomorrow.

Here is the dump of this event from the SOGo database:

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Paris
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20191113T165611Z
LAST-MODIFIED:20191113T165620Z
DTSTAMP:20191113T165620Z
UID:936c8c01-4a97-4037-850a-83bdf1fa5524
SUMMARY:Event starting at 2PM created in TB
DTSTART;TZID=Europe/Paris:20191115T140000
DTEND;TZID=Europe/Paris:20191115T150000
TRANSP:OPAQUE
CLASS:PUBLIC
X-MOZ-GENERATION:1
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT15M
DESCRIPTION:Default Mozilla Description
X-LIC-ERROR;X-LIC-ERRORTYPE=PARAMETER-VALUE-PARSE-ERROR:Got a VALUE paramet
er with an illegal type for property: VALUE=DURATION
END:VALARM
END:VEVENT
END:VCALENDAR

It was not a repetitive event.

It appears starting at 1PM instead of 2PM on my Smartphone which is
connected through ActiveSync. Also in the web interface of SOGo it
appears as starting at 1.00PM

My full package list is below:
libsbjson2.3_4.9.r1664.20191108_amd64.deb
libsbjson2.3-dev_4.9.r1664.20191108_amd64.deb
libsope4.9-dev_4.9.r1664.20191108_all.deb
libsope-appserver4.9_4.9.r1664.20191108_amd64.deb
libsope-appserver4.9-dev_4.9.r1664.20191108_amd64.deb
libsope-core4.9_4.9.r1664.20191108_amd64.deb
libsope-core4.9-dev_4.9.r1664.20191108_amd64.deb
libsope-gdl1-4.9_4.9.r1664.20191108_amd64.deb
libsope-gdl1-4.9-dev_4.9.r1664.20191108_amd64.deb
libsope-ldap4.9_4.9.r1664.20191108_amd64.deb
libsope-ldap4.9-dev_4.9.r1664.20191108_amd64.deb
libsope-mime4.9_4.9.r1664.20191108_amd64.deb
libsope-mime4.9-dev_4.9.r1664.20191108_amd64.deb
libsope-xml4.9_4.9.r1664.20191108_amd64.deb
libsope-xml4.9-dev_4.9.r1664.20191108_amd64.deb
libwbxml2-0_0.11.6-1_amd64.deb
libwbxml2-0-dbg_0.11.6-1_amd64.deb
libwbxml2-dev_0.11.6-1_amd64.deb
libwbxml2-utils_0.11.6-1_amd64.deb
sogo_4.1.1.20191112-1_amd64.deb
sogo-activesync_4.1.1.20191112-1_amd64.deb
sogo-dbg_4.1.1.20191112-1_amd64.deb
sogo-dev_4.1.1.20191112-1_amd64.deb
sope4.9-appserver_4.9.r1664.20191108_amd64.deb
sope4.9-dbg_4.9.r1664.20191108_amd64.deb
sope4.9-gdl1-mysql_4.9.r1664.20191108_amd64.deb
sope4.9-gdl1-postgresql_4.9.r1664.20191108_amd64.deb
sope4.9-libxmlsaxdriver_4.9.r1664.20191108_amd64.deb
sope4.9-stxsaxdriver_4.9.r1664.20191108_amd64.deb

ludovic

ludovic

2019-11-13 13:01

administrator   ~0013900

And what is the value of the SOGoTimeZone parameter in your sogo.conf?

What is the value of the user's timezone parameter from the General preferences panel?

pmb

pmb

2019-11-13 14:13

reporter   ~0013902

root@server:~# cat /etc/sogo/sogo.conf | grep SOGoTimeZone
/ General - SOGoTimeZone MUST be defined /
SOGoTimeZone = Europe/Paris;

and the user timezone is also Europe/Paris.

pmb

pmb

2019-11-18 09:28

reporter   ~0013913

Good evening,
I just wanted to check with you if you need any extra further information/test to allow you to have a look at this unexpected behavior/bug.
This bug is critical for our organization and any hint on how to solve it would be greatly appreciated.
Best regards.

pmb

pmb

2019-11-25 17:36

reporter   ~0013926

Please can you check this bug? I can supply new information if needed. Best regards.

tfu

tfu

2019-12-06 16:28

reporter   ~0013957

This might be similar to what is described in bug 4894.
Please provide the same Infos requested in bug 4894.

francis

francis

2019-12-10 16:17

administrator   ~0013971

Please try the latest nightly build.

pmb

pmb

2019-12-15 05:27

reporter   ~0013979

I installed the latest nightly build and I can confirm that the problem is solved with the nightly build (tested with sogo_4.1.1.20191215-1_amd64.deb etc ...).
Big thanks to Francis and Ludovic for their feedback.
Have great day.

This ticket can be CLOSED and marked as SOLVED.

Issue History

Date Modified Username Field Change
2019-11-13 05:42 pmb New Issue
2019-11-13 09:41 ludovic Note Added: 0013895
2019-11-13 12:21 pmb Note Added: 0013899
2019-11-13 13:01 ludovic Note Added: 0013900
2019-11-13 14:13 pmb Note Added: 0013902
2019-11-18 09:28 pmb Note Added: 0013913
2019-11-25 17:36 pmb Note Added: 0013926
2019-12-06 16:28 tfu Note Added: 0013957
2019-12-10 16:16 francis Relationship added related to 0004894
2019-12-10 16:17 francis Note Added: 0013971
2019-12-15 05:27 pmb Note Added: 0013979
2019-12-15 09:28 francis Assigned To => francis
2019-12-15 09:28 francis Status new => resolved
2019-12-15 09:28 francis Resolution open => fixed
2019-12-15 09:28 francis Fixed in Version => 4.2.0