View Issue Details

IDProjectCategoryView StatusLast Update
0004846SOGosogo-toolpublic2019-11-01 10:25
Reporterrof Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly master 
Fixed in Version4.1.1 
Summary0004846: update sieve-scripts fails with segmenation fault
Description

I tried using the command "sogo-tool user-preferences get defaults username -p sieve.cred Forward '{"Forward":{"forwardAddress": ["newuser@domain.com"], "enabled": "1", "keepCopy": "0"}}'" to set an e-mail forwarding. Unfortunately, I am getting a segmentation fault. Maybe it's related to 0004834?!

Additional Information

In the Dovecot log I find the following error message:
Okt 08 12:11:40 servername dovecot[665]: managesieve-login: Login: user=<username>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=13162, secured, session=<p+L0ZGOUXpx/AAAB>
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Loading modules from directory: /usr/lib/dovecot/modules
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Module loaded: /usr/lib/dovecot/modules/lib01_acl_plugin.so
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Module loaded: /usr/lib/dovecot/modules/lib10_quota_plugin.so
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Added userdb setting: mail=maildir:/var/vmail//username/Maildir
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Effective uid=5000, gid=5000, home=/var/vmail//username
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Quota root: name= backend=maildir args=
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Quota rule: root= mailbox=* bytes=838860800 messages=0
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Quota rule: root= mailbox=Trash bytes=+104857600 messages=0
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Quota rule: root= mailbox=Junk bytes=+104857600 messages=0
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Quota grace: root= bytes=83886080 (10%)
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Namespace inbox: type=private, prefix=, sep=/, inbox=yes, hidden=no, list=yes, subscriptions=yes location=maildir:/var/vmail//username/Maildir
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: maildir++: root=/var/vmail//username/Maildir, index=, indexpvt=, control=, inbox=/var/vmail//username/Maildir, alt=
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: initializing backend with data: vfile
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: acl username = username
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: owner = 1
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl vfile: Global ACLs disabled
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Namespace : type=shared, prefix=shared/%u/, sep=/, inbox=no, hidden=no, list=yes, subscriptions=yes location=maildir:%h/Maildir
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: shared: root=/var/run/dovecot, index=, indexpvt=, control=, inbox=, alt=
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: initializing backend with data: vfile
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: acl username = username
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: owner = 0
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl vfile: Global ACLs disabled
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: Namespace : type=public, prefix=Public/, sep=/, inbox=no, hidden=no, list=yes, subscriptions=no location=maildir:/var/vmail/public
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: maildir++: root=/var/vmail/public, index=, indexpvt=, control=, inbox=, alt=
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: initializing backend with data: vfile
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: acl username = username
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl: owner = 0
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: acl vfile: Global ACLs disabled
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: quota: quota_over_flag check: quota_over_script unset - skipping
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: sieve: Pigeonhole version 0.5.4 () initializing
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: sieve: include: sieve_global is not set; it is currently not possible to include `:global' scripts.
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: sieve: file storage: Using active Sieve script path: /var/vmail/username/.dovecot.sieve
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: sieve: file storage: Using script storage path: /var/vmail//username/sieve
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: sieve: file storage: Using permissions from /var/vmail//username/sieve: mode=0700 gid=-1
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: sieve: file storage: Relative path to sieve storage in active link: sieve/
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Debug: sieve: file storage: sync: Synchronization active
Okt 08 12:11:40 servername kernel: sogo-tool[13160]: segfault at 7ffc0de0efc8 ip 00007fe6e638d067 sp 00007ffc0de0efc0 error 6 in libgnustep-base.so.1.26.0[7fe6e6159000+23c000]
Okt 08 12:11:40 servername kernel: Code: 00 00 00 48 83 c4 08 48 8d 05 e5 0a 27 00 5b 5d c3 66 90 41 57 41 89 cb 41 56 41 55 41 54 55 48 89 d5 53 48 81 ec a8 40 00 00 <48> 89 7c 24 08 48 89 74 24 20 4c 89 4c 24 18 64 48 8b 04 25 28 00
Okt 08 12:11:40 servername dovecot[665]: managesieve(username)<13162><p+L0ZGOUXpx/AAAB>: Connection closed bytes=0/17

TagsNo tags attached.

Relationships

has duplicate 0004834 resolvedludovic update-autoreply fails with segmenation fault 

Activities

ludovic

ludovic

2019-10-08 08:01

administrator   ~0013815

Generate a stack trace: https://sogo.nu/support/faq/how-do-i-debug-sogo.html

rof

rof

2019-10-08 08:51

reporter  

sogo-tool_gdb.txt (1,028,671 bytes)
rof

rof

2019-10-08 08:52

reporter   ~0013816

The command is "set" not "get": sogo-tool user-preferences set defaults username -p sieve.cred Forward '{"Forward":{"forwardAddress": ["newuser@domain.com"], "enabled": "1", "keepCopy": "0"}}'

ludovic

ludovic

2019-10-25 11:53

administrator   ~0013854

I know what the issue is. I'll work on a fix.

Related Changesets

sogo: master 34fcfe02

2019-10-25 13:31:13

ludovic

Details Diff
(fix) use the supplied Sieve creds to fetch the IMAP4 separator (fixes 0004846) Affected Issues
0004846
mod - NEWS Diff File
mod - SoObjects/SOGo/SOGoSieveManager.h Diff File
mod - SoObjects/SOGo/SOGoSieveManager.m Diff File

Issue History

Date Modified Username Field Change
2019-10-08 07:50 rof New Issue
2019-10-08 08:01 ludovic Note Added: 0013815
2019-10-08 08:51 rof File Added: sogo-tool_gdb.txt
2019-10-08 08:52 rof Note Added: 0013816
2019-10-25 11:10 ludovic Relationship added has duplicate 0004834
2019-10-25 11:53 ludovic Note Added: 0013854
2019-10-25 13:37 ludovic Changeset attached => sogo master 34fcfe02
2019-10-25 13:37 ludovic Assigned To => ludovic
2019-10-25 13:37 ludovic Resolution open => fixed
2019-10-28 15:09 ludovic Status new => resolved
2019-10-28 15:09 ludovic Fixed in Version => 4.1.1