View Issue Details

IDProjectCategoryView StatusLast Update
0004799SOGoWeb Mailpublic2021-06-07 09:56
Reporterabma Assigned Tofrancis  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionreopened 
Product Version4.0.7 
Fixed in Version4.1.0 
Summary0004799: Sorting of Global addressbook doesn't work with listRequiresDot = NO
Description

When using ldap as SOGoUserSources:

{
id = directory;
displayName = "Global Adressbook";
type = ldap;
CNFieldName = cn;
IDFieldName = cn;
UIDFieldName = sAMAccountName;
baseDN = "ou=User,dc=some,dc=domain";
bindDN = "cn=sogo,ou=User,dc=some,dc=domain";
bindFields = (sAMAccountName);
bindPassword = 12345;
canAuthenticate = YES;
hostname = "ldap://server:389";
isAddressBook = YES;
filter = "(objectClass='User' AND mail='*' AND userAccountControl:1.2.840.113556.1.4.803: <> '2')";
listRequiresDot = NO;
scope = ONE;
},

its not possible to sort the resulting adressbook.

Additional Information

when clicking at the sort buttons basicly nothing happens.

TagsNo tags attached.

Activities

Christian Mack

Christian Mack

2019-08-26 09:34

developer   ~0013710

LDAP does not have any sorting in its result set at all.
Because of that this isn't a bug.

What you want is an additional feature of client side sorting for global address book.
Therfore I changed this accordingly.

abma

abma

2019-08-26 11:29

reporter   ~0013717

the GUI in the webclient offers to sort LDAP. It would be nice to either support client side sorting or disable the GUI-elements which allow to select sorting.

francis

francis

2019-08-26 17:03

administrator   ~0013718

Sorting is suppose to work. Any Javascript error? Does the attributes mapping look correct when you view a card?

abma

abma

2019-08-30 11:32

reporter   ~0013723

Last edited: 2019-08-30 11:33

View 2 revisions

no, no javascript errors in firefox -> web-console

as far as i can tell the attributes mapping looks corret. i.e. the email address of an entry is shown correctly / clickable but it seems to mostly ignore sorting email / reverse the order.

it looks a bit like it sorts only the first 4 entries. (of ~ 150)

francis

francis

2019-09-25 10:57

administrator   ~0013770

Can you try with a nightly build?

abma

abma

2019-10-10 11:30

reporter   ~0013828

the problem still persists, only difference is that now only the first two entries seems to be sorted as the "inverse result" makes only change the order of the first two entries.

abma

abma

2019-10-10 11:31

reporter   ~0013829

tested with sogo 4.0.8.20191009-1

abma

abma

2019-11-01 10:15

reporter   ~0013876

forgot to reopen, this issue: the problem still persists in sogo 4.1.1.20191101-1

abma

abma

2021-06-07 09:45

reporter   ~0015310

retested, now it works!

thank you!

Related Changesets

sogo: master 85e61ecc

2019-10-21 15:32:13

francis

Details Diff
Add missing contact fields for sorting

Fixes 0004799
Affected Issues
0004799
mod - SoObjects/Contacts/SOGoContactSourceFolder.m Diff File

Issue History

Date Modified Username Field Change
2019-08-23 08:19 abma New Issue
2019-08-26 09:34 Christian Mack Note Added: 0013710
2019-08-26 09:34 Christian Mack Severity minor => feature
2019-08-26 11:29 abma Note Added: 0013717
2019-08-26 17:03 francis Note Added: 0013718
2019-08-30 11:32 abma Note Added: 0013723
2019-08-30 11:33 abma Note Edited: 0013723 View Revisions
2019-09-25 10:57 francis Note Added: 0013770
2019-10-10 11:30 abma Note Added: 0013828
2019-10-10 11:31 abma Note Added: 0013829
2019-10-21 15:33 francis Changeset attached => sogo master 85e61ecc
2019-10-21 15:33 francis Assigned To => francis
2019-10-21 15:33 francis Resolution open => fixed
2019-10-21 15:34 francis Status new => resolved
2019-10-21 15:34 francis Fixed in Version => 4.1.0
2019-11-01 10:15 abma Note Added: 0013876
2019-11-01 10:15 abma Status resolved => feedback
2019-11-01 10:15 abma Resolution fixed => reopened
2021-06-07 09:45 abma Note Added: 0015310
2021-06-07 09:45 abma Status feedback => assigned
2021-06-07 09:56 francis Status assigned => resolved