View Issue Details

IDProjectCategoryView StatusLast Update
0004796SOGoWeb Mailpublic2021-03-01 17:25
Reporterwix Assigned Tofrancis  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version4.0.8 
Fixed in Version5.1.0 
Summary0004796: Sorting mail by thread - bad order
Description

Bonjour Francis,

Je viens de tester le thread mode malheureusement je peux pas répondre aux tickets clos ( https://sogo.nu/bugs/view.php?id=3478 )

Il y a encore un problème. L'ordre n'est pas le bon. Quand on reçoit un nouveau mail en thread il se met après la date du premier reçu, au lieu de remonter tout le bloc de mail

Je met une copie d'écran d'un mail que je me suis envoyé et que je ne trouvais pas car il est passer à la suite d'un mail de 2018 et qu'il ne m'a pas mis en premier malgré le tri par "Date de réception"

Merci d'avance
William

TagsNo tags attached.

Relationships

duplicate of 0003100 resolvedfrancis In thread listing mode sogo sorts emails based on oldest email of the thread 

Activities

wix

wix

2019-08-19 08:35

reporter  

Sélection_763.png (119,213 bytes)   
Sélection_763.png (119,213 bytes)   
Christian Mack

Christian Mack

2019-08-20 09:10

developer   ~0013705

Could you please translate your bug report into English?

wix

wix

2019-08-21 01:56

reporter   ~0013706

Hello,

I just tested the thread mode unfortunately I can not respond to closed tickets (https://sogo.nu/bugs/view.php?id=3478)

There is still a problem. The order is not good. When we receive a new mail thread it starts after the date of the first receipt, instead of going up the whole block of mail

I put a screenshot of an email that I sent myself and that I did not find because it is passed after a mail of 2018 and he did not put me first despite the sorting by "Date of receipt"

thank you in advance
William

FrederickZh

FrederickZh

2020-02-21 12:26

reporter   ~0014170

Confirmed using SOGo 4.3.0. I also have to say it's a bit off to sort the threads/conversations by dates when they are initiated rather than updated.

By the way possible duplicate: https://sogo.nu/bugs/view.php?id=3100

wix

wix

2020-08-24 07:46

reporter   ~0014720

Hello
Same problem on version 5

Thanks

francis

francis

2021-03-01 17:25

administrator   ~0015116

Fixed.

Ref: https://github.com/inverse-inc/sope/commit/b0a271aea01796d41c3086a9f296b34fe855cbd9

Issue History

Date Modified Username Field Change
2019-08-19 08:35 wix New Issue
2019-08-19 08:35 wix File Added: Sélection_763.png
2019-08-20 09:10 Christian Mack Note Added: 0013705
2019-08-21 01:56 wix Note Added: 0013706
2020-02-21 12:26 FrederickZh Note Added: 0014170
2020-02-28 08:12 Christian Mack Relationship added duplicate of 0003100
2020-08-24 07:46 wix Note Added: 0014720
2021-03-01 17:25 francis Assigned To => francis
2021-03-01 17:25 francis Status new => resolved
2021-03-01 17:25 francis Resolution open => duplicate
2021-03-01 17:25 francis Fixed in Version => 5.1.0
2021-03-01 17:25 francis Note Added: 0015116