View Issue Details

IDProjectCategoryView StatusLast Update
0004787SOGoWeb Mailpublic2019-09-25 06:05
Reporterast Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client]OSMicrosoft WindowsOS Version10
Product Version4.0.8 
Fixed in Version4.1.0 
Summary0004787: Webmail view doesn't refresh when creating/deleting folders
Description

Up until SOGo 4.0.7 the web client automatically refreshed its view when I created or deleted a mail folder through IMAP (Dovecot 2.2.33.2).
Since 4.0.8 I have to reload the whole webmail application to see a result.

It seems ActiveSync is also influenced by this behaviour.
Up until SOGo 4.0.7 a folder creation/removal resulted in the immediate ActiveSync push. Since 4.0.8 I have to force-refresh the sync.

I'm sorry if this a duplicate but I couldn't find any ticket related to this problem.

Steps To Reproduce

login
change to webmail
*create/delete folder

TagsNo tags attached.

Activities

ast

ast

2019-09-20 07:56

reporter   ~0013762

To clarify I created/deleted the test folders in the webmailer.
Dovecot is just the IMAP backend.

After Sogo 4.0.7 the webmail doesn't refresh automatically after creating, deleting folders and purging trash.

Related Changesets

sogo: master 2eec7658

2019-09-20 16:37:51

francis

Details Diff
(js) Fix mailboxes refresh

Fixes 0004787
Affected Issues
0004787
mod - UI/WebServerResources/js/Mailer/Account.service.js Diff File

Issue History

Date Modified Username Field Change
2019-07-22 07:29 ast New Issue
2019-09-20 07:56 ast Note Added: 0013762
2019-09-20 16:52 francis Changeset attached => sogo master 2eec7658
2019-09-20 16:52 francis Assigned To => francis
2019-09-20 16:52 francis Resolution open => fixed
2019-09-20 16:52 francis Status new => resolved
2019-09-20 16:52 francis Fixed in Version => 4.1.0