View Issue Details

IDProjectCategoryView StatusLast Update
0000470SOGoWeb Calendarpublic2010-03-24 11:10
Reporterxweber Assigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.1 
Target Version1.2.2Fixed in Version1.2.2 
Summary0000470: Umlauts in title will not be saved with IE8
Description

Create a new appointment with webcalendar under IE8

use as title: "test with umlauts äöüß"

This will create a new appointment, but with no title (for me it displays "Öffentlicher Termin")

If you edit this appointment, the same problem occurs: the title is not saved

Doing the same with FireFox: working as expected, the title is saved (create/edit)

This bug is also reproducable in 1.2.0

TagsNo tags attached.

Activities

schreiner

schreiner

2010-03-08 05:30

reporter   ~0000671

Same problem with french accents too (e.g. éèê).

on

Windows XP Professionnel - Version 2002 - Service Pack 3
IE7 Version 7.0.5730.13
Encoding: europe occidentale (Windows)

and

Windows 7
IE8
Encoding: europe occidentale (Windows)

wsourdeau

wsourdeau

2010-03-09 09:44

viewer   ~0000696

This is likely a bug in your webserver configuration. You must make sure that the charset for SOGo is "utf-8". This is done by specifying "AddDefaultCharset UTF-8" in your Apache configuration. On Debian/Ubuntu, there is a file named "/etc/apache2/conf.d/charset" which has that purpose so you are recommended to modify that one.

xweber

xweber

2010-03-10 03:23

reporter   ~0000702

my apache2 is on a debian system, which already has that encoding set:

Read the documentation before enabling AddDefaultCharset.

In general, it is only a good idea if you know that all your files

have this encoding. It will override any encoding given in the files

in meta http-equiv or xml encoding tags.

AddDefaultCharset UTF-8

Any more ideas for tests?

schreiner

schreiner

2010-03-10 03:40

reporter   ~0000704

Enabling AddDefaultCharset UTF-8 in /etc/apache2/conf.d/charset did not succeed for me too.

My setup is :

  • Ubuntu karmic 9.10 64bits
  • Apache2 (2.2.12-1ubuntu2.1)
  • SOPE r1664 compiled from SOPE-4.9.r1664.20100219.tar.gz
  • SOGo 1.2.1 compiled from SOGo-1.2.1.tar.gz
wsourdeau

wsourdeau

2010-03-15 12:39

viewer   ~0000731

Is it possible for you to sniff the traffic between the server and IE, for example via "tcpflow"?

ludovic

ludovic

2010-03-16 17:25

administrator   ~0000745

Can you also test with sogo-demo.inverse.ca?

schreiner

schreiner

2010-03-17 04:57

reporter   ~0000750

Ok, I have tested today with sogo1@sogo-demo.inverse.ca (french interface) with

Windows 7
IE8
Encoding: europe occidentale (Windows)

I tried to test the event title "test insertion accents éàù grave êâô double point ïë" for one event in calendar "Meeting 2" beginning at 13h45 and ending at 16h00.

After validation, the new event does not show the inserted title but only "(Événement public)".

I have done some captures with tcpdump too with SOGo configuration parameters :

WODontZipResponse = YES
WODebugZipResponse = YES

I will send them to you by email.

schreiner

schreiner

2010-03-17 05:50

reporter   ~0000751

New test,

it seems to be a problem of encoding detection on IE8. Even with "AddDefaultCharset UTF-8" in the Apache configuration, IE still uses "Windows Encoding".

If the web page includes into headers: <meta http-equiv="Content-Type" content="text/html; charset=utf-8">, IE switches to UTF-8.

wsourdeau

wsourdeau

2010-03-24 11:10

viewer   ~0000787

Fixed in 73f3fa811c59b152f7c426fe28488efd6bcfe6f2

Include the "AddCharset UTF-8" directive in the proxy section of your Apache configuration for SOGo (and reload the apache configuration).

Issue History

Date Modified Username Field Change
2010-03-04 07:34 xweber New Issue
2010-03-08 05:30 schreiner Note Added: 0000671
2010-03-08 11:44 ludovic Target Version => 1.2.2
2010-03-09 09:44 wsourdeau Note Added: 0000696
2010-03-10 03:23 xweber Note Added: 0000702
2010-03-10 03:40 schreiner Note Added: 0000704
2010-03-15 12:39 wsourdeau Note Added: 0000731
2010-03-16 17:25 ludovic Note Added: 0000745
2010-03-17 04:57 schreiner Note Added: 0000750
2010-03-17 05:50 schreiner Note Added: 0000751
2010-03-24 11:10 wsourdeau Note Added: 0000787
2010-03-24 11:10 wsourdeau Status new => resolved
2010-03-24 11:10 wsourdeau Fixed in Version => 1.2.2
2010-03-24 11:10 wsourdeau Resolution open => fixed
2010-03-24 11:10 wsourdeau Assigned To => wsourdeau