View Issue Details

IDProjectCategoryView StatusLast Update
0004597SOGoWeb Mailpublic2018-11-22 10:18
Reporteryinlianghui Assigned Tofrancis  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformchrome on the window 10 SystemOSWindowsOS Version7
Product Version4.0.4 
Fixed in Version4.0.5 
Summary0004597: After entering a duplicate mail account, i cannot fill in the new mail account to the mail account box
Description

I can't fill in a new mail account address just after i entered a repeat mail account address.

Steps To Reproduce

First i enter 'ylh@hotoa.com' to the mail account box;
Then i enter the same account address like 'ylh@hotoa.com' again;
Since then i can't enter any account address to the account box.
For example, i can't enter 'abc@hotoa.com'.

Additional Information

When I perform the second step above, the following error message appears on the console:

angular.js:15536 Error: [ngRepeat:dupes] http://errors.angularjs.org/1.7.5/ngRepeat/dupes?p0=%24chip%20in%20%24mdChipsCtrl.items&p1=string%3Aylh%40hotoa.com&p2=ylh%40hotoa.com
at angular.js:99
at angular.js:33721
at angular.js:18965
at m.$digest (angular.js:19103)
at b.$apply (angular.js:19463)
at Object.$$debounceViewValueCommit (angular.js:30763)
at Object.$setViewValue (angular.js:30737)
at e.resetChipBuffer (angular-material.min.js:14)
at e.onInputBlur (angular-material.min.js:14)
at HTMLInputElement.<anonymous> (angular.js:1365)

TagsNo tags attached.

Activities

yinlianghui

yinlianghui

2018-11-19 22:36

reporter  

repeat_mail_account.png (26,585 bytes)   
repeat_mail_account.png (26,585 bytes)   

Related Changesets

sogo: master 40691581

2018-11-22 10:17:09

francis

Details Diff
(js) Fix handling of duplicate recipients

Fixes 0004597
Affected Issues
0004597
mod - NEWS Diff File
mod - UI/WebServerResources/js/Mailer/MessageEditorController.js Diff File

Issue History

Date Modified Username Field Change
2018-11-19 22:36 yinlianghui New Issue
2018-11-19 22:36 yinlianghui File Added: repeat_mail_account.png
2018-11-22 10:17 francis Changeset attached => sogo master 40691581
2018-11-22 10:17 francis Assigned To => francis
2018-11-22 10:17 francis Resolution open => fixed
2018-11-22 10:18 francis Status new => resolved
2018-11-22 10:18 francis Fixed in Version => 4.0.5