View Issue Details

IDProjectCategoryView StatusLast Update
0004503SOGoWeb Mailpublic2021-09-03 14:00
Reporterpeter.barlabas Assigned Tofrancis  
PriorityhighSeveritytrivialReproducibilityalways
Status resolvedResolutionduplicate 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Product Version4.0.0 
Fixed in Version5.2.0 
Summary0004503: SOGo webmail attachment decoding error (winmail.dat)
Description

Hello, SOGo 4.0.0 webmail doesn't decode some attachment. For example pdf and doc files seems winmail.dat.
Can it fix it someway?

Best regards: P├ęter

TagsNo tags attached.

Relationships

duplicate of 0002242 resolvedfrancis Web Mail should decode TNEF attachments (winmail.dat) 

Activities

ASolana

ASolana

2018-07-27 10:01

reporter   ~0012983

Our users are complaining that SOGo doesn't decodes winmail.dat attachment as Thunderbird does, so they cannot read and download attachments from messages sent by customers using MS Outlook or Exchange.

It would be great to add this decoding feature to SOGo.

ASolana

ASolana

2021-02-24 10:03

reporter   ~0015102

Please, add this decoding feature.

Related Changesets

sogo: feature/ms-tnef f201cc18

2021-05-25 10:23:26

francis

Details Diff
feat(mail): initial support for ms-tnef (winmail.dat) body part

Fixes 0002242
Fixes 0004503
Affected Issues
0002242, 0004503
mod - SoObjects/Mailer/GNUmakefile Diff File
mod - SoObjects/Mailer/SOGoMailBodyPart.m Diff File
add - SoObjects/Mailer/SOGoTnefMailBodyPart.h Diff File
add - SoObjects/Mailer/SOGoTnefMailBodyPart.m Diff File
mod - SoObjects/Mailer/product.plist Diff File
mod - SoObjects/SOGo/GNUmakefile Diff File
add - SoObjects/SOGo/RTFHandler.h Diff File
add - SoObjects/SOGo/RTFHandler.m Diff File
mod - UI/MailPartViewers/GNUmakefile Diff File
mod - UI/MailPartViewers/GNUmakefile.preamble Diff File
add - UI/MailPartViewers/UIxMailPartTnefViewer.h Diff File
add - UI/MailPartViewers/UIxMailPartTnefViewer.m Diff File
mod - UI/MailPartViewers/UIxMailPartViewer.h Diff File
mod - UI/MailPartViewers/UIxMailPartViewer.m Diff File
mod - UI/MailPartViewers/UIxMailRenderingContext.m Diff File
mod - UI/MailerUI/UIxMailView.m Diff File
mod - UI/WebServerResources/js/Mailer/sgImageGallery.service.js Diff File
mod - configure Diff File

sogo: feature/ms-tnef 171c1867

2021-05-25 10:23:26

francis

Details Diff
feat(mail): initial support for ms-tnef (winmail.dat) body part

Fixes 0002242
Fixes 0004503
Affected Issues
0002242, 0004503
mod - SoObjects/Mailer/GNUmakefile Diff File
mod - SoObjects/Mailer/SOGoMailBodyPart.m Diff File
add - SoObjects/Mailer/SOGoTnefMailBodyPart.h Diff File
add - SoObjects/Mailer/SOGoTnefMailBodyPart.m Diff File
mod - SoObjects/Mailer/product.plist Diff File
mod - SoObjects/SOGo/GNUmakefile Diff File
add - SoObjects/SOGo/RTFHandler.h Diff File
add - SoObjects/SOGo/RTFHandler.m Diff File
mod - UI/MailPartViewers/GNUmakefile Diff File
mod - UI/MailPartViewers/GNUmakefile.preamble Diff File
add - UI/MailPartViewers/UIxMailPartTnefViewer.h Diff File
add - UI/MailPartViewers/UIxMailPartTnefViewer.m Diff File
mod - UI/MailPartViewers/UIxMailPartViewer.h Diff File
mod - UI/MailPartViewers/UIxMailPartViewer.m Diff File
mod - UI/MailPartViewers/UIxMailRenderingContext.m Diff File
mod - UI/MailerUI/UIxMailView.m Diff File
mod - UI/WebServerResources/js/Mailer/sgImageGallery.service.js Diff File
mod - configure Diff File

sogo: master 045f1343

2021-08-13 11:12:37

francis


Committer: GitHub Details Diff
feat(mail): initial support for ms-tnef (winmail.dat) body part

Fixes 0002242
Fixes 0004503
Affected Issues
0002242, 0004503
mod - SoObjects/Mailer/GNUmakefile Diff File
mod - SoObjects/Mailer/SOGoMailBodyPart.m Diff File
add - SoObjects/Mailer/SOGoTNEFMailBodyPart.h Diff File
add - SoObjects/Mailer/SOGoTNEFMailBodyPart.m Diff File
mod - SoObjects/Mailer/product.plist Diff File
mod - SoObjects/SOGo/GNUmakefile Diff File
add - SoObjects/SOGo/RTFHandler.h Diff File
add - SoObjects/SOGo/RTFHandler.m Diff File
mod - SoObjects/SOGo/SOGoDefaults.plist Diff File
mod - SoObjects/SOGo/SOGoSystemDefaults.h Diff File
mod - SoObjects/SOGo/SOGoSystemDefaults.m Diff File
add - Tests/Unit/Fixtures/bad_hex_and_cr.rtf Diff File
add - Tests/Unit/Fixtures/cyr_event_ru_editor.rtf Diff File
add - Tests/Unit/Fixtures/escapes.rtf Diff File
add - Tests/Unit/Fixtures/mini_russian.rtf Diff File
add - Tests/Unit/Fixtures/spanish_accents.rtf Diff File
add - Tests/Unit/Fixtures/zentyal_crash_2058.rtf Diff File
add - Tests/Unit/Fixtures/zentyal_crash_2089.rtf Diff File
add - Tests/Unit/Fixtures/zentyal_crash_6330.rtf Diff File
add - Tests/Unit/Fixtures/zentyal_crash_8346.rtf Diff File
mod - Tests/Unit/GNUmakefile Diff File
add - Tests/Unit/TestRTFHandler.m Diff File
mod - UI/MailPartViewers/GNUmakefile Diff File
mod - UI/MailPartViewers/GNUmakefile.preamble Diff File
add - UI/MailPartViewers/UIxMailPartTNEFViewer.h Diff File
add - UI/MailPartViewers/UIxMailPartTNEFViewer.m Diff File
mod - UI/MailPartViewers/UIxMailPartViewer.h Diff File
mod - UI/MailPartViewers/UIxMailPartViewer.m Diff File
mod - UI/MailPartViewers/UIxMailRenderingContext.m Diff File
mod - UI/MailerUI/UIxMailView.m Diff File
add - UI/Templates/MailPartViewers/UIxMailPartTnefViewer.wox Diff File
mod - UI/WebServerResources/js/Mailer/Message.service.js Diff File
mod - UI/WebServerResources/js/Mailer/sgImageGallery.service.js Diff File
mod - configure Diff File
mod - packaging/debian/control Diff File
mod - packaging/rhel/sogo.spec Diff File

Issue History

Date Modified Username Field Change
2018-07-04 01:44 peter.barlabas New Issue
2018-07-27 10:01 ASolana Note Added: 0012983
2018-07-27 12:07 francis Relationship added duplicate of 0002242
2021-02-24 10:03 ASolana Note Added: 0015102
2021-05-25 10:25 francis Changeset attached => sogo feature/ms-tnef f201cc18
2021-05-25 10:25 francis Assigned To => francis
2021-05-25 10:25 francis Resolution open => fixed
2021-06-01 16:31 francis Summary SOGo webmail attachment decoding error => SOGo webmail attachment decoding error (winmail.dat)
2021-08-04 13:34 francis Changeset attached => sogo feature/ms-tnef 171c1867
2021-08-13 11:12 francis Changeset attached => sogo master 045f1343
2021-09-03 14:00 francis Status new => resolved
2021-09-03 14:00 francis Resolution fixed => duplicate
2021-09-03 14:00 francis Fixed in Version => 5.2.0