View Issue Details

IDProjectCategoryView StatusLast Update
0004389SOGoWeb Mailpublic2018-04-13 09:42
ReporterOudiceval Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.10 
Fixed in Version4.0.1 
Summary0004389: Cannot paste base64 image
Description

We cannot paste base64-encoded images from clipboard to CKEditor (signature, message...).

Steps To Reproduce

Preferences > Mail > IMAP accounts > Edit > Signature
(or new message redaction window)

Open HTML file containing base64 image (see attachment).
Paste it into CKEditor.

=> Images are not pasted.

Additional Information

Firefox 57.
It works in Roundcube 1.1.2.

TagsNo tags attached.

Activities

Oudiceval

Oudiceval

2018-02-07 03:54

reporter  

base64.htm (1,438 bytes)   
<div class="signature" style="font-family: Helvetica, Arial, sans-serif; font-size:11pt; width:auto; margin-top:15px;"><div style="font-family: Helvetica, Arial, sans-serif; border: none; border-bottom: 2px solid #EAEAEA; color: #808080;"><div style="background-color:#F7F7F7; padding:0; max-width: 380px; border-top: 2px solid transparent; border-bottom: 2px solid transparent; border-left: 10px solid transparent; border-right: 10px solid transparent; font-size: 11pt; line-height: 1.5em;"><span style="color:#A80848; font-weight: bold;">Test</span></div> </div><div style="border-left: 10px solid transparent; line-height:1em;"><span style="color: #808080; font-size: 8pt;"><span style="border-right: 4px solid transparent;"><img align="left" width="20" height="16" alt="" style="color: #FFF;" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAQCAYAAAAWGF8bAAAAIGNIUk0AAG2YAABzjgAA+3UAAITUAAB6swAA/2cAADBbAAAQhVDPV6EAAAAJcEhZcwAACxEAAAsRAX9kX5EAAAAYdEVYdFNvZnR3YXJlAHBhaW50Lm5ldCA0LjAuNvyMY98AAADySURBVDhPYzD0qr9iHTnjPzkYpPf///8MyJgBm0JSMFkGOsbN/t815+D/NTsv/1+94/L/4o6tcDmSDbSLnvn/4o3nII1wsHTTebg8EJBmYBHQNTBw/8m7/wdO3vvfNG0fXB4ISDOwf8ERkCYw8ExdgCEPBKQZOGHhUZAmMLCLmYUhDwTEGVg7cff/Lfuv/79y+yVIExhsPXADLJbVuBGuDgiIM3D5losgxVhBcec2uDogIM7AiYuO/r9+99X/F28+gzSBwY17r8BiYQXL4OqAgDgDYZhqYQjDowZiyAMBqoFWkTPwFl/4DATpBQojGfifAQAH80Bh5sK4hwAAAABJRU5ErkJggg=="/></span></span></div></div><div style="height: 4px; clear: both;"><br></div>
base64.htm (1,438 bytes)   
francis

francis

2018-04-12 13:11

administrator   ~0012832

I can't reproduce the problem with v4.0.0 and Firefox 59.

You can confirm by testing our demo instance: http://demo.sogo.nu/SOGo/ (sogo1/sogo1)

Oudiceval

Oudiceval

2018-04-13 02:06

reporter   ~0012833

Francis, I can reproduce with 4.0.0 and Firefox 59 :(

  1. Open base64.htm (see above) with Firefox
  2. Select all and copy to clipboard
  3. Create a new message in SOGo
  4. Try to paste
    => Facebook logo is not pasted
francis

francis

2018-04-13 08:51

administrator   ~0012837

In CKEditor, click on the "source" button prior to pasting your HTML code.

Oudiceval

Oudiceval

2018-04-13 09:07

reporter   ~0012838

This workaround works in message redaction only.
The "source" button is not enabled for signatures (Preferences > Mail > IMAP accounts > Edit > Signature).

Related Changesets

sogo: master a4876798

2018-04-13 09:27:00

francis

Details Diff
Show 'Source' btn in HTML editor of signature

Fixes 0004389
Affected Issues
0004389
mod - UI/Templates/PreferencesUI/UIxAccountEditor.wox Diff File

Issue History

Date Modified Username Field Change
2018-02-07 03:54 Oudiceval New Issue
2018-02-07 03:54 Oudiceval File Added: base64.htm
2018-04-12 13:11 francis Note Added: 0012832
2018-04-13 02:06 Oudiceval Note Added: 0012833
2018-04-13 08:51 francis Note Added: 0012837
2018-04-13 09:07 Oudiceval Note Added: 0012838
2018-04-13 09:42 francis Changeset attached => sogo master a4876798
2018-04-13 09:42 francis Assigned To => francis
2018-04-13 09:42 francis Resolution open => fixed
2018-04-13 09:42 francis Status new => resolved
2018-04-13 09:42 francis Fixed in Version => 4.0.1