View Issue Details

IDProjectCategoryView StatusLast Update
0004377SOGoBackend Address Bookpublic2020-01-06 13:49
Reporterpschichtel Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Versionnightly master 
Fixed in Version4.3.0 
Summary0004377: Unable to create contact books or calenders after 9-table migration
Description

After I migrated my SOGo database (MySQL 5.7) to the new combined table scheme, SOGo was unable to create new contact books and calenders.
Reading and modifying entries in existing contact books and calenders works fine, adding new entries as well.

When I try to create a new ocntact book or calender the backend returns with an HTTP 400 response and the following text:

An error occurred during object publishing
The new folder could not be created

I suspect the problem to be related to the INSERT statement contructed here: https://github.com/inverse-inc/sogo/blob/master/SOPE/GDLContentStore/GCSFolderManager.m#L914

Steps To Reproduce
  1. Migrate sogo mysql db to combined scheme
  2. create new calender/contact book
TagsNo tags attached.

Activities

ludovic

ludovic

2018-02-05 10:28

administrator   ~0012560

Last edited: 2018-02-05 10:28

View 2 revisions

That's been fixed.

pschichtel

pschichtel

2018-02-05 11:51

reporter   ~0012561

I have not seen any related commit since I tried to do this. Can you tell me how this has been fixed?

jfranken

jfranken

2019-12-29 11:34

reporter   ~0014011

I had this problem too, after migration to the compact database scheme.
In my case, it helped to convert the type of field sogo_folder_info.c_location from INT to VARCHAR:
ALTER TABLE sogo_folder_info CHANGE c_location c_location varchar(255) COLLATE 'utf16_german2_ci' NULL AFTER c_foldername;

Jacek

Jacek

2020-01-02 10:21

reporter   ~0014013

Looks like something I reported here: https://sogo.nu/bugs/view.php?id=4888

Related Changesets

sogo: master ba1757fd

2020-01-06 13:43:40

francis

Details Diff
chore: fix MySQL migration script to 9-table schema

Fix datatype of sogo_folder_info.c_location.

Fixes 0004377
Fixes 0004888
Affected Issues
0004377, 0004888
mod - Scripts/sql-update-3.0.0-to-combined-mysql.sh Diff File

Issue History

Date Modified Username Field Change
2018-01-25 18:57 pschichtel New Issue
2018-02-05 10:28 ludovic Note Added: 0012560
2018-02-05 10:28 ludovic Status new => resolved
2018-02-05 10:28 ludovic Resolution open => fixed
2018-02-05 10:28 ludovic Assigned To => ludovic
2018-02-05 10:28 ludovic Note Edited: 0012560 View Revisions
2018-02-05 11:51 pschichtel Note Added: 0012561
2018-02-05 11:51 pschichtel Status resolved => feedback
2018-02-05 11:51 pschichtel Resolution fixed => reopened
2019-12-29 11:34 jfranken Note Added: 0014011
2020-01-02 10:21 Jacek Note Added: 0014013
2020-01-06 13:48 francis Changeset attached => sogo master ba1757fd
2020-01-06 13:48 francis Assigned To ludovic => francis
2020-01-06 13:48 francis Resolution reopened => fixed
2020-01-06 13:49 francis Status feedback => resolved
2020-01-06 13:49 francis Fixed in Version => 4.3.0