View Issue Details

IDProjectCategoryView StatusLast Update
0004323SOGoBackend Generalpublic2018-03-06 09:32
ReporterMarcel Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly master 
Fixed in Version4.0.0 
Summary0004323: sql-update-3.0.0-to-combined.sh does not handle URLs without port
Description

Having URLs such as "postgresql://sogo:sogo@localhost/mail/sogo_folder_info" in /etc/sogo/sogo.conf will cause sql-update-3.0.0-to-combined.sh to abort with "ERROR: Failed to parse value of OCSFolderInfoURL in /etc/sogo/sogo.conf".

There is no indication that this is due to the missing port number, i.e., the database URLs need to be in the form "postgresql://sogo:sogo@localhost:5432/mail/sogo_folder_info".

Please do change the RegExp to include this case as well or update the error message.

Additional Information

Also, the RegExp will probably not handle numeric IPv6 addresses ("[::1]") in the URL.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master 141af57e

2017-10-24 15:11:41

francis

Details Diff
Make db port optional in update script

Fixes 0004323
Affected Issues
0004323
mod - Scripts/sql-update-3.0.0-to-combined.sh Diff File

sogo: master fe75cb39

2017-10-24 15:14:20

francis

Details Diff
Make db port optional in update script

Fixes 0004323
Affected Issues
0004323
mod - Scripts/sql-update-3.0.0-to-combined-mysql.sh Diff File

Issue History

Date Modified Username Field Change
2017-10-24 12:52 Marcel New Issue
2017-10-24 15:12 francis Changeset attached => sogo master 141af57e
2017-10-24 15:12 francis Assigned To => francis
2017-10-24 15:12 francis Resolution open => fixed
2017-10-24 15:14 francis Changeset attached => sogo master fe75cb39
2018-03-06 09:32 ludovic Status new => resolved
2018-03-06 09:32 ludovic Fixed in Version => 4.0.0