View Issue Details

IDProjectCategoryView StatusLast Update
0004262SOGoWeb Mailpublic2017-08-25 11:48
Reporterppjet Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSArchLinux 
Product Version3.2.10 
Fixed in Version4.0.0 
Summary0004262: Html entities escaped twice in links on web mail
Description

I got a report from a user that a link was broken when reading his email with sogo.

Steps To Reproduce
  • someone sends you an email containing a link, with the latter consisting of properly escaped reserved symbol(s). Something like:
    <a href="...&..."

  • as you open the email with Sogo Web Client, the & will be escaped again
    <a href="...&amp;..."

  • the browser will correctly revert one of these leaving the user with
    <a href="...&..."

Which depending on the website may or may not do the right thing.

Additional Information

Note: Not 100% sure if there isn't anything else in the email that would trigger the bug. I experienced it by:

  • open my gmail account, go to myaccount.google.com -> personal info -> emails -> alternate emails -> add email
  • open the verification email from the web client and observe the issue
TagsNo tags attached.

Relationships

duplicate of 0004242 resolvedfrancis Links with & replaced with & 

Activities

ppjet

ppjet

2017-08-25 11:36

reporter   ~0012236

Last edited: 2017-08-25 11:40

View 3 revisions

Hmm, the bug tracker actually ate my entities..

Here is the original text, maybe somebody can edit the issue meaningfully somehow?
https://bpaste.net/show/cd6c87872ca7

ppjet

ppjet

2017-08-25 11:37

reporter   ~0012237

Last edited: 2017-08-25 11:38

View 2 revisions

Browsers versions being used:

chromium: 60.0.3112.90-1
firefox: 54.0.1-1

Issue History

Date Modified Username Field Change
2017-08-25 11:31 ppjet New Issue
2017-08-25 11:36 ppjet Note Added: 0012236
2017-08-25 11:37 ppjet Note Added: 0012237
2017-08-25 11:38 ppjet Note Edited: 0012237 View Revisions
2017-08-25 11:39 ppjet Note Edited: 0012236 View Revisions
2017-08-25 11:40 ppjet Note Edited: 0012236 View Revisions
2017-08-25 11:48 francis Relationship added duplicate of 0004242
2017-08-25 11:48 francis Status new => resolved
2017-08-25 11:48 francis Fixed in Version => 4.0.0
2017-08-25 11:48 francis Resolution open => fixed
2017-08-25 11:48 francis Assigned To => francis