View Issue Details

IDProjectCategoryView StatusLast Update
0004237SOGoWeb Calendarpublic2017-11-14 06:32
ReporterMathias Roland Assigned Toludovic  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.21 
Summary0004237: yearly repeating events are not shown in web calendar
Description

Events with a yearly repeating rule, e.g. birthdays, are not shown in web calendar in SOGO 2.3.22.

In Thunderbird and other CalDAV clients these events are shown.

Additional Information

BEGIN:VCALENDAR
PRODID:-//Inverse inc./SOGo 2.3.22//EN
VERSION:2.0
BEGIN:VEVENT
UID:1D5D-59785280-1F-2F5D01C0
SUMMARY:Test
CLASS:PUBLIC
CREATED:20170726T082747Z
DTSTAMP:20170726T082747Z
LAST-MODIFIED:20170726T082747Z
RRULE:FREQ=YEARLY
DTSTART;VALUE=DATE:20170726
DTEND;VALUE=DATE:20170727
TRANSP:OPAQUE
END:VEVENT
END:VCALENDAR

TagsNo tags attached.

Relationships

has duplicate 0004325 resolvedfrancis Yearly day event not shown in web gui 

Activities

francis

francis

2017-07-26 06:30

administrator   ~0012126

Can you reproduce the problem on the demo instance? ( http://sogo-demo.inverse.ca/SOGo/ )

Mathias Roland

Mathias Roland

2017-07-26 06:54

reporter   ~0012127

On the demo instance these events are shown.

Mathias Roland

Mathias Roland

2017-07-27 04:46

reporter   ~0012129

Is a fix available or already in the nightly builds?

ludovic

ludovic

2017-07-27 05:59

administrator   ~0012130

Show your list of installed SOGo/SOPE/GNUstep packages.

Mathias Roland

Mathias Roland

2017-07-27 06:38

reporter   ~0012131

Last edited: 2017-07-27 06:40

View 2 revisions

The problem exists on both nodes:

Node1:

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 9.1 (stretch)
Release: 9.1
Codename: stretch

uname -a
Linux node1 4.9.0-3-amd64 0000001 SMP Debian 4.9.30-2+deb9u2 (2017-06-26) x86_64 GNU/Linux

dpkg-query -W *sogo* *sope* *wbxml* *gnustep*
gnustep-base-common 1.24.9-3.1
gnustep-base-doc
gnustep-base-runtime 1.24.9-3.1
gnustep-common 2.6.8-2.1
gnustep-fslayout-fhs
gnustep-make 2.6.8-2.1
gnustep-make-doc
libgnustep-base1.24 1.24.9-3.1
libsope-appserver4.9 4.9.r1664.20170720
libsope-core4.9 4.9.r1664.20170720
libsope-gdl1-4.9 4.9.r1664.20170720
libsope-ldap4.9 4.9.r1664.20170720
libsope-mime4.9 4.9.r1664.20170720
libsope-xml4.9 4.9.r1664.20170720
libwbxml2
libwbxml2-0 0.11.5-1
sogo 2.3.22-1
sogo-activesync 2.3.22-1
sope-libxmlsaxdriver
sope-stxsaxdriver
sope4.9-appserver 4.9.r1664.20170720
sope4.9-db-connector
sope4.9-gdl1-mysql 4.9.r1664.20170720
sope4.9-gdl1-postgresql 4.9.r1664.20170720
sope4.9-libxmlsaxdriver 4.9.r1664.20170720
sope4.9-stxsaxdriver 4.9.r1664.20170720

Node 2:

lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 8.9 (jessie)
Release: 8.9
Codename: jessie

uname -a
Linux node2 3.16.0-4-amd64 0000001 SMP Debian 3.16.43-2+deb8u2 (2017-06-26) x86_64 GNU/Linux

dpkg-query -W *sogo* *sope* *wbxml* *gnustep*
gnustep-base-common 1.24.7-1
gnustep-base-doc
gnustep-base-runtime 1.24.7-1
gnustep-common 2.6.6-3
gnustep-fslayout-fhs
gnustep-make 2.6.6-3
gnustep-make-doc
libgnustep-base1.24 1.24.7-1
libsope-appserver4.9 4.9.r1664.20170720
libsope-core4.9 4.9.r1664.20170720
libsope-gdl1-4.9 4.9.r1664.20170720
libsope-ldap4.9 4.9.r1664.20170720
libsope-mime4.9 4.9.r1664.20170720
libsope-xml4.9 4.9.r1664.20170720
libwbxml2
libwbxml2-0 0.11.5-1
sogo:amd64 2.3.22-1
sogo-activesync 2.3.22-1
sope-libxmlsaxdriver
sope-stxsaxdriver
sope4.9-appserver 4.9.r1664.20170720
sope4.9-db-connector
sope4.9-gdl1-mysql 4.9.r1664.20170720
sope4.9-gdl1-postgresql 4.9.r1664.20170720
sope4.9-libxmlsaxdriver 4.9.r1664.20170720
sope4.9-stxsaxdriver 4.9.r1664.20170720

Mathias Roland

Mathias Roland

2017-07-28 08:28

reporter   ~0012133

On the demo instance these events are no longer shown.

francis

francis

2017-07-28 08:43

administrator   ~0012134

All data is removed every day on the demo instance.

Mathias Roland

Mathias Roland

2017-07-28 08:48

reporter   ~0012135

I added a new event today.

francis

francis

2017-07-28 08:54

administrator   ~0012136

I can't reproduce this problem.

Mathias Roland

Mathias Roland

2017-07-28 09:48

reporter   ~0012137

The nightly from 2017-07-28 on Debian stretch is also broken.

Mathias Roland

Mathias Roland

2017-07-31 04:50

reporter   ~0012142

I installed sogo (2.3.22-1) and sogo-nightly (2.3.22.20170731-1) each in a fresh Debian 9 VM.

I added an all day event, which was shown on top of the day.

Then I changed the event and added a repeating rule and the event was no longer shown.

I was able to reproduce this problem with Firefox, IE and Chrome under Linux and Windows. All browser had no extension installed.

ludovic

ludovic

2017-08-11 13:43

administrator   ~0012167

Asked privately for access to test system.

Also, show your sogo.conf.

Mathias Roland

Mathias Roland

2017-08-15 04:34

reporter   ~0012170

The fixes are working and solving the problem.

Related Changesets

sogo: v2 e1791ac8

2017-08-14 13:59:16

ludovic

Details Diff
(fix) offset can be negative (fixes 0004237) Affected Issues
0004237
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File

sogo: master 66685d9f

2017-08-14 13:59:16

ludovic

Details Diff
(fix) offset can be negative (fixes 0004237) Affected Issues
0004237
mod - SoObjects/Appointments/SOGoAppointmentFolder.m Diff File

Issue History

Date Modified Username Field Change
2017-07-26 04:42 Mathias Roland New Issue
2017-07-26 06:30 francis Note Added: 0012126
2017-07-26 06:54 Mathias Roland Note Added: 0012127
2017-07-27 04:46 Mathias Roland Note Added: 0012129
2017-07-27 05:59 ludovic Note Added: 0012130
2017-07-27 06:38 Mathias Roland Note Added: 0012131
2017-07-27 06:40 Mathias Roland Note Edited: 0012131 View Revisions
2017-07-28 08:28 Mathias Roland Note Added: 0012133
2017-07-28 08:43 francis Note Added: 0012134
2017-07-28 08:48 Mathias Roland Note Added: 0012135
2017-07-28 08:54 francis Note Added: 0012136
2017-07-28 09:48 Mathias Roland Note Added: 0012137
2017-07-31 04:50 Mathias Roland Note Added: 0012142
2017-08-11 13:43 ludovic Severity major => minor
2017-08-11 13:43 ludovic Note Added: 0012167
2017-08-14 14:02 ludovic Changeset attached => sogo v2 e1791ac8
2017-08-14 14:02 ludovic Assigned To => ludovic
2017-08-14 14:02 ludovic Resolution open => fixed
2017-08-14 14:03 ludovic Changeset attached => sogo master 66685d9f
2017-08-15 04:34 Mathias Roland Note Added: 0012170
2017-08-15 09:18 ludovic Status new => resolved
2017-11-14 06:32 francis Relationship added has duplicate 0004325