View Issue Details

IDProjectCategoryView StatusLast Update
0004200SOGoWeb Preferencespublic2017-06-18 12:55
Reporterpoly Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.9 
Fixed in Version3.2.10 
Summary0004200: Can't create a specific filter in Webinterface
Description

Even after filling all blanks out, the OK-Button does not get activated.
If you have the "match all messages" rule selected.

Steps To Reproduce
  1. start to create a filters
  2. after the form pops up, in rules select "match all messages"
  3. add a condition
  4. now you can not click OK to save the changes

Complete configuration is shown in my image.

Additional Information

I found a work around for my problem. I can create filters now, but for the specific configuration, like in my image, I need to do the following:

  1. define a rule with a condition
  2. add a condition
  3. select the rule without any conditions(all messages), then OK gets activated
  4. add actions

Now I can press OK and activate the filter.
But this is still a strange behaviour, it looks like it is checking if there are any conditions even if there are not needed.

This is also related to mailcow: https://github.com/mailcow/mailcow-dockerized/issues/348

Tagsconfiguration, sogo

Activities

poly

poly

2017-06-16 05:59

reporter  

Screenshot_20170611_140340.png (67,250 bytes)   
Screenshot_20170611_140340.png (67,250 bytes)   

Related Changesets

sogo: master 6c654e0f

2017-06-16 16:35:20

francis

Details Diff
(js) Fix validation in Sieve filter editor

Fixes 0004200
Affected Issues
0004200
mod - UI/WebServerResources/js/Preferences/FiltersDialogController.js Diff File

Issue History

Date Modified Username Field Change
2017-06-16 05:59 poly New Issue
2017-06-16 05:59 poly File Added: Screenshot_20170611_140340.png
2017-06-16 06:01 poly Tag Attached: configuration
2017-06-16 06:01 poly Tag Attached: sogo
2017-06-16 16:55 francis Changeset attached => sogo master 6c654e0f
2017-06-16 16:55 francis Assigned To => francis
2017-06-16 16:55 francis Resolution open => fixed
2017-06-18 12:55 francis Status new => resolved
2017-06-18 12:55 francis Fixed in Version => 3.2.10