View Issue Details

IDProjectCategoryView StatusLast Update
0004179SOGosogo-toolpublic2017-05-30 14:45
ReporterMarcel Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version14.04 LTS
Product Versionnightly master 
Fixed in Version3.2.10 
Summary0004179: "sogo-tool dump-defaults" crashes
Description

[I'm actually running on 16.04, but this is not offered]

Running "sogo-tool dump-defaults" results in the following error, no other output

sogo-tool: Uncaught exception NSInvalidArgumentException, reason: [NSPropertyListSerialization +dataWithPropertyList:format:options:error:]: nil property list

Additional Information

This happens since I upgraded from 14.04 to 16.04 (and updated the nightly as well). So the nightly version from a few weeks ago ran correctly on 14.04.

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

sogo: master 9dae52a7

2017-05-30 14:44:43

ludovic

Details Diff
(fix) sanity check when no defaults are found (fixes 0004179) Affected Issues
0004179
mod - Tools/SOGoToolDumpDefaults.m Diff File

sogo: v2 bbac4662

2017-05-30 14:44:43

ludovic

Details Diff
(fix) sanity check when no defaults are found (fixes 0004179) Affected Issues
0004179
mod - Tools/SOGoToolDumpDefaults.m Diff File

Issue History

Date Modified Username Field Change
2017-05-26 03:34 Marcel New Issue
2017-05-30 14:45 ludovic Changeset attached => sogo master 9dae52a7
2017-05-30 14:45 ludovic Assigned To => ludovic
2017-05-30 14:45 ludovic Resolution open => fixed
2017-05-30 14:45 ludovic Changeset attached => sogo v2 bbac4662
2017-05-30 14:45 ludovic Status new => resolved
2017-05-30 14:45 ludovic Fixed in Version => 3.2.10