View Issue Details

IDProjectCategoryView StatusLast Update
0004172SOGoBackend Generalpublic2017-05-30 13:21
Reportercaldave Assigned Toludovic  
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04
Product Version3.2.9 
Fixed in Version3.2.10 
Summary0004172: CardDAV contacts mangled
Description

In the web interface and Thunderbird, my CardDAV contacts look great. Using both Android solutions (DavDroid and CardDAV-Sync), the ends of every field have the lowercase r letter appended. It's very annoying, and I have no idea how it's happening.

Steps To Reproduce

Install 3.2.9 from source
Export contacts from thunderbird as LDIF
Import contacts to SOGo through the web interface
Connect to the server with the /dav/ path in DavDroid
Look at the contacts - r's everywhere.

TagsNo tags attached.

Activities

caldave

caldave

2017-05-21 14:44

reporter  

Screenshot_20170521-143348.png (48,338 bytes)   
Screenshot_20170521-143348.png (48,338 bytes)   
caldave

caldave

2017-05-21 14:45

reporter  

Capture.PNG (72,716 bytes)   
Capture.PNG (72,716 bytes)   
caldave

caldave

2017-05-28 13:43

reporter   ~0011837

It looks like the problem is that the import process doesn't strip carriage returns:

                   |     1495087665 |     1495087665 |         0 |      NULL |

| 1679-591D3A00-FD-6CF72200 | BEGIN:VCARD
UID:1679-591D3A00-FD-6CF72200
VERSION:3.0
CLASS:PUBLIC
PROFILE:VCARD
PRODID:-//Inverse inc./SOGo 3.2.9//EN
N:BarBaz\r;Foo\r
FN:Foo BarBaz\r
EMAIL;TYPE=work:foobarbaz@gmail.com\r
EMAIL;TYPE=home:foobar@gmail.com\r
END:VCARD

I'm going to fix this manually with a sql query, but it should really be patched such that these don't break everything on import.

caldave

caldave

2017-05-28 14:05

reporter   ~0011838

Fixed with this query:

UPDATE sogomanatee00218549758_quick SET c_content = replace(c_content,'\r','');

Related Changesets

sogo: master 29dfc75f

2017-05-30 13:15:04

ludovic

Details Diff
(fix) remove any trailing cr (fixes 0004172) Affected Issues
0004172
mod - UI/Contacts/UIxContactFolderActions.m Diff File

sogo: v2 7cc3ff2f

2017-05-30 13:15:04

ludovic

Details Diff
(fix) remove any trailing cr (fixes 0004172) Affected Issues
0004172
mod - UI/Contacts/UIxContactFolderActions.m Diff File

Issue History

Date Modified Username Field Change
2017-05-21 14:44 caldave New Issue
2017-05-21 14:44 caldave File Added: Screenshot_20170521-143348.png
2017-05-21 14:45 caldave File Added: Capture.PNG
2017-05-28 13:43 caldave Note Added: 0011837
2017-05-28 14:05 caldave Note Added: 0011838
2017-05-30 12:52 ludovic Relationship added duplicate of 0004100
2017-05-30 12:52 ludovic Status new => resolved
2017-05-30 12:52 ludovic Resolution open => fixed
2017-05-30 12:52 ludovic Assigned To => ludovic
2017-05-30 12:53 ludovic Severity major => minor
2017-05-30 12:53 ludovic Resolution fixed => open
2017-05-30 12:53 ludovic Relationship deleted 0004100
2017-05-30 13:15 ludovic Changeset attached => sogo master 29dfc75f
2017-05-30 13:15 ludovic Resolution open => fixed
2017-05-30 13:16 ludovic Changeset attached => sogo v2 7cc3ff2f
2017-05-30 13:21 ludovic Status resolved => closed
2017-05-30 13:21 ludovic Fixed in Version => 3.2.10